Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 23, 2013, 01:43 AM   #1
iBlink
macrumors newbie
 
Join Date: Apr 2003
Location: CANADA
WebDAV Apache2 Syntax Error

Lion Server 10.7.5 Mac Mini

After trying every "solution" I could find on the internet to get WebDAV working, I finally came across a post that fixed it...kind of.

http://www.macsupportguy.com/viewtop...31574&p=137825

This post points out that the /etc/apache2/httpd_webdavsharing_sharepoints.conf file, which is autogenerated by the WebDAV process has a syntax error. This was confirmed in my system.log, which stated there was a syntax error on line 18.

There were " " missing around the RewriteRule entry. As soon as I added the quotes and saved the file I was able to use WebDAV from the connect to server option on my mac (https://mydomain.com/webdav). Awesome.

Here is my problem. As soon as the File Sharing service is turned off and on, it either rewrites the file or deletes my changes to the file and makes logging into the server with WebDAV fail at login again. It prompts me for credentials and then says there was a problem connecting to the server. rebooting the server keeps my changes, it just removes them when bouncing the File Sharing service.

I need to know how to make these changes stick or if the file is being recreated, how do I tell Apache2 to add the quotes?

I have also ditched the file and allowed it to recreate and the same error is present.
iBlink is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Any apps that can connect via WebDAV on one server and copy to WebDAV on another? blueroom iPad Apps 2 Mar 22, 2014 12:29 AM
Syntax Error - help please! :( Brradley Mac Programming 3 May 7, 2013 05:52 PM
WebDAV 10.8.3 testowo Mac OS X Server, Xserve, and Networking 0 May 1, 2013 02:12 PM
I have an encoding syntax error that crashes an app with with NSString hanuman99 iPhone/iPad Programming 4 Feb 3, 2013 12:47 PM
Apache2 Error when PC is restart bwan37 Mac OS X Server, Xserve, and Networking 2 Oct 15, 2012 03:46 AM

Forum Jump

All times are GMT -5. The time now is 08:07 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC