Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 30, 2009, 10:57 AM   #1
mrtekkid
macrumors regular
 
Join Date: Sep 2006
Missing Fonts in Snow Leopard...??

Hey, I am hoping that someone can help me out with this current issue that I have run into after installing Snow Leopard on my machine. It is really the first complaint I have since I put the OS in on the 28th and I am just having time to sit down and toy around with it and I discovered this issue.

When I was playing around in a few Adobe applications, specifically Flash, it warned me when opening a project that I was missing a few fonts form the project and that they would be substituted. Going into my font Library I looked for the fonts that it said were missing and confirmed that they STILL EXISTED in the folder. After double checking, I realized that a lot of my fonts were missing from the application.

After opening Word 2008, I noticed that a lot of my fonts missing from Word as well. I shut down Word and tried rebuilding the Font Cache by dragging the Word font cache file out to the desktop but Word did not rebuild it's font menu with the missing fonts.

Here's where it gets interesting. When opening an Apple application like Mail, all of my fonts that are present in the font folder show up. This is INCLUDING all of the fonts that are missing in Adobe and Word. Opening a program like Adium also shows that all of the fonts are there.

Is there any reasoning behind this?? How can I go about attempting to fix this issue? How do I get Word and Adobe to identify ALL of my fonts in my font folder? I did not have this issue with Leopard.

Suggestions are welcome.

I am going to try to boot into 32-bit Snow Leopard and see if that fixes the issue or not in case part of the issue is with Adobe and Word running in 64-bit. If that solves the issue, I will just run in 32-bit if it gives me my fonts back.
mrtekkid is offline   0 Reply With Quote
Old Aug 30, 2009, 11:17 AM   #2
mrtekkid
Thread Starter
macrumors regular
 
Join Date: Sep 2006
All of my fonts are installed in Library > Fonts so that they are accessible to other users on the system. Booting into 32-bit mode did not resolve the issue. Going to create a new user account and see if I can get the fonts to be identified through a new account.

Will update this post with my findings.

EDIT: Creating a new user account did not solve the issue.

Last edited by mrtekkid; Aug 30, 2009 at 11:40 AM. Reason: Update
mrtekkid is offline   0 Reply With Quote
Old Aug 30, 2009, 02:15 PM   #3
coreytree
macrumors newbie
 
Join Date: Aug 2009
I'm having the same prob in Motion

The font I do not see in Motion, but do see elsewhere, is a Postscript type 1 font. I'm running SL in 32 bit.

Last edited by coreytree; Aug 30, 2009 at 02:16 PM. Reason: elaborating
coreytree is offline   0 Reply With Quote
Old Aug 31, 2009, 11:07 PM   #4
phjellming
macrumors newbie
 
Join Date: Aug 2009
Solution?

This worked for me, hopefully it will for you too. Go to Font Book, you should see that you have some fonts duplicated, hit Cmd+A to select all and then click Edit > Resolve Duplicates and then either restart or log out and log back in again. That got all of my fonts back into Photoshop, Word, etc.
phjellming is offline   0 Reply With Quote
Old Sep 3, 2009, 08:08 PM   #5
mrtekkid
Thread Starter
macrumors regular
 
Join Date: Sep 2006
Just another update.... I have semi-solved the issue. Clearing out duplicates did not help though there was a small amount of them in there....

I made aliases of the fonts in my /Library/Fonts folder and moved them into the /Library/Application Support/Adobe/Fonts folder. This made the fonts visible in Photoshop, Illustrator and InDesign. The one application that needs it and still isn't giving it to me is Flash. I am going to try to reset Adobe's font cache and hope that it resets it again and puts the fonts in Flash and doesn't remove it from everything else. I haven't gotten them to work in Word yet either....
mrtekkid is offline   0 Reply With Quote
Old Sep 11, 2009, 03:45 PM   #6
katambe
macrumors newbie
 
Join Date: Sep 2009
i have the same issue. Even when updated the SL with the 10.6.1. the same thing appens. I have Times New Roman instaled, but strangely in flash cs4 and word 2008 it doesn't appear in the font list. I've updated the full ADobe cs4 package, and i dont know what to do now. any ideas??? thanks!
katambe is offline   0 Reply With Quote
Old Sep 19, 2009, 11:57 AM   #7
PurpleLaser
macrumors newbie
 
Join Date: Sep 2009
Same Problem in both Flash and Same Dialogs

I have the problem on a MacMini (with upgraded firmware, 10.6.1, and Flash 10, and removed duplicates)

My other iMac works fine
Any more hints?
PurpleLaser is offline   0 Reply With Quote
Old Mar 29, 2010, 06:19 PM   #8
iflyer
macrumors newbie
 
Join Date: Oct 2009
Font prob

Anyone try to do a permissions and ACL repair from the Snow Leopard disc, thus resetting home folder permissions (which it could be using for fonts instead of system)? The permissions for Mail are updated/replaced when the OS updates but possibly not these user/non Apple apps. Also I would consider renaming the .plist file for flash with the .old in the preferences and seeing if, when SL regenerates the file the prob is solved.
iflyer is offline   0 Reply With Quote
Old Jul 9, 2010, 12:49 PM   #9
TeckniX
macrumors newbie
 
Join Date: Nov 2009
Bringing this thread back up - I had everything working correctly until I upgraded to Snow Leopard - Now none of my user fonts are showing up!!

I tried to remove/reinstall the fonts with no luck. I also tried to simply create a new font library which didn't help either.

Any help would be greatly appreciated as all of those fonts are crucial!
TeckniX is offline   0 Reply With Quote
Old Oct 7, 2010, 06:18 AM   #10
KlausOstberg
macrumors newbie
 
Join Date: Oct 2010
Solution that helped me

You will need the application "Onyx" (http://www.titanium.free.fr)
Login as administrator.
Start application Onyx.
Choose "Cleaning" from toolbar.
Choose the "Font"-tab of the cleaning panel.
Set checkmark "Microsoft program".
Press the button in the lower right corner to execute your cleaning.
Restart your computer.
If you are lucky, all your installed fonts should be available in Words 2008.
KlausOstberg is offline   1 Reply With Quote
Old Jan 9, 2012, 07:50 AM   #11
Tailspin45
macrumors newbie
 
Join Date: Jan 2012
Quote:
Originally Posted by KlausOstberg View Post
You will need the application "Onyx" (http://www.titanium.free.fr)
Yup worked for me. Apple's Pages had all fonts, but Microsoft Word and Adobe Photoshop did not. Ran Onyx font cleaning with system/user, Microsoft and Adobe checked, restarted, and there they were!
Tailspin45 is offline   0 Reply With Quote
Old Jan 23, 2013, 01:05 PM   #12
Seahawksean
macrumors newbie
 
Join Date: Jan 2013
Quote:
Originally Posted by KlausOstberg View Post
You will need the application "Onyx" (http://www.titanium.free.fr)
Login as administrator.
Start application Onyx.
Choose "Cleaning" from toolbar.
Choose the "Font"-tab of the cleaning panel.
Set checkmark "Microsoft program".
Press the button in the lower right corner to execute your cleaning.
Restart your computer.
If you are lucky, all your installed fonts should be available in Words 2008.
Thank you KlausOstberg!!! (Post #10) Your suggestion fixed my problem of fonts having disappeared from Illustrator CS4 on my Mac after upgrading to Snow Leopard.
Seahawksean is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Pages/Numbers Missing Fonts danqi Mac Applications and Mac App Store 0 Feb 16, 2014 05:46 AM
iPhoto library missing after Snow Leopard>Mountain Lion upgrade on Mac Pro? NEENAHBOY Mac Applications and Mac App Store 2 Oct 31, 2013 04:56 PM
Serious problem with fonts in Snow Leopard - can't use most fonts... Soom Mac Basics and Help 5 Jul 3, 2013 06:41 PM
Missing Fonts rauckr OS X 10.8 Mountain Lion 0 Sep 19, 2012 02:28 PM
New MacBook Pro Retina missing Fonts - Please help! Pared3s MacBook Pro 4 Jun 16, 2012 10:33 PM

Forum Jump

All times are GMT -5. The time now is 09:08 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC