Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 2, 2012, 05:10 PM   #1
Pietje
macrumors newbie
 
Join Date: Mar 2012
Stop Mail prompting at startup

Hi there,

I am sure this isn't a coincidence. Since I recently added calendars of our internet mail accounts to iCal, the Mail app on my snow leopard macbook pro is prompting for access to those mail accounts. This is really annoying because we do not use mail from those accounts and logically do not need to use Mail either.

Does anybody know how to stop this?
For the record:
- we do not even try to open Mail, it does of its own accord after startup.
- once in that prompted window, options like "preferences" are not accessible.
- for the reason above and any other, the option for us is to choose "cancel". But this option hangs the app and force quit is needed in the end, unless I quit iCal before canceling Mail.

Thank you,
Pietje

Last edited by Pietje; Mar 2, 2012 at 05:21 PM.
Pietje is offline   0 Reply With Quote
Old Mar 2, 2012, 05:28 PM   #2
Zarkizon
macrumors member
 
Join Date: Sep 2011
Quote:
Originally Posted by Pietje View Post
Hi there,

I am sure this isn't a coincidence. Since I recently added calendars of our internet mail accounts to iCal, the Mail app on my snow leopard macbook pro is prompting for access to those mail accounts. This is really annoying because we do not use mail from those accounts and logically do not need to use Mail either.

Does anybody know how to stop this?
For the record:
- we do not even try to open Mail, it does of its own accord after startup.
- once in that prompted window, options like "preferences" are not accessible.
- for the reason above and any other, the option for us is to choose "cancel". But this option hangs the app and force quit is needed in the end, unless I quit iCal before canceling Mail.

Thank you,
Pietje
Right-click the Mail icon in the Dock and hover the cursor over 'Options' then uncheck 'Open at Login'.
__________________
Apple Feedback
Zarkizon is offline   0 Reply With Quote
Old Mar 9, 2012, 02:13 AM   #3
Pietje
Thread Starter
macrumors newbie
 
Join Date: Mar 2012
Thank you Zarkizon. The option "Open at Login" was already unchecked, so I checked and unchecked the option, just to give it a go. The problem appeared to be solved but it seems it doesn't (and didn't) accur at every startup.

I read a lot about this prompting issue when the mac doesn't get a connection with the internet. Could that be the problem?

Anyway, I still believe there is a connection between iCal and Mail and I'd like it to be undone or at least Mail not to activate on it's own. Anyone?
Pietje is offline   0 Reply With Quote
Old Mar 9, 2012, 08:28 AM   #4
BrianBaughn
macrumors 68000
 
Join Date: Feb 2011
Location: Baltimore, Maryland
The checkbox in Login Items is for hiding the application and not for keeping it from starting up at login.

To remove it from Login Items you must select it then delete it by clicking the box below the list with the minus sign.

Also, there is an new setting in Lion (in General, I believe) that, when your start up your computer, restarts all of your apps that were open when you shut down or restarted. It is annoying that it is ON by default on a new system.

And yes, when an app that's looking for internet access gets started before internet access is achieved you will sometimes get an error message or alert.
__________________
Brian Baughn
Baughn Consulting
Baltimore, MD
BrianBaughn is offline   0 Reply With Quote
Old Mar 15, 2012, 05:11 PM   #5
Pietje
Thread Starter
macrumors newbie
 
Join Date: Mar 2012
Thank you for your reply.

Mail is not in 'Login items' because I never wanted to use Mail at the first place and not in startup feature of Lion because I still have Snow leopard

Could anybody tell me if I may be able to switch off any settings that could be the origin of the problem in the Mail app once I made an account? I simply do not want to take the risk.

Thank you
Pietje is offline   0 Reply With Quote
Old Mar 15, 2012, 05:21 PM   #6
samh
macrumors 6502
 
Join Date: Oct 2009
Quote:
Originally Posted by Pietje View Post
Thank you for your reply.

Mail is not in 'Login items' because I never wanted to use Mail at the first place and not in startup feature of Lion because I still have Snow leopard

Could anybody tell me if I may be able to switch off any settings that could be the origin of the problem in the Mail app once I made an account? I simply do not want to take the risk.

Thank you
Have you gone into Preferences => Mail, Contacts & Calendars and unchecked "mail" for the accounts you only want Calendar access to?
samh is offline   0 Reply With Quote
Old Mar 15, 2012, 05:52 PM   #7
BrianBaughn
macrumors 68000
 
Join Date: Feb 2011
Location: Baltimore, Maryland
I think your trouble might be from iCal trying to send event reminders, which it does through Mail. Turn off email reminders for all present, past and future events.
__________________
Brian Baughn
Baughn Consulting
Baltimore, MD
BrianBaughn is offline   0 Reply With Quote
Old Mar 16, 2012, 06:52 AM   #8
samh
macrumors 6502
 
Join Date: Oct 2009
Quote:
Originally Posted by BrianBaughn View Post
I think your trouble might be from iCal trying to send event reminders, which it does through Mail. Turn off email reminders for all present, past and future events.
Oh yeah, that could be it, too.
samh is offline   0 Reply With Quote
Old Mar 16, 2012, 08:20 AM   #9
Cohomojo
macrumors newbie
 
Join Date: Jan 2010
BTW, I'm experiencieng the exact same problems. Wonder if it is iCal that is causing the problem? So am I supposed to uncheck the "enable this account" under General/Account Information....???
Cohomojo is offline   0 Reply With Quote
Old Mar 16, 2012, 05:21 PM   #10
Pietje
Thread Starter
macrumors newbie
 
Join Date: Mar 2012
Work around

Quote:
Originally Posted by samh View Post
Have you gone into Preferences => Mail, Contacts & Calendars and unchecked "mail" for the accounts you only want Calendar access to?
I cannot find this checkboxes in iCal. Should it be in the preferences of the Mail app?
The biggest problem (and bug if you ask me) is that I cannot access any option of Mail except the one called "cancel" followed by the "force quit" one.


Quote:
Originally Posted by BrianBaughn View Post
I think your trouble might be from iCal trying to send event reminders, which it does through Mail. Turn off email reminders for all present, past and future events.
I tested this and it looks like Mail is prompting at exact the time I set the mail-alarms on. It still doesn't explain the prompting at startups the moment iCal wasn't opened yet.
So, if I stay away of the alarm I should be okay. Although it is taking away this really annoying problem, I get a new one in return "no possible use of calendar alarms". But this is good enough for me as most of the alarms are pop-ups anyway. I really thank you all and especially for helping me out: BrianBaughn.

Weird that "cancel" is not enough to quit Mail in this situation and the only way has to be "force quit".

ciao,
Pietje

erratums:
1. the prompting didn't occur right after startup only
2.
Quote:
Originally Posted by Pietje
...choose "cancel". But this option hangs the app and force quit is needed in the end, unless I quit iCal before canceling Mail.
It just seemed like that at that moment but in the end this is not true: it doesn't really matter if I quit iCal first.

Last edited by Pietje; Mar 16, 2012 at 05:39 PM. Reason: multiple quotes
Pietje is offline   0 Reply With Quote
Old Jan 28, 2013, 03:25 PM   #11
3000ways
macrumors newbie
 
Join Date: Apr 2010
Quote:
Originally Posted by BrianBaughn View Post
I think your trouble might be from iCal trying to send event reminders, which it does through Mail. Turn off email reminders for all present, past and future events.
I think you may be right. I'm having the same problem. whenever the mail app opens there is a reminder email that is waiting to be sent (from iCal), but do you have any idea as to how I can turn off these reminders without going to every single calendar event?

----------

Quote:
Originally Posted by samh View Post
Have you gone into Preferences => Mail, Contacts & Calendars and unchecked "mail" for the accounts you only want Calendar access to?
I think you may be referring to an iphone or an ipad (iOS) and the original question was referring to a mac running OSx.
3000ways is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
How to stop Dropbox from starting on startup tiredof MacBook Pro 10 Jul 25, 2014 09:27 AM
Mac Mail keeps prompting for password stringtheorist Mac Basics and Help 12 May 21, 2013 01:36 AM
How does one effectively stop mail spam (real mail, not e-mail)? someguy Community Discussion 9 Dec 31, 2012 01:15 AM
Stop sparrow storing all mail QuickFlame Mac Applications and Mac App Store 2 Dec 17, 2012 10:10 AM
Anyway to stop the mail app from checking mail when first opened? 2jzgze iOS 5 and earlier 3 Jun 9, 2012 08:16 AM

Forum Jump

All times are GMT -5. The time now is 06:28 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC