Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 5, 2012, 03:20 PM   #1
blackboxxx
macrumors member
 
Join Date: Sep 2008
iCloud Mobile Documents on Windows

As you all probably know, "Documents & Data" checkbox appears to be missing from Windows version of iCloud control panel, which kind of makes sense, because iCloud document syncing is exclusive to iOS and Mac App Store apps.
However, all necessary components for this feature are there, including ubd.exe (Ubiquity daemon), so turning this feature on is a matter of tweaking a couple of plist files:

%AppData%\Apple Computer\Preferences\com.apple.ubd.plist
kUBSyncEnabledKey = true

%AppData%\Apple Computer\Preferences\MobileMeAccounts.plist
• Accounts[0]:Services[where ServiceID="com.apple.Dataclass.Ubiquity"]:Enabled = true

Here's how to do this:
  1. Open Command Prompt and execute the following commands (right-click to paste into Command Prompt window):
    Code:
    path %PATH%;%CommonProgramFiles%\Apple\Apple Application Support
    defaults write com.apple.ubd kUBSyncEnabledKey -bool true
    plutil -convert xml1 "%AppData%\Apple Computer\Preferences\MobileMeAccounts.plist"
    write "%AppData%\Apple Computer\Preferences\MobileMeAccounts.plist"
  2. In WordPad window that opens, scroll to the end of the file, find the section that looks like the following and add the bolded lines (note that the url might be different — there's no need to change it):
    Code:
    ...
    <dict>
        <key>Enabled</key>
        <true/>
        <key>Name</key>
        <string>Mobille Documents</string>
        <key>ServiceID</key>
        <string>com.apple.Dataclass.Ubiquity</string>
        <key>apsEnv</key>
        <string>production</string>
        <key>authMechanism</key>
        <string>token</string>
        <key>url</key>
        <string>https://p02-ubiquity.icloud.com:443</string>
    </dict>
    ...
  3. Save the file and close WordPad
  4. This step isn't strictly necessary, but it will return the plist to its original format: return to the Command Prompt window and execute:
    Code:
    plutil -convert binary1 "%AppData%\Apple Computer\Preferences\MobileMeAccounts.plist"
  5. Log out (from Windows, not iCloud) and log back in
  6. If you did everything correctly, there should be a new folder "Mobile Documents" under %AppData%\Apple Computer (for example, C:\Users\Username\AppData\Roaming\Apple Computer\Mobile Documents)

So now you can access all your files stored in iCloud from Windows. To make access to the Mobile Documents folder easier, you can create a shortcut on the desktop or drag it to the sidebar. Everything seems to work exactly the same way as on the Mac side, even the well-known undocumented feature: any files dropped into Mobile Documents folder are synced to all your devices, just like Dropbox does, so you can use this feature to sync files between a Mac and a PC, or between OS X and Boot Camp on the same machine. It even recognizes your other devices on the same network and transfers files between them locally to save bandwidth.

Warning: this feature is probably not user-accessible for a reason, and most likely it hasn't received the same amount of testing as the Mac version, so don't blame me for any bugs or crashes, or if all your documents stored in iCloud suddenly vaporize. Also note that if you log out of iCloud control panel or change any settings you'll have to repeat the above steps to enable Mobile Documents again.
__________________
about 6 stickers with  on them

Last edited by blackboxxx; Sep 10, 2012 at 11:06 PM. Reason: Corrected spelling of the preference key
blackboxxx is offline   1 Reply With Quote
Old Jun 16, 2012, 05:03 PM   #2
LastMinuteMike
macrumors member
 
Join Date: Jun 2012
Thanks!

Great tip man! Have been wanting for such a long time, thanks a million!

Now let's just hope Apple makes a official and prettier solution.
LastMinuteMike is offline   0 Reply With Quote
Old Jun 17, 2012, 08:50 PM   #3
queyomismosoy
macrumors newbie
 
Join Date: Jun 2012
It did not work

Hi, i really want to be able to sinc to icloud directly from windows, but i did what you said many times and it did not work. The mobile documents folder is never there.

I have win 7, does it work with windows seven or is there something else wrong???
queyomismosoy is offline   0 Reply With Quote
Old Jun 17, 2012, 11:08 PM   #4
blackboxxx
Thread Starter
macrumors member
 
Join Date: Sep 2008
It definitely works on Win7, I tested on a fresh install.
__________________
about 6 stickers with  on them
blackboxxx is offline   1 Reply With Quote
Old Jun 18, 2012, 07:40 AM   #5
queyomismosoy
macrumors newbie
 
Join Date: Jun 2012
Quote:
Originally Posted by blackboxxx View Post
It definitely works on Win7, I tested on a fresh install.
Why would you think t doesnt work for me. I did exactly as you said and log off windows and nothing, any. Any ideas please????

I really need this, thank, up front.
queyomismosoy is offline   0 Reply With Quote
Old Jun 18, 2012, 11:12 AM   #6
yahgoo
macrumors newbie
 
Join Date: Jun 2012
Mobile Documents Folder Missing

Quote:
Originally Posted by blackboxxx View Post
It definitely works on Win7, I tested on a fresh install.
@Blackboxxx, My macbook is too old to be upgraded to Lion. So I was ecstatic when i stumbled upon your solution which is my only option to run iCloud on XP. I followed all the steps that you have provided on Win XP. I even installed iCloudXP.msi. But, the "Mobile Documents" folder is missing. Should i create this folder manually? I confirmed from XP task manager that ubd is running.

Please help.
yahgoo is offline   0 Reply With Quote
Old Jun 18, 2012, 01:03 PM   #7
queyomismosoy
macrumors newbie
 
Join Date: Jun 2012
Quote:
Originally Posted by yahgoo View Post
@Blackboxxx, My macbook is too old to be upgraded to Lion. So I was ecstatic when i stumbled upon your solution which is my only option to run iCloud on XP. I followed all the steps that you have provided on Win XP. I even installed iCloudXP.msi. But, the "Mobile Documents" folder is missing. Should i create this folder manually? I confirmed from XP task manager that ubd is running.

Please help.
I tried creating the folder, it didnt work either.

Anyone help please!!!!
queyomismosoy is offline   0 Reply With Quote
Old Jun 18, 2012, 11:33 PM   #8
blackboxxx
Thread Starter
macrumors member
 
Join Date: Sep 2008
yahgoo, iCloud is not supported on XP... only on Vista and 7.
__________________
about 6 stickers with  on them
blackboxxx is offline   0 Reply With Quote
Old Jun 19, 2012, 03:36 AM   #9
yahgoo
macrumors newbie
 
Join Date: Jun 2012
@Blackboxxx, iCl

----------

@Blackboxxx, iCloud does work on XP. See http://clarinerd.com/blog/software/icloud-for-xp/
Am I missing something? Do I need a MobileMe account in order to get it working?
yahgoo is offline   0 Reply With Quote
Old Jun 19, 2012, 10:05 AM   #10
blackboxxx
Thread Starter
macrumors member
 
Join Date: Sep 2008
Ok, now I see that it's possible to install iCloud on XP by modifying the msi file. But note that the commands I posted use environment variables (such as %AppData%) that might work differently on XP, so try to substitute the full path (e.g., "C:\Documents and Settings\<Username>\Application Data").
Also, killing all iCloud-related processes before modifying the plist files might be a good idea.
Ubd.exe running by itself is not an indication that mobile documents are enabled, because it runs on startup by default.
__________________
about 6 stickers with  on them
blackboxxx is offline   0 Reply With Quote
Old Jun 19, 2012, 11:15 AM   #11
queyomismosoy
macrumors newbie
 
Join Date: Jun 2012
Quote:
Originally Posted by blackboxxx View Post
Ok, now I see that it's possible to install iCloud on XP by modifying the msi file. But note that the commands I posted use environment variables (such as %AppData%) that might work differently on XP, so try to substitute the full path (e.g., "C:\Documents and Settings\<Username>\Application Data").
Also, killing all iCloud-related processes before modifying the plist files might be a good idea.
Ubd.exe running by itself is not an indication that mobile documents are enabled, because it runs on startup by default.


i could use a little help too, i am using win 7 32 bit, and there is just no way the mobile documents folder come out, i even try what you said here and killed with task manager ubd.exe and all the processes related to it, an did the procedure then log off anb back but still nothing. Any ideas please!!!!!
queyomismosoy is offline   0 Reply With Quote
Old Jun 19, 2012, 03:09 PM   #12
blackboxxx
Thread Starter
macrumors member
 
Join Date: Sep 2008
queyomismosoy, do you have iCloud control panel 1.1 installed and are you signed into it with your apple id?
__________________
about 6 stickers with  on them
blackboxxx is offline   0 Reply With Quote
Old Jun 19, 2012, 04:02 PM   #13
queyomismosoy
macrumors newbie
 
Join Date: Jun 2012
Quote:
Originally Posted by blackboxxx View Post
queyomismosoy, do you have iCloud control panel 1.1 installed and are you signed into it with your apple id?
Yes of course i have icloud panel control and alwas sign in.
queyomismosoy is offline   0 Reply With Quote
Old Jun 20, 2012, 12:56 AM   #14
queyomismosoy
macrumors newbie
 
Join Date: Jun 2012
Quote:
Originally Posted by queyomismosoy View Post
Yes of course i have icloud panel control and alwas sign in.
So i guess i wont have mobile documents in win after all?
queyomismosoy is offline   0 Reply With Quote
Old Jun 20, 2012, 09:14 PM   #15
queyomismosoy
macrumors newbie
 
Join Date: Jun 2012
Quote:
Originally Posted by queyomismosoy View Post
So i guess i wont have mobile documents in win after all?
it seems this web page is just about rumors after all and not real facts.
queyomismosoy is offline   0 Reply With Quote
Old Jul 29, 2012, 02:31 PM   #16
Junkdumpster
macrumors newbie
 
Join Date: Mar 2012
I see there hasn't been a response in a small while, but have any of you Windows users who aren't seeing the file solved this? I stumbled upon this post and was disappointed to find it isn't working for me.

I'm having the same problem. I've tried following all the suggestions and still don't see the folder. I'm running Windows 7 32-bit.
Junkdumpster is offline   0 Reply With Quote
Old Sep 10, 2012, 02:16 PM   #17
AntiCat
macrumors newbie
 
Join Date: Sep 2012
spelling mistake?

it definitly works on windows 7
there seems however to be a spelling mistake in the Guide. I had to add the following lines to the com.apple.ubd:
Code:
<key>kUBSyncEnabledKey</key>
<true/>
AntiCat is offline   1 Reply With Quote
Old Sep 10, 2012, 11:08 PM   #18
blackboxxx
Thread Starter
macrumors member
 
Join Date: Sep 2008
Thanks for spotting my mistake, AntiCat. I've updated the instructions.
__________________
about 6 stickers with  on them
blackboxxx is offline   0 Reply With Quote
Old Sep 20, 2012, 02:17 PM   #19
Eurisko69
macrumors newbie
 
Join Date: Jan 2009
Quote:
Originally Posted by blackboxxx View Post
Thanks for spotting my mistake, AntiCat. I've updated the instructions.
Can anyone confirm if this works on the new iCloud 2.0 Control Panel for Windows that came out with IOS 6?
Eurisko69 is offline   0 Reply With Quote
Old Sep 21, 2012, 07:39 AM   #20
blackboxxx
Thread Starter
macrumors member
 
Join Date: Sep 2008
It no longer works with iCloud 2.0 because the Ubiquity daemon (ubd.exe) has been removed. Somebody at Apple must have seen this thread.

So if you need this feature, you can stay on version 1.1 and it should continue syncing with iOS 6 just fine — the only significant addition in version 2.0 is support of shared photo streams.

If someone wants to experiment further, it might be possible to transplant ubd.exe and missing dll's from previous version, but this will likely require more effort than it's worth.
__________________
about 6 stickers with  on them

Last edited by blackboxxx; Sep 21, 2012 at 07:51 AM.
blackboxxx is offline   0 Reply With Quote
Old Sep 27, 2012, 03:54 PM   #21
nickjf20
macrumors member
 
Join Date: Jan 2009
Installed iCloud 1.1, followed the instructions after finding the directory manually (First command doesn't return the correct path change for me Win 7 x64)

Everything seemed to go OK, but no MobileDocuments folder for me
__________________
PowerMac G5 --> ATX Conversion
http://bit.ly/QkKkzb
MBP 2010 i7 -- PowerBook G4 Titanium
nickjf20 is offline   0 Reply With Quote
Old Nov 9, 2012, 09:22 AM   #22
BrunoPCosta
macrumors newbie
 
Join Date: Nov 2012
When I open the "MobileMe Accounts.plist" (in WordPad window), I can't find any section that looks like the one that you put on step 2.

The only part of the text that refers to "MOBILE DOCUMENTS" is this:

"SCDTUVWVapsEnv_com.apple.Dataclass.BookmarksYBookmarksZproduction_Bcom.apple.Dataclass.Bookmarks:45 EACD77-2018-B849-8FE2-DF8215F26814_$https://p04-bookmarks.icloud.com:443Y;!=P>?
\DU]^_WEnabled _com.apple.Dataclass.MediaStream\Photo Stream_Dcom.apple.Dataclass.MediaStream:405E4610-ECE8-584C-B725-594524948D5A_"https://p04-streams.icloud.com:443!=P?aDUbc_com.apple.Dataclass.Ubiquity_#https://p04-ubiquity.icloud.com:443_Mobille Documents ViCloud"

This part is near the end of the document.
After that comes a series of characters that don't appear in the text of the forum.

I am using iCloud 1.1.

Help me.
BrunoPCosta is offline   0 Reply With Quote
Old Nov 10, 2012, 04:49 AM   #23
blackboxxx
Thread Starter
macrumors member
 
Join Date: Sep 2008
It looks like you didn't convert that file from binary into XML plist format (that's what 'plutil -convert xml1 ...' does).
__________________
about 6 stickers with  on them
blackboxxx is offline   0 Reply With Quote
Old Jan 31, 2013, 01:19 AM   #24
afunsten
macrumors newbie
 
Join Date: Feb 2008
change dir first

first

cd "C:\Program Files (x86)\Common Files\Apple\Apple Application Support"


and make sure you leave a new line between true and plutil
afunsten is offline   0 Reply With Quote
Old Jun 3, 2013, 08:19 AM   #25
Tom Houben
macrumors newbie
 
Join Date: Jun 2013
It does not work!

Hi everybody, somehow it does not work on my win 7 PC.
I have icloud 1.1 installed.
When I open command and I paste the first line nothing happens as you can see below:

Microsoft(R) Windows DOS
(C)Copyright Microsoft Corp 1990-2001.

C:\USERS\TOMHOU~1>path %PATH%;%CommonProgramFiles%\Apple\Apple Application Suppo
rt
Too many parameters

C:\USERS\TOMHOU~1>defaults write com.apple.ubd kUBSyncEnabledKey -bool true
DEFAULTS is not recognized as an internal
or external command, operable program or batch file.

C:\USERS\TOMHOU~1>uter\Preferences\MobileMeAccounts.plist"
The system can not find the specified path.

C:\USERS\TOMHOU~1>

what do I wrong???? please help!
Tom Houben is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
How can I view iCloud upload speed on my mac in the Mobile Documents folder? KTK1990 iCloud and Apple Services 2 Apr 21, 2014 02:55 PM
iWork for iCloud: Saving Shared Documents into iCloud JPM42 Mac Applications and Mac App Store 3 Oct 27, 2013 06:45 AM
Open iCloud Documents goes to Documents on Mac Julien OS X Mavericks (10.9) 9 Jul 7, 2013 11:21 PM
iCloud "Mobile Documents" Folder - Able to Share Files? bedifferent OS X Mavericks (10.9) 2 Jun 27, 2013 05:58 PM
iCloud Reliability for Documents Traverse iCloud and Apple Services 1 Mar 17, 2013 05:03 AM

Forum Jump

All times are GMT -5. The time now is 01:58 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC