Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 29, 2013, 03:11 PM   #1
Phill-art
macrumors newbie
 
Join Date: Jan 2013
Can't turn off Sleep Schedule on Macbook Pro!

I've tried trashing the com.apple.PowerManagement.plist and the com.apple.AutoWake.plist and restarting the computer right after, multiple times. Yet it still brings up a message that says something like 'This computer is scheduled to sleep at 8:40 and will go to sleep in 10 minutes if nothing is done'. I have NO schedule for it to sleep!!! And it's always around 8:40 pm, sometimes it's a few minutes after or before that time (so I can't even set up a counter wake up schedule for it because the time varies).

When it goes to sleep, it disconnects me from a game I'm playing (that takes up the whole screen and can't be minimized) and it pisses me off. Please help!!!!
Phill-art is offline   0 Reply With Quote
Old Jan 29, 2013, 03:33 PM   #2
GGJstudios
macrumors Westmere
 
Join Date: May 2008
Quote:
Originally Posted by Phill-art View Post
I've tried trashing the com.apple.PowerManagement.plist and the com.apple.AutoWake.plist and restarting the computer right after, multiple times. Yet it still brings up a message that says something like 'This computer is scheduled to sleep at 8:40 and will go to sleep in 10 minutes if nothing is done'.
You mention deleting .plist files, but you didn't specifically say if you tried the normal route of going to System Preferences > Energy Saver > Schedule and unchecking the boxes there.

Caffeine will temporarily override your energy saver settings and keep your Mac awake with a click on the Menu Bar icon. Another click turns it off.

To keep your Mac notebook awake with the lid closed, use InsomniaX or InsomniaT (rebuild for SL) (fix for 2011 MPBs)

NoSleep also keeps your Mac notebook awake when you close the lid.
GGJstudios is offline   0 Reply With Quote
Old Jan 29, 2013, 04:10 PM   #3
Phill-art
Thread Starter
macrumors newbie
 
Join Date: Jan 2013
Thanks for the links, I'll try them. As for the boxes being unchecked, they definitely are. : /
Phill-art is offline   0 Reply With Quote
Old Feb 1, 2013, 07:52 PM   #4
Phill-art
Thread Starter
macrumors newbie
 
Join Date: Jan 2013
Quote:
Originally Posted by GGJstudios View Post
You mention deleting .plist files, but you didn't specifically say if you tried the normal route of going to System Preferences > Energy Saver > Schedule and unchecking the boxes there.

Caffeine will temporarily override your energy saver settings and keep your Mac awake with a click on the Menu Bar icon. Another click turns it off.

To keep your Mac notebook awake with the lid closed, use InsomniaX or InsomniaT (rebuild for SL) (fix for 2011 MPBs)

NoSleep also keeps your Mac notebook awake when you close the lid.
I had Caffeine running, and the sleep schedule message still popped up! I Also tried activating Caffeine after the message popped up, to see if it would counter it. Didn't work.

I read somewhere this could have something to do with the logic board of the computer... Am I mistaken? If so, is this a hardware problem and something that can't be fixed without taking it to Apple?
Phill-art is offline   0 Reply With Quote
Old Feb 2, 2013, 01:05 PM   #5
chown33
macrumors 603
 
Join Date: Aug 2009
Quote:
Originally Posted by Phill-art View Post
I read somewhere this could have something to do with the logic board of the computer... Am I mistaken? If so, is this a hardware problem and something that can't be fixed without taking it to Apple?
It may be broken hardware. Unless you're handy with electronics, repairs should be done by Apple, or certified tech.

Did you run the Hardware Test?
http://support.apple.com/kb/HT1509

Did you try a Safe Boot?
http://support.apple.com/kb/HT1564

If a faulty extension or driver is triggering the sleep, then Safe Boot should prevent it from happening. Restarting in Normal Mode (i.e. not Safe Mode) would allow the scheduling again, if you took no steps to identify or remove the faulty driver. That is, Safe Boot is a diagnostic tool, not a repair tool.
chown33 is offline   0 Reply With Quote
Old May 7, 2013, 10:11 PM   #6
Phill-art
Thread Starter
macrumors newbie
 
Join Date: Jan 2013
I tried running a normal and extended hardware test. There were NO found issues. Booting it in safemode wouldn't do me any good because of its limitations.

Is there anyone in the mac world that has any idea what the heck is going on? So now my computer has been wanting to go to sleep around 10:00pm, just tonight it was closer to 11:00pm. And it's not everyday it does this....
Phill-art is offline   0 Reply With Quote
Old Mar 4, 2014, 09:05 AM   #7
Duffie
macrumors newbie
 
Join Date: Mar 2014
Turn off Sleep Schedule on Macbook Pro

Hi Phill-art, any solution to this problem? I have the same, on a brand new MBP running Mavericks, after a clean install. Diagnostics returned no problem.
Duffie is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:00 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC