Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 2, 2013, 06:51 PM   #1
slapple
macrumors 6502
 
Join Date: Jul 2008
Cannot install latest ATI Catalyst driver in W7 on MBP

I have a 2011 MBP with the ATI Radeon HD 6770M. I have Boot Camp installed with Windows 7 64-bit.

Up until today, I was just using the latest Boot Camp drivers, which include an ATI Radeon driver dated 1/4/2011. But then I got a couple of BSODs in Windows 7 while just browsing with Firefox. The crashes were seemingly related to the video drivers, so I thought I should update to the latest ATI Catalyst drivers.

I went to the ATI web site, and it told me to download the AMD Mobility Radeon Driver Verification Tool. I installed that, and it said: "Your computer does not contain a proper graphics adapter."

Seems like some people have seen that message before, and others have suggested to just download the latest drivers and install them. So I downloaded this and installed it: http://www2.ati.com/drivers/13-1_vis...d_ccc_whql.exe

The installation seemed to go well, but then even after rebooting, Device Manager said the ATI Radeon HD 6770M driver was dated 1/4/2011. So the driver never got updated. I uninstalled that driver, then re-ran the ATI Catalyst installation program, and it still installed the 1/4/2011 driver.

Why can't I get the latest driver installed?

EDIT:

After spending a few hours uninstalling and reinstalling video drivers and then doing a repair on my Boot Camp drivers, I finally got the latest Catalyst drivers installed and working. You need the mobility version which you can download from http://www.guru3d.com/files_get/amd_...ownload,3.html

Last edited by slapple; Feb 3, 2013 at 01:37 AM. Reason: got it working
slapple is offline   1 Reply With Quote
Old Apr 12, 2013, 09:08 AM   #2
MaximizedAction
macrumors newbie
 
Join Date: Sep 2012
Awesome! The update worked perfectly without any bsods thus far.

Thank you so much!
MaximizedAction is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:02 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC