Go Back   MacRumors Forums > Apple Hardware > Mac Peripherals

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 1, 2013, 12:33 PM   #1
itsamacthing
macrumors 6502
 
Join Date: Sep 2011
OWC Guardian Maximus USB 3 issues

Just a heads up: bought one 6 months ago with the plan to use it on USB 3 with my new imac. Plugged it into my USB 3 port today and it crashed my MBAir. After many frustrating hours, OWC blamed it on Apple..and the tech was rude and aggressive with me. Like its my fault! I've dealt with tech support from many companies, but this is the second time an OWC tech support person has gotten aggressive and rude. The last time was when my OWC 6G SSD was bad...again, this is my fault and I should be yelled at.

Well, the good news is that the Guardian Maximus is fixable via a firmware update... Bad news is that the tech from OWC with a bad attitude can not be fixed. I'm done doing business with them and don't know why they get so many awards. I have had nothing but problems.
itsamacthing is offline   1 Reply With Quote
Old Feb 1, 2013, 02:47 PM   #2
g4cube
macrumors 6502a
 
Join Date: Apr 2003
How could it be Apple's fault when there are so many USB 3.0 products that seem to work quite well with the new Macs with USB 3.0?

You are correct, there is no excuse for the support rep to say this, and to be so unhelpful. Especially when there actually is a solution!
g4cube is offline   0 Reply With Quote
Old Feb 1, 2013, 05:52 PM   #3
cosmicjoke
macrumors 6502
 
Join Date: Oct 2011
Location: Portland, OR
Quote:
Originally Posted by itsamacthing View Post
Just a heads up: bought one 6 months ago with the plan to use it on USB 3 with my new imac. Plugged it into my USB 3 port today and it crashed my MBAir. After many frustrating hours, OWC blamed it on Apple..and the tech was rude and aggressive with me. Like its my fault! I've dealt with tech support from many companies, but this is the second time an OWC tech support person has gotten aggressive and rude. The last time was when my OWC 6G SSD was bad...again, this is my fault and I should be yelled at.

Well, the good news is that the Guardian Maximus is fixable via a firmware update... Bad news is that the tech from OWC with a bad attitude can not be fixed. I'm done doing business with them and don't know why they get so many awards. I have had nothing but problems.
The MBA kernel panicked? Did it do it instantly when plugging it in or during a file transfer or while idling? Whose firmware update? Apple needs to release one? Just curious.
cosmicjoke is offline   0 Reply With Quote
Old Feb 1, 2013, 08:15 PM   #4
jterp7
macrumors 6502a
 
Join Date: Oct 2011
Quote:
Originally Posted by itsamacthing View Post
Just a heads up: bought one 6 months ago with the plan to use it on USB 3 with my new imac. Plugged it into my USB 3 port today and it crashed my MBAir. After many frustrating hours, OWC blamed it on Apple..and the tech was rude and aggressive with me. Like its my fault! I've dealt with tech support from many companies, but this is the second time an OWC tech support person has gotten aggressive and rude. The last time was when my OWC 6G SSD was bad...again, this is my fault and I should be yelled at.

Well, the good news is that the Guardian Maximus is fixable via a firmware update... Bad news is that the tech from OWC with a bad attitude can not be fixed. I'm done doing business with them and don't know why they get so many awards. I have had nothing but problems.
heh nothing like bad publicity, i'll keep your story in mind next time i consider making a purchase from them. Almost did a few months ago.
__________________
27" Thunderbolt display
2012 rMBP base
2011 13" MBA base
iPhone 5S
jterp7 is offline   0 Reply With Quote
Old Feb 1, 2013, 08:28 PM   #5
itsamacthing
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Quote:
Originally Posted by g4cube View Post
How could it be Apple's fault when there are so many USB 3.0 products that seem to work quite well with the new Macs with USB 3.0?

You are correct, there is no excuse for the support rep to say this, and to be so unhelpful. Especially when there actually is a solution!
That's just it, I have older USB 3 devices that work just fine with my MBA ... He had nothing but excuses. "Apple is using a unique USB 3 driver" "Apple just released their first USB 3 device in June".

What a load, they had the same Apple excuses when my over priced 6G OWC SSD failed to perform as advertised. Must be apple's fault, and the Blackmagic speed test is not accurate!

----------

Quote:
Originally Posted by cosmicjoke View Post
The MBA kernel panicked? Did it do it instantly when plugging it in or during a file transfer or while idling? Whose firmware update? Apple needs to release one? Just curious.
My imac is still shipping, but when I plugged it into the USB2 on my mini, no issues. But plug it into USB3, and it will kernel panic your machine to death. It's OWC firmware...will update today and then update you all
itsamacthing is offline   0 Reply With Quote
Old Feb 1, 2013, 08:40 PM   #6
itsamacthing
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Another thing, the device has a toggle inside to set RAID level. It support 0,1,JBOD, and Independent. Yet, the support rep says he can only talk to me about 1, the chip supports the rest ... But "OWC" did not design the rest of the device to support 0,JBOD, or independent. What a load!

My experience with OWC is that they have a big attitude about their products, and that nothing could ever go or be wrong with them. It's always someone else's fault. It would be nice if they just take responsibility and provided attitude free support.

No doubt, I'll be avoiding them in the future. I'll never use their SSDs again. It took them a year, replacement, and 3 firmware updates before their 6G SSD was stable in my 2011 Mini. It was my work computer ... The coming back to my desk to find a frozen or crashed system was costly.
itsamacthing is offline   0 Reply With Quote
Old Feb 2, 2013, 11:48 AM   #7
itsamacthing
Thread Starter
macrumors 6502
 
Join Date: Sep 2011
Update

Finally got my Guardian Maximus updated to the correct firmware and it's performing nicely over USB3. r/w 140 in Raid 1, and r/w 180 in Raid 0. Using WD Red drives.
itsamacthing is offline   0 Reply With Quote
Old Feb 3, 2013, 05:22 PM   #8
Skeli
macrumors newbie
 
Join Date: May 2009
Any chance you can post a link to the firmware update? I've been looking and can't find it anywhere..
Skeli is offline   0 Reply With Quote
Old Feb 9, 2013, 05:07 PM   #9
a.m.c.
macrumors newbie
 
Join Date: Feb 2013
Thanks for the helpful information.

I'm considering purchasing this enclosure, but was hesitant about the ability to change RAID modes. I've read enough forum posts and reviews stating the hardware RAID-1 is unstable and fails fairly consistently, which makes me want to have the option of creating a software RAID-1 or use the enclosure as a RAID-0.

My machine doesn't have USB 3.0 yet, but I'm looking forward to using it when I upgrade.

Where did you obtain the Firmware Updates?

Cheers,
A.
a.m.c. is offline   0 Reply With Quote
Old Oct 24, 2013, 01:47 PM   #10
nuno1959
macrumors member
 
Join Date: Oct 2009
installing Guardian Maximus USB 3.0 firmware….

hi guys

talk about reviving an old thread ! :-b but fact is i'm having the exact same USB 3 troubles w/ my G-Max & i have never installed a firmware before - at least using Crossover

can anyone here explain to me how to go about it ? i would hate to do something g wrong & funk up my enclosures or worse, my data !!

many thanks

oh by the way, someone asked for a link to the firmware, here it is :

http://home2.owc.net/~tech/OWC/Firmw...it%20only).zip

got it just now from OWC, hope that helps

cheers guys
nuno1959 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Mac Peripherals

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Formatting Newertech Guardian Maximus JBOD? pjny Buying Tips and Advice 1 Apr 22, 2013 07:51 AM
Newer Tech Guardian Maximus - Faster on eSata or USB3? eyepea Mac Peripherals 1 Apr 2, 2013 11:39 AM
help regarding Guardian Maximus Raid enclosure macchiato2009 Mac Peripherals 0 Feb 20, 2013 06:11 PM
Guardian Maximus HD setup Deftony99 Mac Peripherals 1 Feb 11, 2013 02:01 PM
Newertech Guardian Maximus fan noise macchiato2009 Mac Peripherals 0 Sep 24, 2012 01:54 PM

Forum Jump

All times are GMT -5. The time now is 12:22 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC