Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 2, 2006, 09:25 PM   #1
mklos
macrumors 68000
 
mklos's Avatar
 
Join Date: Dec 2002
Location: My house!
Send a message via AIM to mklos
17" iMac G4 no video...

My dad's 1 GHz iMac G4 screen doesn't seem to work anymore. It was fine yesterday and has been running fine before this happened.

Here's a list of things I've tried:

1. Reset PRAM

2. Reset PMU

3. Took it apart and reseat the video cable and inspected it.

4. Took back cover off display and reseated that end of the signal cable.

5. Tried booting from an OS X.4 Installer DVD

Nothing worked!

It DOES provide video to an external display. So to me, that rules out a bad logic board. Also, the computer runs fine, just no video. It boots right into OS X just as if the display was working. Like I said, I hooked up a 17" CRT display and it works just fine there.

So what do you guys/gals think? I'm thinking its either the display or the LCD inverter board. I can get an LCD display on eBay for $200. I can get the inverter for $80. Any other suggestions?

Thanks!
__________________
2.66 GHz Quad-Core Mac Pro (Nehlem)
24" LED Cinema
Aluminum MacBook
2.0 GHz Core 2 Duo
16GB iPhone 3GS
mklos is offline   0 Reply With Quote
Old Nov 3, 2006, 09:35 PM   #2
mklos
Thread Starter
macrumors 68000
 
mklos's Avatar
 
Join Date: Dec 2002
Location: My house!
Send a message via AIM to mklos
Ok, I think I narrowed it down to a bad LCD inverter. The screen is actually working, but its VERY dim. If you put a flash light up to it, you can actually see what's on the screen. 99.9% of the time a new LCD inverter will fix that issue as the inverter provides power to the backlight. So if its bad, no power is going to the backlight, making it very dim.

I just bought one from www.welovemacs.com. We'll see in a few days if it fixes the issue. I'm fairly confident it will.
__________________
2.66 GHz Quad-Core Mac Pro (Nehlem)
24" LED Cinema
Aluminum MacBook
2.0 GHz Core 2 Duo
16GB iPhone 3GS
mklos is offline   0 Reply With Quote
Old Feb 3, 2013, 09:21 PM   #3
vrodion
macrumors newbie
 
Join Date: May 2012
Location: Canada
No Video

Hi, I have the same problem with my IMac.
Did you fix it ? is it inverter board?
Please let me know
vrodion is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
iMac G4 Advice MBP13 Buying Tips and Advice 10 May 5, 2011 02:49 AM
iMac G4 flat panel 17" USB2.0 no video txlonghorn82 Mac Basics and Help 0 Feb 4, 2011 10:52 AM
iMac G4 Upgrade Question Cuba46 iMac 3 Feb 2, 2011 02:01 PM
Turning iMac G4 into a multimedia center and automation themacguy12 iMac 1 Dec 16, 2010 05:23 PM


All times are GMT -5. The time now is 09:17 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC