Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 10, 2013, 04:12 AM   #1
DRF
macrumors newbie
 
Join Date: Jun 2012
Location: Germany
Solution Win7 Bootcamp problem "Setup was unable to create a new system partition..."

Hello!
I just got my iMac late 2012 and tried to install my Windows 7 Professional 64 Bit via Bootcamp. I have an external blu ray writer and an external hdd attached.

1) Created iso file from the Windows DVD (use disk utility to create a cdr file and just rename it to iso)
2) bootcamp assistant (enabled all three options)
3) created boot USB stick via bootcamp assistant with the created iso file. Using the Windows DVD as boot media didn't work (I got error: no bootable device on startup, had to restart iMac and press alt to choose Macintosh HD as boot media again to get back to the system)
4) created cd/dvd with bootcamp Software downloaded with additional drivers, etc. - no probs
5) created bootcamp partition for Windows - no probs
6) bootcamp restarted iMac automatically, loading Windows files from stick and started the setup procedure. I formatted the bootcamp partition (no options, NTFS seems to be standard) and pressed next. Then the error "Setup was unable to create a new system partition or locate an existing system partition" occured. I tried it a few times but it didn't work

Solution: Removed external hdd from USB connection!! external hdd was the last partition in the overview of the Windows setup. It seems as if the setup has a problem if the bootcamp partition isn't the last one there.

It took some time to find all errors I ran into mentioned above via Google. So I hope it helps some others out there.

One source was here: https://discussions.apple.com/thread...art=0&tstart=0
DRF is offline   1 Reply With Quote
Old Feb 11, 2013, 09:35 AM   #2
David-J-L
macrumors newbie
 
Join Date: Feb 2013
Smile Excellent solution

I had struggled with 'missing drivers' and 'system partition' issues for a few days and was about to give up when I came across your solution. Disconnecting my external/Time Machine drive which shifted the new windows partition to the bottom of the selection did the trick and the installation went through like a knife through butter. Even the Windows Support downloaded this morning after a couple of days of 'hanging'. My lucky day, thank you. Saves a lot in terms of cash and also computer resources than running a Parallels type solution. I had an OEM Windows 7 (no disc) but found an ISO online and had luckily kept a redundant Windows 7 Product Key after upgrading my laptop to Windows 8. It sometimes pay to keep old data for a while!
David-J-L is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:21 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC