Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 24, 2011, 08:00 PM   #26
Daveoc64
macrumors 601
 
Join Date: Jan 2008
Location: Bristol, UK
Quote:
Originally Posted by LIVEFRMNYC View Post
The "HUGE flaw in iMessage" was Apple thinking that everyone would be smart enough to use it correctly.
No, the huge flaw is that iMessage makes several assumptions about a connected device, its user and the data connection (if any) that the device has.

Apple doesn't really allow you to control how iMessage functions. It's pretty much all or nothing.

A better system would offer the user more customisation. I'd like to be able to use iMessage, but ONLY if the the recipient is unable to receive an SMS (i.e. they are on an iPad or iPod touch).
__________________
Nexus 5 32GB Black (Three UK) | Nexus 7 (2012) | Kindle Paperwhite (2013)
iPhone 4 32GB
White MacBook (Late 2007)
Windows 8.1 | iCloud, Dropbox, Spotify Premium
Daveoc64 is offline   0 Reply With Quote
Old Oct 24, 2011, 08:01 PM   #27
Rodimus Prime
Banned
 
Join Date: Oct 2006
Yeah this was a cluster **** I dealt with when my brother switch to Android. My mom and sisters phone still show a blue send button but because I turned off recieving iMessage on his phone it forces it green and he does not have any other iDevice.

It is a massive cluster because we can not figure out how to turn it off receiving them for a phone number and Apple is making it hard to fix it.

Apple is being Apple making it a royal pain to leave the Apple ecosystem. Apple screwed the up on this one and there needs to be more hell raised about it.

We type in his number defaults to iMessage so yes it is a massive pain in the rear. This is a 100% Apple created bug. I called this problem before iMessage was released and question it. Seamless my rear end.
Rodimus Prime is offline   -1 Reply With Quote
Old Oct 24, 2011, 08:06 PM   #28
diamond.g
macrumors Demi-God
 
Join Date: Mar 2007
Location: Virginia
Quote:
Originally Posted by pcunite View Post
iMessage logic is flawed, when I'm on a wifi connection it chooses to send an iMessage to my wife's phone ... which is fine when she's on wifi too ... but when she has her data turned off it delays every message by 5 minutes!
From what I can tell iMessage always tries sending over 3G when using an iPhone. You have to be trying to send an image/video or turn off cellular data to force it to use WiFi.
diamond.g is offline   0 Reply With Quote
Old Oct 24, 2011, 08:26 PM   #29
haruhiko
macrumors 68030
 
haruhiko's Avatar
 
Join Date: Sep 2009
Quote:
Originally Posted by neiltc13 View Post
Someone has probably reported this already, but I've found what I think is a dealbreaker for me using iMessage on my iPhone 4.

One of my friends upgraded to iOS5 and then got an Android phone. However, when he got rid of his iPhone he didn't remove his phone number from his Apple ID for iMessage. This means that when I (or anyone else with an iPhone running iOS5) try to message him, my phone chooses to send the messages by iMessage, despite him no longer having a phone capable of receiving the messages.

I can't disable iMessage on a per-contact basis, so I can either disable iMessage completely for all of my contacts, or choose not to send him any more messages.

Has anyone else encountered this issue, and is there a way to remove your phone number from your Apple ID so that people aren't sending you messages you can't receive?
Yes, that's it. My case isn't exactly like yours, but I gave my old 3GS to my mom, but she insisted that she doesn't need an expensive data plan and so I turned off mobile data when she's on the go. But iMessage can't tell if she's online or offline and just send my message to her without delivering, but I don't have the option to send it as text, even if the "send as SMS" option is turned on.

Finally I disabled iMessage on her phone.
__________________
Mac: rMBP'12, iMac'08/24", Mini'09, MBP'10/15", MBA'11/13". iPhone: 5s/64S 5/64B, 4S/64W, 4/32B, 3GS/16. iPT: 3G,1G. iPad: Air,Mini2,4,3/LTE/64 2/3G/32, 1/WiFi/16. ATV'12,'11, AEBS'09, TC'13/2TB
haruhiko is offline   0 Reply With Quote
Old Oct 24, 2011, 08:44 PM   #30
pcunite
macrumors member
 
Join Date: Nov 2010
Quote:
Originally Posted by diamond.g View Post
From what I can tell iMessage always tries sending over 3G when using an iPhone. You have to be trying to send an image/video or turn off cellular data to force it to use WiFi.
My data is always off, so it's using my wifi connection.
pcunite is offline   0 Reply With Quote
Old Oct 24, 2011, 10:38 PM   #31
munkery
macrumors 68020
 
munkery's Avatar
 
Join Date: Dec 2006
Disable iMessage, then Messages returns to its previous behaviour that was acceptable to you before iMessage was introduced.

or

Disable the SMS feature in Messages and download a third party SMS app to send messages to contacts without iOS devices.
__________________
Mac Security Suggestions
munkery is offline   1 Reply With Quote
Old Oct 24, 2011, 10:44 PM   #32
Rodimus Prime
Banned
 
Join Date: Oct 2006
Quote:
Originally Posted by munkery View Post
Disable iMessage, then Messages returns to its previous behaviour that was acceptable to you before iMessage was introduced.

or

Disable the SMS feature in Messages and download a third party SMS app to send messages to contacts without iOS devices.
problem with that is it does not solve the fundamental problem with iMessage.

The problem is if you leave the iOS all your friends iPhones will keep defaulting to iMessage instead of going over to SMS.

What you are suggesting is OP and all his friends turn off iMessage so they can SMS the one guy who went android.
Do you see the fundamental problem with your argument and the larger issue with iMessage that Apple created?
Rodimus Prime is offline   0 Reply With Quote
Old Oct 25, 2011, 12:23 AM   #33
LIVEFRMNYC
macrumors 68030
 
Join Date: Oct 2009
Quote:
Originally Posted by Rodimus Prime View Post
problem with that is it does not solve the fundamental problem with iMessage.

The problem is if you leave the iOS all your friends iPhones will keep defaulting to iMessage instead of going over to SMS.

What you are suggesting is OP and all his friends turn off iMessage so they can SMS the one guy who went android.
Do you see the fundamental problem with your argument and the larger issue with iMessage that Apple created?
I just tried this out and could not reproduce this problem. I just put my sim card(using adapter) in an old windows palm treo and from my cousin's iPhone I text my number and it DID NOT ACTIVATE iMessage. It just sent as a regular text. (Green Bubble w/ text message indicator in typing window and of top of chat)

Put my sim back in my iPhone and text myself again using her iPhone and iMessage ACTIVATED again. (Blue Bubble w/ iMessage indicator in typing window and top of chat)

NOTE: Me and my cousin chatted with iMessage many times before and her iPhone still had old iMessage chats from a week ago.

BTW ... I'm on AT&T.
LIVEFRMNYC is offline   3 Reply With Quote
Old Oct 25, 2011, 05:11 AM   #34
nomad01
macrumors 68000
 
nomad01's Avatar
 
Join Date: Aug 2005
Location: Birmingham, England
Weird... my best friend has a Blackberry for work and uses the sim in an iPhone at weekends. He also has an iPad with iMessage functioning.

So far, no issues. When I send a text in the week, it goes as an SMS (sometimes have to prompt this the first time) but as soon as he starts using his iPhone, it goes via iMessage.

Can see that there's a potential for error but so far... it's been fine.
__________________
11" Macbook Air, Mac Mini, eMac, White Macbook, iPad 2, iPhone 4s
http://www.bake-shop.co.uk
nomad01 is offline   2 Reply With Quote
Old Oct 25, 2011, 08:19 AM   #35
JRoDDz
macrumors 68000
 
JRoDDz's Avatar
 
Join Date: Jul 2009
Location: NJ
Quote:
Originally Posted by neiltc13 View Post
One of my friends upgraded to iOS5 and then got an Android phone. However, when he got rid of his iPhone he didn't remove his phone number from his Apple ID for iMessage.
So your friend messed up and didn't remove his phone number from his apple ID. How is this a flaw in iMessage? I think it may be a flaw with your friend.

The person he sold it to is probably receiving all the iMessages sent to him. As far as I know iMessage will check to see if that device is turned on and has a data connection. There was a thread here (http://forums.macrumors.com/showthread.php?t=1258734) about someone who sold his iPhone and then his wife started getting messages that were supposedly from him, they weren't. They were from the person who he sold his iPhone to. He never deleted his iMessage from the device.

Last edited by JRoDDz; Oct 25, 2011 at 08:27 AM.
JRoDDz is offline   2 Reply With Quote
Old Oct 25, 2011, 09:03 AM   #36
CBJammin103
macrumors regular
 
Join Date: Jun 2007
Location: Louisiana, United States
Quote:
Originally Posted by nomad01 View Post
Weird... my best friend has a Blackberry for work and uses the sim in an iPhone at weekends. He also has an iPad with iMessage functioning.

So far, no issues. When I send a text in the week, it goes as an SMS (sometimes have to prompt this the first time) but as soon as he starts using his iPhone, it goes via iMessage.

Can see that there's a potential for error but so far... it's been fine.
This has been my experience so far as well - iMessage figures out what my contacts' devices can accept and then switches appropriately.

I can certainly see the possibility for confusion in some situations but I haven't personally encountered it yet. The only weirdness I have is that my iMessage conversations are not identical on my iPad and my iPhone, which I assumed they were supposed to be. (Some messages are missing from the iPad)
__________________
iMac 27" Core i7 15" Retina Macbook Pro iPhone 5
CBJammin103 is offline   1 Reply With Quote
Old Oct 25, 2011, 10:41 AM   #37
munkery
macrumors 68020
 
munkery's Avatar
 
Join Date: Dec 2006
Quote:
Originally Posted by Rodimus Prime View Post
The problem is if you leave the iOS all your friends iPhones will keep defaulting to iMessage instead of going over to SMS.
This doesn't occur if iMessage is disabled in the Messages preferences. This is why I made the following suggestion:
Quote:
Disable iMessage, then Messages returns to its previous behaviour that was acceptable to you before iMessage was introduced.
Quote:
Originally Posted by Rodimus Prime View Post
What you are suggesting is OP and all his friends turn off iMessage so they can SMS the one guy who went android.
As an alternative to the solution above, I provided a solution that addresses this issue as well. This alternative solution is the following:
Quote:
Disable the SMS feature in Messages and download a third party SMS app to send messages to contacts without iOS devices.
__________________
Mac Security Suggestions
munkery is offline   0 Reply With Quote
Old Oct 25, 2011, 10:48 AM   #38
KittyKatta
macrumors 6502
 
Join Date: Feb 2011
Location: SoCal
Just like with so many other iOS5 features, iMessage seems to be a lot more complicated than Apple users are used to. I have an iPhone and iPad which dont seem to work as advertised despite them both being configured correctly to default to Apple ID. My iMessage text logs dont sync up between two devices and the requirement to tell every iPhone user you know to text my email address rather than the phone number in order to get iMessaging to recognize it seems very unintuitive.

Hopefully Apple does some quick updates to this or at least changes the marketing because I know a lot of people who are misunderstanding what iMessaging is.
KittyKatta is offline   0 Reply With Quote
Old Oct 25, 2011, 10:53 AM   #39
Tortri
macrumors 6502a
 
Join Date: Aug 2010
Not sure if this is a fix or not but this guys contact, is his number listed as a iPhone or Mobile phone? Not sure if that'll fix it but might be why it's trying to send via iMessage by default.
Tortri is offline   0 Reply With Quote
Old Oct 25, 2011, 10:59 AM   #40
munkery
macrumors 68020
 
munkery's Avatar
 
Join Date: Dec 2006
Quote:
Originally Posted by KittyKatta View Post
...
Go into Messages preferences and select Receive At.

Your phone number should already be added to the list.

If not, then add your phone number.

Only iMessage communications will be synced across devices. SMS messages that are sent to non-iOS users will not be synced.
__________________
Mac Security Suggestions
munkery is offline   1 Reply With Quote
Old Oct 25, 2011, 11:00 AM   #41
BanterClaus
macrumors regular
 
Join Date: Feb 2011
Location: UK
you can still send an SMS to him however its quite a hidden option. Straight after sending a message hold over the message bubble and a 'send as SMS' will appear. Its kind of fiddly to do this and I don't see why apple haven't made an easier way but still it should work for now.

__________________
iPad 4 32GB iPhone 5S 16GB iPod Touch 4 32GB
13" 2011 MacBook Pro | i5 | 8GB | 120GB Vertex 3 SSD & 320GB HDD
Gaming PC | Quad i5 3.3GHz | 8GB | 1TB | AMD 6970 2GB

Last edited by BanterClaus; Oct 25, 2011 at 11:06 AM.
BanterClaus is offline   5 Reply With Quote
Old Oct 25, 2011, 01:01 PM   #42
joecatz
macrumors member
 
Join Date: Jan 2011
Quote:
Originally Posted by jessica. View Post
^ but what happens if you send an iMessage to someone's e-mail address who doesn't have an iPhone or any iOS device?
you can't. when you attempt to send the message (from imessage) the contact shows up RED.

I've updated the ipad, but not my iphone yet to ios5. I can't send a message from the ipad to the iphone.

----------

Quote:
Originally Posted by mkrishnan View Post
For the OP, what happens if you (I would test this but I don't think I have anyone on iOS 5 to text! ) go to their phone number in Contacts and click the send a text message (or whatever it says now) button? Does it give you an option to pick the intended destination? And does it send an iMessage anyways?
It ports the CONTACT into imessage. while it gives you the option to send it to email OR phone number, if that contact had, say, an ipad AND an Iphone running IOS, linked to the same email for apple ID, they would get the text on both devices, regardless.

The only way it will go strictly to the phone is if there is no email address associated with the contact I believe (or if the email is not their apple ID for Imessage)

----------

By the way, everyone does realize that the whole POINT of imessage from Apples perspective is to get people to have iphones AND ipads, not one or the other, right?

I mean, they want them to work seamlessly together, and be a bit of a problem with other devices, no?
joecatz is offline   -1 Reply With Quote
Old Oct 28, 2011, 11:11 AM   #43
haleak2
macrumors newbie
 
Join Date: Oct 2011
Fix

Quote:
Originally Posted by bob616 View Post
You can remove iMessage from that person's contact by:

1. Creating a new message
2. Type the person's name in
3. Press and hold on the blue bubble of their name
4. Select the option to remove there name from your iPhone's stored iMessage database.
This worked for me! My sister had an iPhone with iOS5, but then switched to a non-iPhone but kept the same phone #. My iPhone kept trying to send her iMessages because of her old setup. It would try iMessage, then after several minutes, eventually send an SMS, but who wants to wait minutes for a text to go through? Anyway, following the above suggestion, I typed a text to her and hit the blue "send." My text then appeared in the blue bubble on the screen. I held my finger down over the blue bubble text until options came up. I hit "send as text message." The message was then immediately sent as a standard text message. All subsequent messages to my sister were sent as SMS. Thanks for the fix!
haleak2 is offline   1 Reply With Quote
Old Oct 28, 2011, 11:20 AM   #44
frunkis54
macrumors 65816
 
frunkis54's Avatar
 
Join Date: Apr 2009
After hearing this i thought it would be a problem but its not. i have had ios 5 since beta 1. i broke my iphone 2 days ago and had to use a backup droid since the iphone broke i couldn't make any setting changes. after reading this i was worried i wouldn't get any of my messages. so i had my friend who is also using ios5 and i have previously imessaged text me. i took a few min extra to receive but it worked fine.

non issue for me at least.
frunkis54 is offline   0 Reply With Quote
Old Oct 28, 2011, 12:12 PM   #45
YoYoCome
macrumors newbie
 
Join Date: Apr 2010
Quote:
Originally Posted by BanterClaus View Post
you can still send an SMS to him however its quite a hidden option. Straight after sending a message hold over the message bubble and a 'send as SMS' will appear. Its kind of fiddly to do this and I don't see why apple haven't made an easier way but still it should work for now.

Image
Just to add a note: you need to have the "Send as SMS" option turned ON to to this.
YoYoCome is offline   1 Reply With Quote
Old Oct 30, 2011, 01:22 PM   #46
sviato
macrumors 68000
 
sviato's Avatar
 
Join Date: Oct 2010
Location: HR 9038 A
When your friend got rid of his iPhone didn't he remove the sim card and wipe all the data on it? I think that would've reset the iMessage settings.

I recently got rid of my iPhone 4 and I did a complete wipe and receive texts normally on my new phone(not an iphone) and friends haven't said anything about sending iMessages to me/me not getting their messages.


edit: actually I asked my friend just now and he said that sometimes his texts try to get sent as iMessages but don't go through. The guy who I gave my iPhone to has not activated it with his SIM yet though, when he does I wonder if texts to my number will go as iMessages to his phone or if it'll change to only receive to his number

Last edited by sviato; Oct 30, 2011 at 04:15 PM.
sviato is offline   0 Reply With Quote
Old Oct 9, 2012, 04:13 PM   #47
pluvc1993
macrumors newbie
 
Join Date: Oct 2012
How to remove iMessage when switching to Android

I did both of these and then it finally cleared.

Method #1


1) Go to https://daw.apple.com/cgi-bin/WebObj...language=US-EN
2) Login
3) Deactivate your old phone
4) Shut off iPhone
5) Restart your droid phone and text someone and see if they can text you back
****If this doesn't work then go to method #2****

1) Shut down your Android phone
2) Remove sim Card
3) Remove Sim Card from iPhone (you can open sim trya by simply using a paperclip and pushing it in the hole.
4) Put new sim card from your android phone into iPhone 4 or 4S and turn on iPhone
5) Go into settings then scroll down to Messaging
6) Shut off iMessaging and turn on SMS Messaging.
7) Wait 2 min
8) Shut off iPhone 4 or 4S remove sim and put back into Android phone then restart phone.
9) Wahla!!! It should be working
****If you lost your phone you can use someone elses to do Method #2****

Hope this helps..if it works give me feedback...
pluvc1993 is offline   0 Reply With Quote
Old Nov 6, 2012, 09:19 AM   #48
godfatherjaw
macrumors newbie
 
Join Date: Nov 2012
Quote:
Originally Posted by jessica. View Post
Read the OP. He is using an e-mail address.
Now, unless you can use a standard e-mail address to send an SMS, this is just irrelevant.
Reread the OP. He is trying to message the person not email them. I have the same issue. The way the number is saved has noting todo with it and you can make it send sms if you hold over it right after you click send but its dumb that it doesnt just know. I thought that was the wole point of it?!? love that it is integrated but dont love this one flaw!!
godfatherjaw is offline   0 Reply With Quote
Old Dec 11, 2012, 04:24 PM   #49
RylanH16
macrumors member
 
Join Date: Dec 2012
Thumbs up Monk!

This has nothing to do with the thread, but I love your profile pic
RylanH16 is offline   0 Reply With Quote
Old Feb 18, 2013, 01:41 PM   #50
MikeR123
macrumors newbie
 
Join Date: Feb 2013
IMessage cock-up

I have an iPhone and an iPad, both connected via WiFi. My girlfriend also has an iPhone and and iPad, and iMessage works fine, until you take the phone out of the house. The phone is then not connected to WIFI, but the iPad is. Now, when an iMessage comes in, it is delivered to the iPad and the 'Delivered' message goes back to the sender, BUT it doesn't go to the phone until the phone next logs on to WIFI, so the sender is told that message was delivered, and it WASN'T. You would not believe how much trouble this little flaw has just got me into!!!!
MikeR123 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Tags
bug, imessage

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Finally fixed my issue with imessage to group when one doesn't have imessage vrillusions iOS 7 0 Oct 28, 2013 08:26 PM
Well, I Found a Huge Flaw in Retina Displays skitzogreg Wasteland 15 Oct 26, 2013 02:19 AM
iMessage is a huge deal Honza iPhone 103 Feb 16, 2013 12:15 PM
Samsung Galaxy S3 has huge security flaw ScottishDuck Alternatives to iOS and iOS Devices 27 Sep 27, 2012 08:04 PM
iMessage with Phone Number on multiple devices - Possible Design Flaw timlopez iOS 6 8 Sep 25, 2012 01:06 PM

Forum Jump

All times are GMT -5. The time now is 01:10 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC