Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 17, 2012, 08:45 PM   #1
Razorhog
macrumors 6502a
 
Razorhog's Avatar
 
Join Date: Sep 2006
Location: Arkansas
Installed Windows 7, bootcamp drivers, now keyboard doesn't work

I just installed Windows 7 on my 27" 2012 iMac. The bootcamp install in windows went fine. Keyboard and mouse were both functional - until I rebooted after the drivers installed. Now the windows login screen comes up, but the keyboard and mouse do not work. I've tried a regular USB keyboard and still nothing. Apple wireless keyboard does not work either. Any ideas how I can get into windows to try and figure out the driver issues? Thanks

----------

I can boot into safemode and the keyboard and mouse works. Normal boot and they don't.
Razorhog is offline   0 Reply With Quote
Old Dec 18, 2012, 05:11 PM   #2
ender land
macrumors 6502a
 
Join Date: Oct 2010
Wow, same exact issue here.

The really confusing part to me is things like Command E and Command D work - so it's something really screwy.
ender land is offline   0 Reply With Quote
Old Dec 19, 2012, 12:21 AM   #3
Project Alice
macrumors member
 
Join Date: Jul 2008
Location: Spokane WA
This happens to me EVERY single time I install windows on my macbook pro. It seems to happen only after I install my bootcamp drivers. Granted this is not an iMac, i will tell you what works for me. I plug in an external mouse and keyboard, and then those work for the time being. using those, I run all the available bootcamp updates. after that, I reset the PRAM/NVRAM and everything works again. The PRAM/NVRAM reset is crucial even if you dont update bootcamp. its just easier to get two reboot birds with one stone.

EDIT: I see you cannot use an external mouse or keyboard. So instead just reset the PRAM/NVRAM.

http://support.apple.com/kb/HT1379
__________________
MacBook Pro 15", 2.33 C2D, 3gb ram, 500GB, Mac OS X 10.7.5; Power Mac G4 Quicksilver, Dual 800mhz, 1.5gb ram. 80gb HDD, triple boot: Mac OS 10.5.8, 10.4.11, and 9.2.2
Project Alice is offline   0 Reply With Quote
Old Dec 20, 2012, 04:03 PM   #4
MaxVaini
macrumors newbie
 
Join Date: Dec 2012
something similar happened to me with two new "late 2012 iMac 27 inch".
all the usb ports have stopped suddenly to work after bootcamp installation's.
I was locked, without possibilities to use mouse and keyboard
I sorted out the problem starting windows in safe mode, activating the remote desktop, connecting to the machine remotly, updating windows to the latest update/service pack, and finally uninstalling an intel USB 3 extension driver.
Max
MaxVaini is offline   0 Reply With Quote
Old Dec 20, 2012, 05:39 PM   #5
MaxVaini
macrumors newbie
 
Join Date: Dec 2012
I confirm, after restoring bootcamp, the problem is come back because the
"Intell USB 3.0 eXtensible Host Controller Driver" it was reinstalled.
I removed again the driver and now keyboard and mouse are working perfectly.
MaxVaini is offline   0 Reply With Quote
Old Jan 23, 2013, 03:21 PM   #6
MattDavies93
macrumors newbie
 
Join Date: Jan 2013
Hi I seem to be having this issue too, I have installed windows 7 perfectly fine via bootcamp to my Mac Mini and I installed all the bootcamp drivers fine, restarted the computer to run windows and my external keyboard and mouse which worked perfectly before now do not function.

If I run windows in safe mode they function fine again and I have even tried uninstalling the intel USB 3.0 eXtensible Host Controller Driver, but when I restart windows I get the same problem and I find upon trying safe mode the driver has installed itself again

Any help would be appreciated
Matt
MattDavies93 is offline   0 Reply With Quote
Old Jan 31, 2013, 03:24 PM   #7
Joracate
macrumors newbie
 
Join Date: Jan 2013
Another one with a 27" 2012 Imac and the same problem and without solution...
Joracate is offline   0 Reply With Quote
Old Feb 1, 2013, 01:26 PM   #8
jzn010
macrumors newbie
 
Join Date: Feb 2013
The issue is the USB 3.0 extreme driver that gets installed.

To fix this boot into windows safe mode by holding or repeatedly hitting F8 as windows boots. Once in safe mode go to the control panel/ add remove programs and uninstall the USB 3.0 driver listing. After that you can reboot back into regular windows and your keyboard/mouse will work and you will have 1 unknown device listed in device manager.

Apparently this is related to a usb3 monitor utility that gets installed with the normal intel setup package. To get the drivers installed without that utility i downloaded the usb driver package from http://downloadcenter.intel.com/Deta...?DwnldID=21129
Extract the files but do not run the setup. Instead go to device manager and update the driver and point it to the folder you extracted.

After you install the first unknown device a second one will pop up. Do the exact same thing with that device. Both items will install successfully and everything should be fine.

I haven't tested a usb3 device yet but everything should be in a position for it to work.
jzn010 is offline   5 Reply With Quote
Old Feb 2, 2013, 02:54 AM   #9
adamsfcal
macrumors newbie
 
Join Date: Feb 2013
I just installed Windows 7 Enterprise on a brand new iMac with bootcamp and had the same problem after a clean install. That is, the wireless keyboard and trackpad did not work and I couldn't get a USB mouse and keyboard to work either because the USB ports were dead. I was stuck unable to even enter my password to get into Windows. I followed JZN010's instructions to the letter and everything worked great afterwards. Thanks so much!!!
adamsfcal is offline   0 Reply With Quote
Old Feb 2, 2013, 03:23 PM   #10
Joracate
macrumors newbie
 
Join Date: Jan 2013
I followed jzn010 instructions too and now it works perfect. Thank you!!
Joracate is offline   0 Reply With Quote
Old Feb 2, 2013, 10:37 PM   #11
hfg
macrumors 68020
 
hfg's Avatar
 
Join Date: Dec 2006
Location: Cedar Rapids, IA.
Same thing here, so I reinstalled. This time, after the BootCamp driver installation, I was about to click the restart button when I noticed a message at the bottom that a driver was installing. I clicked on it and got a list of drivers which were being updated by "Windows Update" and it was taking a really long time ... but they did finally all load and initialize. They included things like BlueTooth, Keyboard, Mouse, Trackpad, USB-3.0, etc. After they all showed they were complete, I hit the restart button and when it rebooted, everything worked perfectly! Just had to have patience before rebooting.
hfg is offline   0 Reply With Quote
Old Feb 19, 2013, 12:01 AM   #12
schmick63
macrumors newbie
 
Join Date: Feb 2013
I am having the same problem but I can't work out how to get to Control Panel to delete the driver
I can't type in my password so I can't get into windows
schmick63 is offline   0 Reply With Quote
Old Mar 9, 2013, 06:20 AM   #13
burgo
macrumors newbie
 
Join Date: Mar 2013
It was supposed to be so easy...

I have the same issue. Brand new 2013 iMac, Snow Leopard, Win7x64
Installed Bootcamp drivers and Apple USB keyboard stopped working, and USB mouse too.

I reset PVRAM/NRAM -- no difference.

I followed the advice of jzn010 to reinstall USB3.0 drivers and now USB mouse is working, but still no keyboard!

While in safemode I tried to update bootcamp and Windows, but bootcamp seems to be up to date. WinUpdate did not even seem to start -- does it work in safe mode?

Anybody got any more ideas?
burgo is offline   0 Reply With Quote
Old Mar 10, 2013, 06:41 PM   #14
burgo
macrumors newbie
 
Join Date: Mar 2013
Working

Well I have it working now. But I'm not entirely sure how...

What I did was WindowsUpdate (which doesn't run in safe mode) and let it reboot and rerun WindowsUpdate a few times. Eventually it found and installed my Apple USB keyboard.

It didn't seem to have found the Magic mouse, but then I switched the mouse off for a few seconds and back on and it started working.

So I guess I have to thank the possibly non-existent Microsoft Macintosh Support Group for including the Apple drivers in their updates.
burgo is offline   0 Reply With Quote
Old Mar 21, 2013, 01:13 PM   #15
benjaminfoden
macrumors member
 
Join Date: Feb 2013
Spot On!

Quote:
Originally Posted by jzn010 View Post
The issue is the USB 3.0 extreme driver that gets installed.

To fix this boot into windows safe mode by holding or repeatedly hitting F8 as windows boots. Once in safe mode go to the control panel/ add remove programs and uninstall the USB 3.0 driver listing. After that you can reboot back into regular windows and your keyboard/mouse will work and you will have 1 unknown device listed in device manager.

Apparently this is related to a usb3 monitor utility that gets installed with the normal intel setup package. To get the drivers installed without that utility i downloaded the usb driver package from http://downloadcenter.intel.com/Deta...?DwnldID=21129
Extract the files but do not run the setup. Instead go to device manager and update the driver and point it to the folder you extracted.

After you install the first unknown device a second one will pop up. Do the exact same thing with that device. Both items will install successfully and everything should be fine.

I haven't tested a usb3 device yet but everything should be in a position for it to work.
Thanks for this, it fixed the issue I was having without any further problems. USB3 devices are working fine too
benjaminfoden is offline   0 Reply With Quote
Old Mar 28, 2013, 09:23 PM   #16
mainemacuser
macrumors newbie
 
Join Date: Mar 2007
Location: Maine
Quote:
Originally Posted by burgo View Post
Well I have it working now. But I'm not entirely sure how...

What I did was WindowsUpdate (which doesn't run in safe mode) and let it reboot and rerun WindowsUpdate a few times. Eventually it found and installed my Apple USB keyboard.

It didn't seem to have found the Magic mouse, but then I switched the mouse off for a few seconds and back on and it started working.

So I guess I have to thank the possibly non-existent Microsoft Macintosh Support Group for including the Apple drivers in their updates.
I had the same problem, after deleting the USB driver and installing the intel driver, the mouse worked, the keyboard was still dead.

I was able to log on using the on-screen keyboard at the Win 7 password startup screen (I clicked at the bottom and the option to use the on-screen keyboard was there).

Then I ran the Windows Update like you did, but I also replugged the keyboard in, a chime sounded, an dialog box came up saying an input device update was being downloaded, then the Microsoft Mouse and Keyboard Center screen came up and had a download button. i clicked that, and finally the keyboard was working. it may have been plugging it in again, but I don't know.
mainemacuser is offline   0 Reply With Quote
Old Mar 29, 2013, 12:20 AM   #17
WayDownSouth
macrumors newbie
 
Join Date: Mar 2013
Quote:
Originally Posted by jzn010 View Post
The issue is the USB 3.0 extreme driver that gets installed.

To fix this boot into windows safe mode by holding or repeatedly hitting F8 as windows boots. Once in safe mode go to the control panel/ add remove programs and uninstall the USB 3.0 driver listing. After that you can reboot back into regular windows and your keyboard/mouse will work and you will have 1 unknown device listed in device manager.

Apparently this is related to a usb3 monitor utility that gets installed with the normal intel setup package. To get the drivers installed without that utility i downloaded the usb driver package from http://downloadcenter.intel.com/Deta...?DwnldID=21129
Extract the files but do not run the setup. Instead go to device manager and update the driver and point it to the folder you extracted.
Thank you for posting this. After hours of frustration, this solved the problem. I registered here just to say how much I appreciate the time you spent writing the post. Good on you.
WayDownSouth is offline   0 Reply With Quote
Old Jun 16, 2013, 10:31 PM   #18
vpchao
macrumors newbie
 
Join Date: Jun 2013
It works!

Quote:
Originally Posted by jzn010 View Post
The issue is the USB 3.0 extreme driver that gets installed.

To fix this boot into windows safe mode by holding or repeatedly hitting F8 as windows boots. Once in safe mode go to the control panel/ add remove programs and uninstall the USB 3.0 driver listing. After that you can reboot back into regular windows and your keyboard/mouse will work and you will have 1 unknown device listed in device manager.

Apparently this is related to a usb3 monitor utility that gets installed with the normal intel setup package. To get the drivers installed without that utility i downloaded the usb driver package from http://downloadcenter.intel.com/Deta...?DwnldID=21129
Extract the files but do not run the setup. Instead go to device manager and update the driver and point it to the folder you extracted.

After you install the first unknown device a second one will pop up. Do the exact same thing with that device. Both items will install successfully and everything should be fine.

I haven't tested a usb3 device yet but everything should be in a position for it to work.
Thank you so much jzn010 for taking time to post this wonderful info!! Although I still am finding out how to get the wireless mighty mouse scrolling function going, but still, many many thanks!
vpchao is offline   0 Reply With Quote
Old Jun 30, 2013, 09:15 PM   #19
Wild Orca
macrumors newbie
 
Join Date: Jun 2013
Smile Three Cheers for jzn010. This worked for me

Thank you so much jzn010.

I have been having this problem and searching for the solution for 2 weeks. Couldn't find the source of the problem anywhere. Your detailed instructions did the trick.

I have the new 27 inch iMac i7 running Mac OS 10.8.4. I installed Windows 7 64 bit using bootcamp on a 3 TB fusion drive. Everything worked great in windows except no USB device (keyboard, usb key, usb drive) would function.

many thanks,
Wild Orca

Quote:
Originally Posted by jzn010 View Post
The issue is the USB 3.0 extreme driver that gets installed.

To fix this boot into windows safe mode by holding or repeatedly hitting F8 as windows boots. Once in safe mode go to the control panel/ add remove programs and uninstall the USB 3.0 driver listing. After that you can reboot back into regular windows and your keyboard/mouse will work and you will have 1 unknown device listed in device manager.

Apparently this is related to a usb3 monitor utility that gets installed with the normal intel setup package. To get the drivers installed without that utility i downloaded the usb driver package from http://downloadcenter.intel.com/Deta...?DwnldID=21129
Extract the files but do not run the setup. Instead go to device manager and update the driver and point it to the folder you extracted.

After you install the first unknown device a second one will pop up. Do the exact same thing with that device. Both items will install successfully and everything should be fine.

I haven't tested a usb3 device yet but everything should be in a position for it to work.
Wild Orca is offline   0 Reply With Quote
Old Jul 5, 2013, 10:02 AM   #20
Lucille Carter
macrumors 65816
 
Join Date: Jul 2013
The new MBA is here and WIndows Installed but the keyboard or mosue pad does not work when Windows is starting. I tried going to safemode but it say the "Windows can not complete installation in Safe Mode" I can not get in to delete the USB3 Driver. Have even tried a USB keyboard and mouse and nothing
Lucille Carter is offline   0 Reply With Quote
Old Jul 5, 2013, 11:12 AM   #21
Lucille Carter
macrumors 65816
 
Join Date: Jul 2013
I can not get past setup

Will not allow me to get into safe mode as I can not complete setup

Last edited by Lucille Carter; Jul 5, 2013 at 12:24 PM.
Lucille Carter is offline   0 Reply With Quote
Old Jul 6, 2013, 02:38 PM   #22
JimOHara
macrumors newbie
 
Join Date: Oct 2012
Smile getting blue tooth device to work after install

iMac 21.5 inch OS X Lion (10.8.4), Bootcamp install of Windows 7 Professional 64 bit.

At the end of my install, I noticed that Bootcamp was not available from Windows (e.g., no hidden taskbar icon). Other issues with missing USB drivers. Magic mouse worked ok, except the trackpad-like swiping features were absent. Ran setup in the BootCamp folder of the thumb drive (not the setup in the thumb drive's root directory), which indicated it was a continuing install (guess somehow the first one stopped prematurely), installed all the special Apple etc. drivers for the Bootcamp interface with Windows.
After restart, all the troubleshooter warnings for USB devices had cleared, but Magic mouse was not communicating with system. Attached a standard Microsoft optical USB mouse.
Then, in Windows control panel > devices and printers:
  1. right clicked the magic mouse's icon (was labeled apple-username's mouse)
  2. selected Services tab
  3. (Bluetooth Services refreshes, then shows checkbox for Drivers for keyboard, mice, etc (HID))
  4. check the checkbox
Windows installs the driver and the magic mouse works with all its features in Windows.

incidentally, noticed that had lots of internet cutouts with both wi-fi and lan connected. maybe an issue with my ISP, don't know, although issue only apparent in Windows, not Mac OS X.
JimOHara is offline   0 Reply With Quote
Old Mar 17, 2014, 08:48 AM   #23
kometen
macrumors newbie
 
Join Date: Jan 2003
Location: Breim, westcoast of Norway
win7 and usb3

Hi.

I faced a similar problem with win7 and usb3 and tried to uninstall the usb3-driver but it did not work.

I then attached the usb-keyboard and -mouse to an apple cinema-display and connected the display to the imac's display-port. Then I circumvented the usb3-problem by using the thunderbolt-port instead.

I finished the installation and it works now with the imac's usb3-bus.

regards
Claus
kometen is offline   0 Reply With Quote
Old Jun 22, 2014, 04:57 AM   #24
sauron34
macrumors newbie
 
Join Date: Jul 2011
After trying all this solutions without success, I found the easiest solution ever: just before bootcamp finishes to install everything, a bubble appears informing that new drivers are being installed.

Click on it and wait to Windows installs all this drivers (in this process is when your mouse stops working). You will see that Windows recognizes the mouse and installs a driver for it. Just turn off and on your mouse and it will works perfectly! Trust me, I have tried everything and the solution was just wait!

By the way, tank you hfg, because you gave me the hint with your post:

Quote:
Originally Posted by hfg View Post
Same thing here, so I reinstalled. This time, after the BootCamp driver installation, I was about to click the restart button when I noticed a message at the bottom that a driver was installing. I clicked on it and got a list of drivers which were being updated by "Windows Update" and it was taking a really long time ... but they did finally all load and initialize. They included things like BlueTooth, Keyboard, Mouse, Trackpad, USB-3.0, etc. After they all showed they were complete, I hit the restart button and when it rebooted, everything worked perfectly! Just had to have patience before rebooting.
Many thanks!
sauron34 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Installed SSD, Downloaded Windows 7 - Sound doesn't work, graphic card not supported! StatedFailure Windows, Linux & Others on the Mac 4 Feb 21, 2014 03:26 PM
How do I install the Bootcamp drivers after I've already installed Windows? SVTmaniac Windows, Linux & Others on the Mac 4 Nov 4, 2013 10:41 AM
Keyboard doesn't work in bootcamp? HuskyUK Mac Basics and Help 0 Jul 18, 2013 07:13 AM
Bootcamp Windows 7 Doesn't see mouse or Keyboard mainemacuser Windows, Linux & Others on the Mac 2 Mar 28, 2013 07:48 PM
Update Windows/Bootcamp from new drivers installed on OS X? BrioBriss Windows, Linux & Others on the Mac 2 Feb 2, 2013 05:22 PM

Forum Jump

All times are GMT -5. The time now is 04:11 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC