Go Back   MacRumors Forums > News and Article Discussion > iOS Blog Discussion

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 19, 2013, 04:20 PM   #1
MacRumors
macrumors bot
 
Join Date: Apr 2001
Evasi0n Jailbreak Works with iOS 6.1.2, 1.4 Update Coming Later Today




Apple today released iOS 6.1.2, fixing a Microsoft Exchange bug that surfaced after the release of iOS 6.1.

Though there were fears that the update might fix the bugs used by the recently released iOS 6.x evasi0n jailbreak, the evad3rs team has confirmed with a tweet (via iPhoneHacks) that the evasi0n jailbreak works with iOS 6.1.2 on an iPhone 5 and an iPad mini. Testing for other devices is still ongoing.

According to evad3rs team member @planetbeing, evasi0n 1.4 will be released later today with official support for iOS 6.1.2. The new update will allow jailbreakers to update to iOS 6.1.2. When released, the download will be available from the evasi0n website.

Update: Evasi0n 1.4 is now available for download.

Article Link: Evasi0n Jailbreak Works with iOS 6.1.2, 1.4 Update Coming Later Today
MacRumors is offline   1 Reply With Quote
Old Feb 19, 2013, 04:24 PM   #2
zin
macrumors 6502
 
Join Date: May 2010
Location: United Kingdom
Phew. Huge sigh of relief there.

zin is offline   2 Reply With Quote
Old Feb 19, 2013, 04:26 PM   #3
DayOfChaos
macrumors 6502
 
Join Date: Nov 2011
Hmm, two releases and they haven't patched it? Did they give up?
DayOfChaos is offline   0 Reply With Quote
Old Feb 19, 2013, 04:27 PM   #4
bradl
macrumors 68030
 
Join Date: Jun 2008
Quote:
Originally Posted by zin View Post
Phew. Huge sigh of relief there.

Yes, a huge sigh of relief.

I quite enjoy being able to tether my Mac or my work laptop to my iPhone for legitimate, non-excessive purposes, especially when I have had unlimited data for at least 4 years.

BL.
bradl is offline   4 Reply With Quote
Old Feb 19, 2013, 04:27 PM   #5
crisss1205
macrumors 6502a
 
crisss1205's Avatar
 
Join Date: Oct 2008
Location: Long Island, New York
Send a message via AIM to crisss1205
I don't think the jailbreak vulnerabilities are really that high on Apple's priority list. It will probably be fixed with iOS 7 or a 6.2 update.

This is mostly because,
  1. Vulnerability requires physical access to device
  2. It requires passcode to be off
  3. Requires the phone to not have an encrypted backup

Something like the old Jailbreakme.com hack is higher up since the user can just visit a website and be compromised.
__________________
 27" iMac  13" Retina MacBook Pro  iPhone 5s  iPad mini
crisss1205 is offline   0 Reply With Quote
Old Feb 19, 2013, 04:32 PM   #6
Davmeister
macrumors 6502
 
Join Date: May 2009
Location: From Oxford, studying in Cardiff, UK
Quote:
Originally Posted by crisss1205 View Post
I don't think the jailbreak vulnerabilities are really that high on Apple's priority list. It will probably be fixed with iOS 7 or a 6.2 update.

This is mostly because,
  1. Vulnerability requires physical access to device
  2. It requires passcode to be off
  3. Requires the phone to not have an encrypted backup

Something like the old Jailbreakme.com hack is higher up since the user can just visit a website and be compromised.
Incorrect on one count and mostly useless on the other--does not require passcode to be off (is recommended however) and most people do not encrypt their backups anyway. But yes, physical access is required.

I doubt its just a security issue as well--I can imagine there being an embarrassment factor there too.
__________________
Yes. I own Apple products.
Medical Student in Cardiff, UK
Davmeister is offline   0 Reply With Quote
Old Feb 19, 2013, 04:34 PM   #7
Ratatapa
macrumors 6502a
 
Join Date: Apr 2011
Time to unjailbreak and rejailbreak lol
Ratatapa is offline   2 Reply With Quote
Old Feb 19, 2013, 04:35 PM   #8
crisss1205
macrumors 6502a
 
crisss1205's Avatar
 
Join Date: Oct 2008
Location: Long Island, New York
Send a message via AIM to crisss1205
Quote:
Originally Posted by Davmeister View Post
Incorrect on one count and mostly useless on the other--does not require passcode to be off (is recommended however) and most people do not encrypt their backups anyway. But yes, physical access is required.

I doubt its just a security issue as well--I can imagine there being an embarrassment factor there too.
I believe if you have an encrypted backup before, you need to turn off your passcode. I know others, including myself, needed to turn off the passcode to complete the jailbreak without an error.
__________________
 27" iMac  13" Retina MacBook Pro  iPhone 5s  iPad mini
crisss1205 is offline   0 Reply With Quote
Old Feb 19, 2013, 04:35 PM   #9
sza
macrumors regular
 
Join Date: Dec 2010
evasi0n 1.4 will be released later today with OFFICIAL support for iOS 6.1.2
sza is offline   1 Reply With Quote
Old Feb 19, 2013, 04:41 PM   #10
wacky4alanis
macrumors 6502
 
Join Date: Mar 2009
I don't even use exchange any more, so I probably won't bother upgrading.
wacky4alanis is offline   0 Reply With Quote
Old Feb 19, 2013, 04:47 PM   #11
JPChicago
macrumors regular
 
Join Date: Nov 2012
Location: Chicago
Should I update? Really dont think its necessary. IP5 6.1 Jb
JPChicago is offline   0 Reply With Quote
Old Feb 19, 2013, 05:05 PM   #12
Nickerbocker
macrumors regular
 
Join Date: Apr 2012
I'm updating to ensure I have a proper SHSH blob save for 6.1.2.
Nickerbocker is offline   0 Reply With Quote
Old Feb 19, 2013, 05:10 PM   #13
willisbr
macrumors newbie
 
Join Date: Oct 2010
How does this work? Do I have to update, lose the jailbreak, then re-jailbreak? I currently have the latest jailbreak prior to the update. If I update and have to re-jailbreak, how do I get all of my stuff back on there?
willisbr is offline   0 Reply With Quote
Old Feb 19, 2013, 05:21 PM   #14
bonskovsky
Banned
 
Join Date: Dec 2012
Quote:
Originally Posted by DayOfChaos View Post
Hmm, two releases and they haven't patched it? Did they give up?
Apple does not discourage jailbreaking.
bonskovsky is offline   0 Reply With Quote
Old Feb 19, 2013, 05:30 PM   #15
scotty588
macrumors 6502
 
Join Date: Jan 2007
Location: Carlsbad, CA
Quote:
Originally Posted by Nickerbocker View Post
I'm updating to ensure I have a proper SHSH blob save for 6.1.2.
Blobs don't matter anymore.
https://twitter.com/MuscleNerd/statu...46514806501377
scotty588 is offline   0 Reply With Quote
Old Feb 19, 2013, 05:37 PM   #16
pacohaas
macrumors 6502a
 
Join Date: Jan 2006
Quote:
Originally Posted by sza View Post
evasi0n 1.4 will be released later today with OFFICIAL support for iOS 6.1.2
It's released now.
pacohaas is offline   1 Reply With Quote
Old Feb 19, 2013, 05:48 PM   #17
Nickerbocker
macrumors regular
 
Join Date: Apr 2012
Quote:
Originally Posted by scotty588 View Post
Hmmm . So really, it is probably still best to update to the latest iOS version if it supports jailbreaking. Might not have a problem with the Exchange bug now, but I maybe in the future. Seems like a good idea to update now than wait until 6.2 or w/e is released that makes the JB not work anymore.
Nickerbocker is offline   0 Reply With Quote
Old Feb 19, 2013, 06:15 PM   #18
adammusic
macrumors regular
 
Join Date: Jun 2007
So do you have to update. then re jailbreak? Any way to save all your tweaks?
adammusic is offline   0 Reply With Quote
Old Feb 19, 2013, 06:18 PM   #19
locoboi187
macrumors 6502a
 
Join Date: Oct 2012
Why is MuscleNerd saying not to update? I mean it's still jailbreakable.
__________________
Macbook Pro Retina 15"
iPhone 6 64GB - Space Gray
TV 3
locoboi187 is offline   0 Reply With Quote
Old Feb 19, 2013, 07:07 PM   #20
PrayForDeath
macrumors 6502
 
Join Date: Jan 2012
Quote:
Originally Posted by scotty588 View Post
They still matter, they just won't let you downgrade anymore. However, if you want to restore your device for whatever reason, and your current firmware is no longer signed, you will be forced to update unless you have your blobs saved.
PrayForDeath is offline   0 Reply With Quote
Old Feb 19, 2013, 08:13 PM   #21
ghostface147
macrumors 65816
 
Join Date: May 2008
Anyone updating with no issues using iTunes 11.0.2?
ghostface147 is offline   0 Reply With Quote
Old Feb 19, 2013, 09:07 PM   #22
i0Nic
macrumors 65816
 
Join Date: May 2006
Location: Sydney, Australia
Quote:
Originally Posted by willisbr View Post
How does this work? Do I have to update, lose the jailbreak, then re-jailbreak? I currently have the latest jailbreak prior to the update. If I update and have to re-jailbreak, how do I get all of my stuff back on there?
Very interested to know this as well if anyone can help?
__________________
peterpetrovski.com - thoughts on the connected future.
i0Nic is offline   0 Reply With Quote
Old Feb 19, 2013, 09:36 PM   #23
pacohaas
macrumors 6502a
 
Join Date: Jan 2006
Quote:
Originally Posted by i0Nic View Post
Very interested to know this as well if anyone can help?
Yes, you need to restore to 6.1.2 in iTunes, then the JB is just the same as any other fresh 6.1.2 device. Then you can set your phone up from a backup (you did remember to back up right?) and then restore your Cydia purchases. There are Cydia apps to assist with restoring those apps, but its easier to just reinstall them from a list if you are sure to write down the JB apps that you use.
pacohaas is offline   0 Reply With Quote
Old Feb 20, 2013, 12:14 AM   #24
pacohaas
macrumors 6502a
 
Join Date: Jan 2006
Quote:
Originally Posted by ghostface147 View Post
Anyone updating with no issues using iTunes 11.0.2?
I updated to iTunes 11.0.2 first, then restored my JB'd 4S to original state 6.1.2, then was able to re-JB with evasi0n, launch Cydia to prepare the JB filesystem, then restore my phone from the backup I had just taken in iTunes.

A bit cumbersome, but certainly not difficult. The restore says it's got ~20 minutes left, but based how long it took last time to actually complete the restore and do the initial sync of my apps, songs and stuff in iTunes, I'm going to let it run overnight and hope things look good in the morning.
pacohaas is offline   0 Reply With Quote
Old Feb 20, 2013, 12:43 AM   #25
scotty588
macrumors 6502
 
Join Date: Jan 2007
Location: Carlsbad, CA
Quote:
Originally Posted by PrayForDeath View Post
They still matter, they just won't let you downgrade anymore. However, if you want to restore your device for whatever reason, and your current firmware is no longer signed, you will be forced to update unless you have your blobs saved.
Don't think this is true. You can't downgrade at all. According to this reddit thread the only reason blobs are being saved is if a future bootrom exploit is found and then you could use them to downgrade. At this point it is not possible.

http://www.reddit.com/r/jailbreak/co...nformed_about/
scotty588 is offline   0 Reply With Quote

Reply
MacRumors Forums > News and Article Discussion > iOS Blog Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
General: iOS 7 Beta 4 patches evasi0n 7 jailbreak afterafx Jailbreaks and iOS Hacks 77 Jan 22, 2014 12:22 PM
iPhone: How stable is this evasi0n iOS 6 Jailbreak? Brother Esau Jailbreaks and iOS Hacks 12 Mar 13, 2013 09:06 AM
iPhone: Safari crash after evasi0n jailbreak iOS 6.1 Kidvicious1973 Jailbreaks and iOS Hacks 6 Feb 26, 2013 12:03 AM
iPhone: evasi0n - iOS 6.x Jailbreak - FEEDBACK Monkeydo Jailbreaks and iOS Hacks 36 Feb 6, 2013 05:33 PM
iPhone: iOS 5.1.1 - evasi0n jailbreak - newbie Knuckleheadz Jailbreaks and iOS Hacks 1 Feb 4, 2013 01:22 PM

Forum Jump

All times are GMT -5. The time now is 03:29 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC