Go Back   MacRumors Forums > Special Interests > Mac and PC Games

Reply
 
Thread Tools Search this Thread Display Modes
Old May 12, 2010, 04:58 PM   #1
gohome190
macrumors regular
 
Join Date: Feb 2007
"Unable to connect to Steam network"

Whenever I try to login to my existing steam account... It says "unable to connect to steam network". I am connected to the internet... so why is it not connecting?
thanks
gohome190 is offline   0 Reply With Quote
Old May 12, 2010, 05:02 PM   #2
tnisatard
macrumors 6502
 
Join Date: Apr 2008
i have the same problem too

i also have windows running on my macbook wiht steam installed, i heard that if you update steam on windows it should fix it, but i still have the problem, hopefully someone will be able to figure this out
tnisatard is offline   0 Reply With Quote
Old May 12, 2010, 06:39 PM   #3
crunchbox
macrumors newbie
 
Join Date: Feb 2008
Location: Brisbane, Australia
Yeah, looks like I have the same problem here too...

Any help would be greatly appreciated!
crunchbox is offline   0 Reply With Quote
Old May 12, 2010, 07:21 PM   #4
Vegeta-san
macrumors 6502
 
Join Date: Aug 2006
I'm having the same problem. Turn off Little Snitch and it still does it...
Vegeta-san is offline   0 Reply With Quote
Old May 12, 2010, 07:35 PM   #5
crunchbox
macrumors newbie
 
Join Date: Feb 2008
Location: Brisbane, Australia
Yeah I've tried on two different networks and same result...

I really can't work out what the problem is, usually don't have any problems. I wonder if there is something we all have in common?

Behind a firewalled router? Yes
Use port forwarding? Yes
In Australia? Yes
Use Little Snitch? Yes

I can login to Steam without issue via bootcamp Windows 7 on my MBP... make's no sense...
crunchbox is offline   0 Reply With Quote
Old May 12, 2010, 07:52 PM   #6
Rodus
macrumors 6502a
 
Rodus's Avatar
 
Join Date: Oct 2008
Location: Midlands, UK
Typical. Valve have ballsed up the Mac release, not really surprising as this is a fairly regular occurrence with them. Firewall etc seems to make no difference and at the moment even a 'create new account' isn't working. This'll probably be fixed soon in a client update.
__________________
27" iMac i5, iPad, iPhone 4S
John Pierce: After growing wildly for years, the field of computing appears to be reaching its infancy.
Rodus is offline   0 Reply With Quote
Old May 13, 2010, 12:56 AM   #7
crunchbox
macrumors newbie
 
Join Date: Feb 2008
Location: Brisbane, Australia
FIX: Steam unable to connect - Stuck in Offline mode

So after some manic hunting around it seems the fix is to completely uninstall PeerGuardian for OSX. I had to re-download the PeerGuardian installer dmg to get the uninstaller. I ran that twice (to be sure) and then re-launched the Steam app. Immediately could log in without issues...

Hope this helps...

I remember this happening to me years ago on windows too. PG must block Steam servers. Makes sense...
crunchbox is offline   0 Reply With Quote
Old May 14, 2010, 04:18 PM   #8
Vegeta-san
macrumors 6502
 
Join Date: Aug 2006
Seriously? Delete PeerGuardian? There has to be a better solution...Either editing a setting in Peerguardian or configuring Steam so it doesn't run into the same problem or something....I use Peerguardian...Don't wanna delete it. Anyone have any other suggestions?
Vegeta-san is offline   0 Reply With Quote
Old May 15, 2010, 05:27 PM   #9
RollTide
macrumors 6502
 
Join Date: Mar 2006
Location: Alabama
I have installed/restarted/updated everything and whenever I try and open steam after a fresh install, this is as far as I get. I have tried multiple networks

Any Ideas!?
Attached Thumbnails
Click image for larger version

Name:	Picture 3.png
Views:	6357
Size:	731.5 KB
ID:	226365  
__________________
Peter: Fox has one of those new reality shows at eight, "Fast animals, slow children"
RollTide is offline   0 Reply With Quote
Old May 15, 2010, 06:12 PM   #10
Conexionz
macrumors newbie
 
Join Date: Jun 2009
Quote:
Originally Posted by crunchbox View Post
So after some manic hunting around it seems the fix is to completely uninstall PeerGuardian for OSX. I had to re-download the PeerGuardian installer dmg to get the uninstaller. I ran that twice (to be sure) and then re-launched the Steam app. Immediately could log in without issues...

Hope this helps...

I remember this happening to me years ago on windows too. PG must block Steam servers. Makes sense...
Quote:
Originally Posted by Vegeta-san View Post
Seriously? Delete PeerGuardian? There has to be a better solution...Either editing a setting in Peerguardian or configuring Steam so it doesn't run into the same problem or something....I use Peerguardian...Don't wanna delete it. Anyone have any other suggestions?
I was having the same problem and had PG enabled. You don't have to delete PG, just temporarily disable PG's filters when using Steam.
Conexionz is offline   0 Reply With Quote
Old May 15, 2010, 08:01 PM   #11
Vegeta-san
macrumors 6502
 
Join Date: Aug 2006
Quote:
Originally Posted by Conexionz View Post
I was having the same problem and had PG enabled. You don't have to delete PG, just temporarily disable PG's filters when using Steam.
DUDE YOU FUC*ING ROCK! WIN! TOTALLY WORKED!
Vegeta-san is offline   0 Reply With Quote
Old May 15, 2010, 10:05 PM   #12
ethan86
macrumors member
 
Join Date: Jul 2009
I'm having the same problem when I try to install Steam (it looks similar to what's in Rolltide's picture). The thing is, I don't have PeerGuardian installed (never heard of it either). I've tried running the installer with my iMac wirelessly connected to my network and hardwired into the router and modem, all with the same network error results. I've never used steam before, so I'm not really sure how to troubleshoot it. Does anyone have any ideas?
ethan86 is offline   0 Reply With Quote
Old May 15, 2010, 10:44 PM   #13
RollTide
macrumors 6502
 
Join Date: Mar 2006
Location: Alabama
Quote:
Originally Posted by ethan86 View Post
I'm having the same problem when I try to install Steam (it looks similar to what's in Rolltide's picture). The thing is, I don't have PeerGuardian installed (never heard of it either). I've tried running the installer with my iMac wirelessly connected to my network and hardwired into the router and modem, all with the same network error results. I've never used steam before, so I'm not really sure how to troubleshoot it. Does anyone have any ideas?
Completely in the same boat with you except I play Steam on the windows side. I don't use PG either. The main frustration is that you cannot even get to a menu TO troubleshoot!
__________________
Peter: Fox has one of those new reality shows at eight, "Fast animals, slow children"
RollTide is offline   0 Reply With Quote
Old May 15, 2010, 11:06 PM   #14
ethan86
macrumors member
 
Join Date: Jul 2009
I just tried reinstalling Steam and when it failed, I checked my router's logs. I didn't see anything being denied, so the router isn't the problem. Since a lot of other people are having problems, it must be on Valve's side.
ethan86 is offline   0 Reply With Quote
Old May 15, 2010, 11:41 PM   #15
gumbyx84
macrumors 6502
 
Join Date: Dec 2008
Not sure if its a problem at Valve. I can log in without any issues.
__________________
MBP 4,1 (Mid 2008), 2.4Ghz C2D, 4GB RAM, 350GB HD
Gaming Consoles: NES, Genesis w/ Sega CD, SNES, Saturn, N64, Xbox (modded w/ XBMC), Wii, PS3, DS Lite, DSi XL, 3DS, PSP (2k, hacked)
gumbyx84 is offline   0 Reply With Quote
Old May 16, 2010, 12:28 AM   #16
knew2mack
macrumors regular
 
Join Date: Sep 2009
Location: The Beach
Same problem with me too. I don't know what PeerGuardian is. Does anyone have any suggestions? I really want to take advantage of this game being free for now......

thanks
knew2mack is offline   0 Reply With Quote
Old May 16, 2010, 12:36 AM   #17
gumbyx84
macrumors 6502
 
Join Date: Dec 2008
I just tired downloading a demo of World of Goo but was unable to. Said the servers were too busy to handle my request. Seems Valve servers are being hit harder then they thought. Not sure why some people (like me) can log in and other can't.

Best I can suggest is wait till Monday to see if Valve fixes the problem. If they don't, or you want to take immediate action, contact Valve tech support and complain.
__________________
MBP 4,1 (Mid 2008), 2.4Ghz C2D, 4GB RAM, 350GB HD
Gaming Consoles: NES, Genesis w/ Sega CD, SNES, Saturn, N64, Xbox (modded w/ XBMC), Wii, PS3, DS Lite, DSi XL, 3DS, PSP (2k, hacked)
gumbyx84 is offline   0 Reply With Quote
Old May 16, 2010, 01:10 AM   #18
The Final Cut
macrumors 6502
 
Join Date: Sep 2009
Quote:
Originally Posted by gohome190 View Post
Whenever I try to login to my existing steam account... It says "unable to connect to steam network". I am connected to the internet... so why is it not connecting?
thanks
looking at how pathetic steam on mac is right now, consider yourself lucky. There is basically 1 game from 3 years ago and a maxed out 20,000 mac pro probaly could not get more than 20 fps out of it.
The Final Cut is offline   0 Reply With Quote
Old May 16, 2010, 07:09 AM   #19
Rodus
macrumors 6502a
 
Rodus's Avatar
 
Join Date: Oct 2008
Location: Midlands, UK
As a troubleshooting exercise try turning your router firewall off. At least then you'll know for sure if that's the problem or not.
__________________
27" iMac i5, iPad, iPhone 4S
John Pierce: After growing wildly for years, the field of computing appears to be reaching its infancy.
Rodus is offline   0 Reply With Quote
Old May 16, 2010, 07:34 AM   #20
gumbyx84
macrumors 6502
 
Join Date: Dec 2008
Quote:
Originally Posted by The Final Cut View Post
looking at how pathetic steam on mac is right now, consider yourself lucky. There is basically 1 game from 3 years ago and a maxed out 20,000 mac pro probaly could not get more than 20 fps out of it.
Off topic and reeks of troll.

Anyway, just tried downloading World of Goo demo and it works now. Anyone of you guys having problems tried logging in recently?
__________________
MBP 4,1 (Mid 2008), 2.4Ghz C2D, 4GB RAM, 350GB HD
Gaming Consoles: NES, Genesis w/ Sega CD, SNES, Saturn, N64, Xbox (modded w/ XBMC), Wii, PS3, DS Lite, DSi XL, 3DS, PSP (2k, hacked)
gumbyx84 is offline   0 Reply With Quote
Old May 16, 2010, 09:43 AM   #21
Vegeta-san
macrumors 6502
 
Join Date: Aug 2006
Quote:
Originally Posted by The Final Cut View Post
looking at how pathetic steam on mac is right now, consider yourself lucky. There is basically 1 game from 3 years ago and a maxed out 20,000 mac pro probaly could not get more than 20 fps out of it.
Might wanna look into something being wrong with your machine bro. I've got a late 2006 2.33 Ghz MBP that is running Portal on high with no problems. Don't know how to bring up the console and figure out the FPS, but I can visually tell you its hitting higher than 30 FPS.
Vegeta-san is offline   0 Reply With Quote
Old May 17, 2010, 12:32 AM   #22
HackDaBox
macrumors newbie
 
Join Date: Nov 2009
Complete Fix , Tested on my iMac and Macbook Pro !

If you have peer guardian installed you must disable it by doing this...

Start Peer Guardian , control click on the icon in the Dock. Choose Disable Filters. Quit Peer Guardian. Try Steam again !

Now you still need to make a new empty folder called Steam in your Application Support folder which is inside your Library folder which is inside your account name !

Go to Finder then Double click on your account name ( which has a little house next to it in the sidebar of Finder ) , Double click on Library , Double Click on Application Support. Now control click or right click and choose New Folder , finally rename the new folder to Steam.

The full path is yourusername/Library/Application Support/Steam.

Enjoy !

HackDaBox!
HackDaBox is offline   0 Reply With Quote
Old May 29, 2010, 10:08 AM   #23
icBigMike
macrumors newbie
 
Join Date: Sep 2009
Location: Chicago
same problem. I don't have PG installed. Just started happening after steam auto updated itself when I opened the app.

edit:
Fixed. I turned Airport Off...then started steam app in offline mode. Started fine. Then turned Airport ON, In steam - Account - Go Online, it restarted the steam app, and I was able to log in just fine.
__________________
13" MBP, 2.53GHz, 8 GB RAM, 256GB Samsung SSD; 3G iPad 2 32GB Black, iPad2 16GB Black Wifi , iPhone 5s 16GB, Linux Engineer

Last edited by icBigMike; May 29, 2010 at 10:14 AM.
icBigMike is offline   0 Reply With Quote
Old May 29, 2010, 02:19 PM   #24
sandman42
macrumors 6502a
 
sandman42's Avatar
 
Join Date: Oct 2003
Location: Seattle
Quote:
Originally Posted by icBigMike View Post
same problem. I don't have PG installed. Just started happening after steam auto updated itself when I opened the app.

edit:
Fixed. I turned Airport Off...then started steam app in offline mode. Started fine. Then turned Airport ON, In steam - Account - Go Online, it restarted the steam app, and I was able to log in just fine.
Same problem after today's update, essentially same solution worked for me too: after turning Airport off and starting Steam off line, I quit it myself, enabled Airport, then restarted Steam and was able to connect. Thanks!!
__________________
Race fast, safe car.
sandman42 is offline   0 Reply With Quote
Old May 30, 2010, 04:07 AM   #25
toolbox
macrumors 68020
 
toolbox's Avatar
 
Join Date: Oct 2007
Location: Australia (WA)
Mine was doing this, turns out i had firewall rules in my router that were killing the connection. Now all is good
__________________
2009 iMac 27 inch | i7 2.8 | 1 TB | 16GB DDR3
iPhone 3gs | iPhone 4 | iPhone 4s | iPad 1 | iPad 2
toolbox is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Mac and PC Games

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
"We are unable to connect at this time." melterx12 iPhone 3 Sep 14, 2014 08:38 PM
iPhone 5 "Unable to join the network" help!!! avjp87 iPhone Tips, Help and Troubleshooting 10 Feb 2, 2014 08:22 PM
HP Printer on network always paused and "unable to connect" nyctravis OS X Mavericks (10.9) 1 Oct 28, 2013 08:16 AM
iPhone: [3GS | 6.0.1 | 05.16.07] "unable to load network list" // "no service" Moritz1 Jailbreaks and iOS Hacks 11 Jan 22, 2013 11:36 AM
HELP: Unable to join the network "ABC" Hankster iPhone 0 Sep 24, 2012 04:46 PM

Forum Jump

All times are GMT -5. The time now is 06:47 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC