Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPod

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 13, 2008, 12:05 AM   #1
Twilight Elk
macrumors regular
 
Join Date: Sep 2007
Location: Arizona
Send a message via MSN to Twilight Elk
iPod Ejecting by Itself; Won't Charge; Sync With iTunes

It's an 80gb iPod Classic; It will connect to the PC for only 3 seconds, then it will eject without syncing or charging. I don't want to restore.
__________________
-Elk
iPod Classic 80gb (Black)
Aluminum MacBook 2.4GHz 4GB RAM 250GB HHD
(Yay, my first Mac )
Twilight Elk is offline   0 Reply With Quote
Old Feb 18, 2008, 05:19 PM   #2
Twilight Elk
Thread Starter
macrumors regular
 
Join Date: Sep 2007
Location: Arizona
Send a message via MSN to Twilight Elk
Reviving this thread because I did not get an answer. If I could get a solution to this problem, it would be greatly appreciated.
__________________
-Elk
iPod Classic 80gb (Black)
Aluminum MacBook 2.4GHz 4GB RAM 250GB HHD
(Yay, my first Mac )
Twilight Elk is offline   0 Reply With Quote
Old Feb 13, 2009, 06:11 PM   #3
jewels
macrumors newbie
 
Join Date: Jan 2009
No one seems to have an answer to this problem.

I too have an 80 Gb iPod Classic that suddenly ejects itself soon after I launch itunes. This is also a new problem- this only started about a month ago.

(If itunes does not automatically launch when I connect the iPod I noticed that the iPod stays connected)
jewels is offline   0 Reply With Quote
Old Feb 13, 2009, 06:14 PM   #4
nick9191
macrumors 68040
 
Join Date: Feb 2008
Location: Britain
Could be a bad USB cable. Try taking it in to a store (they wont charge for a new cable).
nick9191 is offline   0 Reply With Quote
Old Feb 18, 2009, 01:06 PM   #5
richardhunt
macrumors regular
 
Join Date: Oct 2007
It's a bad cable or it's too long. I have this issue with a long cable that came with a 3rd party charger. It works to charge the ipod, heck it even works with an Iphone, it just won't work with the classic and itunes for some reason.
richardhunt is offline   0 Reply With Quote
Old Mar 15, 2009, 05:27 PM   #6
quartzz
macrumors newbie
 
Join Date: Mar 2009
I'm having this problem and still looking for a solution.

my problem, i think, is caused by too many usb devices.

if i have my hauppauge usb tv box, and-or speedtouch adsl modem connected, my ipod disconnects straight away.
quartzz is offline   0 Reply With Quote
Old Oct 1, 2009, 08:35 AM   #7
sas5209
macrumors newbie
 
Join Date: Oct 2009
Possible bad USB port?

I had this same problem a couple of months ago. Then, all of a sudden it stopped. I didn't think any more about it for a while. Then a couple of days ago I tried plugging in a jump drive, and my pc would not read it, it kept ejecting and reloading. I thought it was a problem with my jump drive. Just a little while later, I plugged my iPod Nano into the same USB port and again, it kept ejecting itself. I then tried a different USB port, and both my jump drive and my Nano worked fine.

Worth a try!
sas5209 is offline   1 Reply With Quote
Old Oct 21, 2009, 02:21 AM   #8
DaninFuchs
macrumors newbie
 
Join Date: Oct 2009
Solved?

Just signed up to throw this out - my roomie has had this problem, iPod Video 80gb Classic fails to sync, disconnects after 3-5 seconds, etc etc.....

Plug it into a powered USB hub. We did, and it worked - my guess is it is due to the device spinning up its hard drive, and overdrawing from the USB port, causing damage (to some) and/or disconnection. Hope this helps.
DaninFuchs is offline   0 Reply With Quote
Old May 23, 2011, 08:39 AM   #9
rembrant
macrumors newbie
 
Join Date: May 2011
Usb

It has nothing to do with usb cable. I have the original usb cable with my ipod classic 80 GB and I had this same problem. Till 3-5 sec connected and auto ejecting.

I plugged the cable into another USB port on my pc and it is now working.
rembrant is offline   0 Reply With Quote
Old Jan 19, 2012, 09:19 PM   #10
jonnynitro138
macrumors newbie
 
Join Date: Jan 2012
Iod keeps ejecting

Using a powered USB hub does fixes the problem of having the ipod ejecting itself.
jonnynitro138 is offline   0 Reply With Quote
Old Feb 13, 2012, 12:40 AM   #11
greg.fenton
macrumors newbie
 
Join Date: Feb 2012
Simply wait

On xp64, iTunes sees my iPod then after 2-3 seconds without synchronizing, the iPod disconnects. iTunes still "sees" the iPod, but clicking "Sync" has iTunes freeze while the iPod is blissfully unaware of being connected.

The answer, it seems, is simply to wait. If I wait for 1 to 2 minutes and then have iTunes sync again (clicking the "Sync" button or right-click >> Sync), then the iPod will connect after about 20 seconds and a successful sync ensues.

Bizarre...but then again, I'm running xp64 with iTunes 10.5.2.11 and a Classic 120GB iPod.

Hope this helps a few folks out there (like me when I google this problem again),
greg.fenton
greg.fenton is offline   0 Reply With Quote
Old Feb 13, 2012, 05:34 AM   #12
Dagless
macrumors Core
 
Dagless's Avatar
 
Join Date: Jan 2005
It has become sentient.
__________________
Maybe if everyone who'd ever been close to you had died, you'd be sarcastic, too.
Macrumors Steam Group
Dagless is offline   0 Reply With Quote
Old Apr 27, 2013, 01:06 AM   #13
Lin-Lin
macrumors newbie
 
Join Date: Sep 2011
Quote:
Originally Posted by sas5209 View Post
I had this same problem a couple of months ago. Then, all of a sudden it stopped. I didn't think any more about it for a while. Then a couple of days ago I tried plugging in a jump drive, and my pc would not read it, it kept ejecting and reloading. I thought it was a problem with my jump drive. Just a little while later, I plugged my iPod Nano into the same USB port and again, it kept ejecting itself. I then tried a different USB port, and both my jump drive and my Nano worked fine.

Worth a try!
THIS worked for me! now it's syncing just fine
Lin-Lin is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPod

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Trying to sync .m4a music files to iPhone 5S. They play in iTunes but won't sync. Maverick1337 iPhone 3 Apr 8, 2014 01:50 AM
Ipod Nano 7th Gen Won't Sync Right With iTunes slynger iPod 2 Jan 3, 2014 08:41 AM
iPod Touch won't charge! BananasAreC00l iPod touch 8 Dec 27, 2013 04:32 PM
4S won't sync or charge after upgrading to iOS 7 nathangello iPhone Tips, Help and Troubleshooting 2 Sep 22, 2013 07:19 PM
iPod Touch: My IPod touch won't charge essammo Jailbreaks and iOS Hacks 2 Jun 12, 2012 08:16 AM

Forum Jump

All times are GMT -5. The time now is 12:00 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC