Go Back   MacRumors Forums > Apple Hardware > Desktops > iMac

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 4, 2013, 09:17 AM   #1
Twimfy
macrumors 6502a
 
Join Date: Sep 2011
Location: UK
iMac 2008. Inverter cable, Inverter or Screen?

I have a strange problem with my 2008 iMac.

At first I thought it might be the GPU as I have the dreaded Geforce 8800GS.

However now I fear it may be a screen problem. The first symptom was that the brightness controls now no longer work (both on the keyboard and in sys prefs).

Now when I start the machine from cold the backlight flickers on and off for around a minute, as soon as the system warms up it will stay on all day and everyday no matter what I do.

When it does flicker black I can still see the desktop running in the background and the system doesn't freeze as I can move windows around etc.

So does anyone know if it's the inverter cable or the inverter itself?

I'm hoping it's the former as I can source the cable relatively cheaply from the states. (Unless someone knows where I can find one in the UK?)

I just find it weird that the machine will function fine (sans brightness controls) once it has been running for a few minutes.

Any info would be great. I've done extensive googling on the subject but cannot find anyone who describes my problem exactly.

Thanks.
Twimfy is offline   0 Reply With Quote
Old Feb 4, 2013, 09:50 AM   #2
Brian Y
macrumors 68020
 
Join Date: Oct 2012
Sounds like it's the inverter to me. The cable wouldn't stop working when it'd warmed up.
Brian Y is offline   0 Reply With Quote
Old Feb 4, 2013, 09:57 AM   #3
Twimfy
Thread Starter
macrumors 6502a
 
Join Date: Sep 2011
Location: UK
Quote:
Originally Posted by Brian Y View Post
Sounds like it's the inverter to me. The cable wouldn't stop working when it'd warmed up.
That's what I feared.

Well in the meantime I've ordered a new cable which was very cheap. Will try that first as I'm on a budget at the moment.

If that fails to make a difference I can order a new inverter once my cash flow picks up. I really don't want to spend too much money on this Mac as it's probably getting close to the end of its life anyway especially with that GPU that's doomed to fail sometime soon.
Twimfy is offline   0 Reply With Quote
Old Feb 4, 2013, 10:00 AM   #4
Brian Y
macrumors 68020
 
Join Date: Oct 2012
Quote:
Originally Posted by Twimfy View Post
That's what I feared.

Well in the meantime I've ordered a new cable which was very cheap. Will try that first as I'm on a budget at the moment.

If that fails to make a difference I can order a new inverter once my cash flow picks up. I really don't want to spend too much money on this Mac as it's probably getting close to the end of its life anyway especially with that GPU that's doomed to fail sometime soon.
Bear in mind it might still be the LCD panel instead of the Inverter. Apple don't carry the parts separately, so I'm not sure how you could diagnose it further without actually buying an inverter.
Brian Y is offline   0 Reply With Quote
Old Feb 4, 2013, 02:24 PM   #5
Twimfy
Thread Starter
macrumors 6502a
 
Join Date: Sep 2011
Location: UK
Quote:
Originally Posted by Brian Y View Post
Bear in mind it might still be the LCD panel instead of the Inverter. Apple don't carry the parts separately, so I'm not sure how you could diagnose it further without actually buying an inverter.
I've sourced an inverter too. Will install both and report back. Might be handy info for anyone experiencing the same problem.

EDIT: The new cable turned up today but I've yet to fit it. What is weird is that the brightness controls decided to work again today and there's no dips in brightness, the display is solid.

I've yet to let it go cold since this thread was started though so it may still have the issue if left off for a while.

Last edited by Twimfy; Feb 6, 2013 at 04:03 PM. Reason: New information.
Twimfy is offline   0 Reply With Quote
Old Feb 10, 2013, 07:13 PM   #6
Twimfy
Thread Starter
macrumors 6502a
 
Join Date: Sep 2011
Location: UK
Well just an update incase anyone has the same issue.

Replacing only the inverter cable fixed the problem, also I was suffering from ghosting/screen burn in one dark area on the right hand side of the screen, that too has gone, looks like a totally brand new screen.

Hopefully the random freezes will stop too now I've also replaced my broken SuperDrive.
Twimfy is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > iMac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Palm rest cracking & inverter cable or board? Curtis 92 MacBook 1 Mar 15, 2014 08:08 PM
Inverter cable/board problem ??? mattpreece87 MacBook 1 Aug 30, 2013 07:50 PM
No Backlight even with new LCD and inverter board + cable andymac24 MacBook 0 Apr 24, 2013 09:15 AM
Installed inverter cable now boots up with white screen N00DLE MacBook 0 Jan 26, 2013 09:53 PM
2009 White 13" macbook inverter/cable problem? nyclaw MacBook 0 Aug 22, 2012 12:06 AM

Forum Jump

All times are GMT -5. The time now is 07:13 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC