Go Back   MacRumors Forums > Special Interests > Mac and PC Games

Thread Tools Search this Thread Display Modes
Old Sep 12, 2012, 07:15 PM   #1
macrumors newbie
Join Date: Apr 2008
Jedi Academy / Jedi Outcast / Enemy Territory Lion Launcher

Jedi Academy Multiplayer (and a few other Q3 engine games) doesn't run on Lion/Mountain Lion because of some OpenGL issues on ATI graphics cards.

JKJALaunch is a launcher for Jedi Academy Multiplayer that forces ATI FSAA off, allowing the game to run on Lion. It also allows you to specify command-line options and force 32-bit colour (as needed on certain graphics cards). By default OpenAL is turned off by the launcher. If it is turned on then the sound system of the game is automatically restarted on launch by the launcher to avoid a slowdown on Lion.

Hold Shift down at launch to bring up the options window, where you can choose the location of Jedi Academy Multiplayer and set the command-line options (such as launching mods with +set fs_game modname).

Otherwise, the launcher will just launch the application from the saved path with the saved options (if there are any).

When you're asked to find Jedi Academy MP, you can also select Jedi Academy, Jedi Knight II, Jedi Knight II MP or Wolfenstein ET.

(if Jedi Academy MP can be found in the same folder as JKJALaunch, and your preferences are not to launch another application in the folder, this copy will be launched regardless of the previously saved path)

You can download it from here.

There's a slightly out-of-date screenshot of the options window here.
redsaurus is offline   1 Reply With Quote
Old Sep 13, 2012, 08:17 AM   #2
Old Muley
macrumors 6502a
Old Muley's Avatar
Join Date: Jan 2009
Location: Titletown USA
Nice one! My son and I were just talking about this issue yesterday and trying to decide if these games were now dead for good, or if there was a way to continue to play them. These aren't commonly played games anymore, but we do pull them out from time to time. We'll have to try this fix out later today.
"Using the potty is an expectation for everyone." -Nurse Beining
Old Muley is offline   0 Reply With Quote
Old Feb 5, 2013, 08:30 PM   #3
macrumors 68040
MagnusVonMagnum's Avatar
Join Date: Jun 2007
Aspyr has apparently updated them since they are now on the Apple App Store and Steam just got Jedi Academy as well. I just got Jedi Academy from the App Store and tried it and it works fine in Mountain Lion at nice new widescreen high resolutions. A few OpenGL features seemed to cause slowdowns on the Intel 4000, though (glow effects, for example) but otherwise it never looked better, really.

Jedi Outcast I bought over the summer from Steam and it worked fine on my 2008 Macbook Pro in Snow Leopard. I just installed it for my Mac Mini and Mountain Lion and it won't start in full screen or windowed mode. It DOES work on that same Macbook Pro with Mountain Lion. I have no idea so far what the problem is other than the console report says "Unknown Class" for some file in the install.
Mac Mini Server 2012 (2.3GHz Quad i7, 8GB, 2x1TB RAID 0) ; External 12x Memorex Blu-Ray USB3, External WD 3x3TB,1x2TB HD USB3)
15" Matte MBP 2.4GHz, 4GB/500GB, NVidia 8600M GT; 3 ATV; 3 iPod Touch
MagnusVonMagnum is offline   0 Reply With Quote

MacRumors Forums > Special Interests > Mac and PC Games

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
OS X: Jedi Knight Jedi Academy help swafellon Mac and PC Games 11 Mar 3, 2014 04:58 PM
OS X: Jedi Academy Zoomed in anorton Mac and PC Games 8 Jul 29, 2013 12:09 PM
OS X: Jedi Knight II: Jedi Outcast - default.cfg missing? ddarko71 Mac and PC Games 0 Jun 24, 2013 08:18 PM

Forum Jump

All times are GMT -5. The time now is 04:07 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2015, MacRumors.com, LLC