Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 14, 2015, 12:37 PM   #3451
gruv2ths
macrumors newbie
 
Join Date: Feb 2011
Quote:
Originally Posted by clawhammer64 View Post
now show in Mac OS as 0%, and if i go to system preferences - power properties - the error occurs during collecting data.

I think water damage pull down SDA line of SMC.
kOhm.
So i believe that you need to start eliminating users of the Battery SM bus.
(battery, battery lever indicator, charger IC and SMC)

Sounds like you have unplugged the battery light indicator.

I would next (with the laptop off) unplug of battery with the magsafe plugged in, look and see if you see logic on both SDA and SMC pins. If so the battery was/is messing up communications on the Battery SM bus.

If the battery unplugged changes nothing, the only 2 thing on that SM bus that you have not eliminated are the charge controller and the SMC.

This is drastic, but it is how i narrowed down my sm bus problem.
I narrowed mine down to either the charger chip or the SMC. Since I can replace the charger chip, i cut the trace to the bad signal with an exacto at that pin of the charger IC. Doing that disconnected the charger chip from that pin on the bus.

The charger chip is being replaced now, will report back when it's done.
gruv2ths is offline   0 Reply With Quote
Old Apr 17, 2015, 02:48 AM   #3452
Lloydz1914
macrumors newbie
 
Join Date: Apr 2015
mb 13 late 2008 a1278

Hello,

First of all I want to apolagize for my english, not my native language.

I've been reading this tread for the past day (all the 139 pages) looking for some help, and learned a lot with you.

I have a mb late 2008 a1278 that doesn't turn on, only with charger or battery the same, no power.
magsafe has no led, charger IC doesn't have 12v, it has 4.04v, already changes it, had 12v for few second, then all again to 4.04v. I think that he probably is dead. I have 3.3v at power pads. only with battery have 12v, 3.3v on power pad but efi chip doesn't receive any power.

I was hopping if someone could help me

Thanks in advance.

----------

BTW i've seen that Q6910 was off, change it with a used on and now saw that R6917 has 17v on one side and ground on another

Last edited by Lloydz1914; Apr 17, 2015 at 03:56 AM.
Lloydz1914 is offline   0 Reply With Quote
Old Apr 22, 2015, 05:10 PM   #3453
sbakar
macrumors newbie
 
Join Date: Apr 2015
This is an excellent thread but I haven't found a reference to my questions.

I have a 820-2879 that had liquid spilled. There is almost no corrosion and I have made 3 passes with isopropyl alcohol and a brush. I am getting all S5 rails including 0.9V, 3.3V and 5V. I am not getting any S3 rails or S0 rails. PM_SLP_S3_L and PM_SLP_S4_L both show zero volts. I tried jumpering a working 3.3V S5 rail to the S0 enable circuit where PM_SLP_S3 goes in but the fan still doesn't turn on at least when I try bridging the power pads on the top or bottom side of the circuit. I unfortunately do not have a component that I can solder across to give the S0 enable a 3.3V supply so I have to hold the jumper wire with both hands. My questions are these: first, to go into S0 mode, don't BOTH PM_SLP_S3_L AND PM_SLP_S4_L have to be working? At least that's what I interpret from the Power Control Signals chart in the schematics. If I supply 3.3V to the PM_SLP_S3_L or PM_SLP_S4_L circuits individually, the fan does not turn on. Second, in your video, you supplied 3.3V to the S0 enable as a bypass for PM_SLP_S3_L but was PM_SLP_S4_L working? Finally, is it okay to use the power pads on the logic board as 'Power On' or should one use the keyboard power button?

I should mention that the green light comes on brightly when the MagSafe is connected, and that the battery charged properly with an orange light that turned to green in the expected time for a full charge. It seems like I should be able to figure this out but I am being held back by a lack of hands to give 3.3V to S0 enable while turning the power on!! Perhaps I should unscrew the keyboard from the laptop so that I can maneuver it more easily while keeping it connected to the logic board? I did try bridging the power pads both with and without the keyboard ribbon connected just in case that was the problem but no luck there.
sbakar is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Early 2008 MBP with SMC issue? Need ideas/suggestions... seanmuth MacBook Pro 4 Jan 10, 2015 09:48 AM
MaxOSX Tips Troubleshooting Guide Huntn Mac Basics and Help 1 Oct 11, 2013 09:52 AM
MacBook Air Hardware Troubleshooting Guide varungargi MacBook Air 0 Sep 17, 2013 01:39 AM
Mac OS X Tips Troubleshooting Guide Huntn OS X 2 Jun 18, 2013 02:18 PM

Forum Jump

All times are GMT -5. The time now is 01:28 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2015, MacRumors.com, LLC