Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 28, 2012, 07:41 PM   #1
FrenchKheldar
macrumors member
 
Join Date: May 2006
Location: Atlanta, GA
Non-smooth scrolling pdf with trackpad in Preview with 10.8

Finally upgraded to Mountain Lion and I am noticing an annoying behavior in Preview. When I two-finger scroll too quickly with my 2009 MBP trackpad, the scrolling is jerky and can skip many pages in a document. So you're scrolling a 25 page document, you are at page 2, you scroll quickly to get to page 10 and suddenly you are page 22...

I cannot replicate this with a mouse no matter how fast I scroll and I don't see a setting for trackpad scrolling speed. Slowing down the tracking speed of the trackpad seems to have no effect either... I have secrets installed but I can't find a hidden preference there either... Anyone else experiencing this? How could I fix this?

Thanks in advance !

EDIT: I also had the smooth scrolling disabled (thanks John Siracusa!) via
Quote:
defaults write -g NSScrollAnimationEnabled -bool NO
but turning this back on has no effect on this behavior.

My setup: 2009 13" MBP with 10.8.2. Full disclosure, this is a cross-post from StackExchange.
__________________
My Flickr
MBP 2.26Ghz 13" 4GB + 500GB 7.2k + SSD; iPhone 3GS
; Nikon D90
FrenchKheldar is offline   0 Reply With Quote
Old May 21, 2013, 03:36 PM   #2
sshhoott
macrumors 6502
 
Join Date: Feb 2010
Quote:
Originally Posted by FrenchKheldar View Post
Finally upgraded to Mountain Lion and I am noticing an annoying behavior in Preview. When I two-finger scroll too quickly with my 2009 MBP trackpad, the scrolling is jerky and can skip many pages in a document. So you're scrolling a 25 page document, you are at page 2, you scroll quickly to get to page 10 and suddenly you are page 22...

I cannot replicate this with a mouse no matter how fast I scroll and I don't see a setting for trackpad scrolling speed. Slowing down the tracking speed of the trackpad seems to have no effect either... I have secrets installed but I can't find a hidden preference there either... Anyone else experiencing this? How could I fix this?

Thanks in advance !

EDIT: I also had the smooth scrolling disabled (thanks John Siracusa!) via but turning this back on has no effect on this behavior.

My setup: 2009 13" MBP with 10.8.2. Full disclosure, this is a cross-post from StackExchange.
Try opening that PDF document in Safari. Safari has a much smoother hardware accelerated scrolling engine. (Right click on PDF file > open with > Safari)

From what I observed, if you scroll crazy fast on the trackpad, it keeps on accelerating and accelerating until it reaches the end of a long PDF document. The user tends to miss a lot of pages scrolling this way. I guess the only way to scroll without missing pages is to have some pause in between when you lift your fingers from the bottom of the trackpad and place them on top of the trackpad during scrolling. I hope that made sense, but do try using Safari. Cheers.
sshhoott is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Tags
10.8, preview, scrolling, trackpad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:05 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC