Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 14, 2012, 12:15 AM   #1
geoffreak
macrumors 68020
 
geoffreak's Avatar
 
Join Date: Feb 2008
Location: Texas; Wish I was in Japan
Question NVIDIA 304.79 Drivers Failing Install on rMBP in Windows 8

I cannot seem to get the NVIDIA 304.79 drivers to install under Windows 8 on my rMBP. During installation, the core graphics driver is just listed as "Failed" and the installation stops.

I am using the English (US) version of the driver and I have modified the INF file correctly. I have tried to perform a clean installation of NVIDIA drivers (under custom installation). I have tried completely removing the existing NVIDIA drivers.

Anyone else encountered this issue?
__________________
rMBP 2.6GHz 16GB 512GB | Mac Mini 2009 2.26GHz | MBP Early '08 2.4GHz | iPhone 4S 32GB | Drobo
Nimbix - Accelerated Cloud Supercomputing

Last edited by geoffreak; Aug 14, 2012 at 10:58 AM.
geoffreak is offline   0 Reply With Quote
Old Aug 14, 2012, 12:19 AM   #2
JacaByte
macrumors 6502
 
Join Date: Dec 2009
Are you sure you're not trying to install nvidia's drivers over any default graphics drivers other than Window's default frame-buffers? You might want to check and make sure that you're currently using the defaults in the Hardware and Devices control panel.

Edit: Doing a quick search for drivers on nVidia's site reveals that there are no stable drivers for the Geforce GT 650M for Windows 7/8 yet; it appears that 304.79 is a beta driver for now. You might want to consider waiting for stable drivers.
__________________
2010 15" Macbook Pro, 2.4 GHz i5, 8GB RAM, 500GB HHDD, OS X 10.8.2
MDD G4, single 1.25 GHz, 1.25GB RAM, 40GB HDD, Debian Linux 6
JacaByte is offline   0 Reply With Quote
Old Aug 14, 2012, 03:08 AM   #3
MacReloaded
macrumors 6502
 
Join Date: Oct 2007
Location: Canada
I figured it out after some experimentation. This is specific to Windows 8 and is not required in Windows 7:
  1. Open up the Charms bar.
  2. Click on Settings.
  3. Click on Change PC settings.
  4. Click on General.
  5. Under Advanced startup, click Restart now.
  6. When the blue screen shows up, click on Troubleshoot.
  7. Click on Advanced options.
  8. Click on Startup Settings.
  9. Click on Restart.
  10. Your system now reboots and when the blue screen shows up, press F7 on your keyboard.
  11. Windows boots up and then you can install the drivers with the modified INF.
__________________
iMac (24-inch, Mid 2007) | iPad 2, Air | iPhone 3G, 4, 4S, 5 | MacBook Pro (Retina, Mid 2012) (Retina, 15-inch, Early 2013)
MacReloaded is offline   3 Reply With Quote
Old Aug 14, 2012, 08:36 AM   #4
geoffreak
Thread Starter
macrumors 68020
 
geoffreak's Avatar
 
Join Date: Feb 2008
Location: Texas; Wish I was in Japan
I can't believe that actually worked, thanks!
__________________
rMBP 2.6GHz 16GB 512GB | Mac Mini 2009 2.26GHz | MBP Early '08 2.4GHz | iPhone 4S 32GB | Drobo
Nimbix - Accelerated Cloud Supercomputing
geoffreak is offline   0 Reply With Quote
Old Aug 14, 2012, 12:52 PM   #5
MacReloaded
macrumors 6502
 
Join Date: Oct 2007
Location: Canada
Quote:
Originally Posted by geoffreak View Post
I can't believe that actually worked, thanks!
You're welcome.
__________________
iMac (24-inch, Mid 2007) | iPad 2, Air | iPhone 3G, 4, 4S, 5 | MacBook Pro (Retina, Mid 2012) (Retina, 15-inch, Early 2013)
MacReloaded is offline   0 Reply With Quote
Old Aug 18, 2012, 12:13 PM   #6
crimsontwo
macrumors member
 
Join Date: Jul 2008
Quote:
Originally Posted by MacReloaded View Post
I figured it out after some experimentation. This is specific to Windows 8 and is not required in Windows 7:
  1. Open up the Charms bar.
  2. Click on Settings.
  3. Click on Change PC settings.
  4. Click on General.
  5. Under Advanced startup, click Restart now.
  6. When the blue screen shows up, click on Troubleshoot.
  7. Click on Advanced options.
  8. Click on Startup Settings.
  9. Click on Restart.
  10. Your system now reboots and when the blue screen shows up, press F7 on your keyboard.
  11. Windows boots up and then you can install the drivers with the modified INF.
WOW! After literally hours of banging my head against the wall I find this your post and... it WORKS. I'm not on a Mac but it doesn't matter. Apparently this startup mode disables automatic denial of unverified drivers. Wicked. Thanks.
crimsontwo is offline   0 Reply With Quote
Old Aug 18, 2012, 01:06 PM   #7
jenzjen
macrumors 68000
 
Join Date: Aug 2010
Quote:
Originally Posted by MacReloaded View Post
I figured it out after some experimentation. This is specific to Windows 8 and is not required in Windows 7:
  1. Open up the Charms bar.
  2. Click on Settings.
  3. Click on Change PC settings.
  4. Click on General.
  5. Under Advanced startup, click Restart now.
  6. When the blue screen shows up, click on Troubleshoot.
  7. Click on Advanced options.
  8. Click on Startup Settings.
  9. Click on Restart.
  10. Your system now reboots and when the blue screen shows up, press F7 on your keyboard.
  11. Windows boots up and then you can install the drivers with the modified INF.
Do you know how to get it to install under Windows 7?
jenzjen is offline   0 Reply With Quote
Old Aug 19, 2012, 08:50 PM   #8
Engali
macrumors member
 
Join Date: Jul 2012
Read this thread from start to finish to get it work on Windows 7
Engali is offline   0 Reply With Quote
Old Oct 29, 2012, 09:37 PM   #9
somebody32
macrumors newbie
 
Join Date: Oct 2012
If somehow anyone here cannot install nvidia drivers in the new Windows 8 full release:
1. Run the exe for the driver for the first time, and remember the location it extracted to.
2. Go to Control Panel, then Device Manager.
3. Right click your display adapter, and to update driver software.
4. Click Browse my comp, and then click Let me pick device drivers.
5. Click Have Disk, then browse to the location from step 1.
6. Go to Display.Driver under \NVIDIA\DisplayDriver\versionnum\Win8_WinVista_Win7_64\English\, then select nv_disp.inf.
7. It should now install the new driver, and your driver version should now be updated.
Cheers. --Psi
somebody32 is offline   1 Reply With Quote
Old Nov 24, 2012, 05:16 AM   #10
awj
macrumors newbie
 
Join Date: Nov 2012
Finally!

MacReloaded, a huge thanks to you sir.

I've spent the past evening and this morning trying many different methods without success. And then I found your post.

One thing I would add to anyone else who has trouble even while trying MacReloaded's solution: at first this failed for me but I then uninstalled the current NVidia driver, rebooted (Device Manager shows that it uses something like "Microsoft Compatibility Driver") and then went through MacReloaded's instructions again.

Furthermore, after I had installed the drivers using those steps, I rebooted and NVidia told me an update was available. This time it installed the drivers by itself.
awj is offline   0 Reply With Quote
Old Jan 27, 2013, 05:35 PM   #11
jlambert1
macrumors newbie
 
Join Date: Jan 2013
Windows 8 Problems

Im having a real problem as i just updated my sony vaio vgn ar750e/b to windows 8 and now have no access to my nvidia geforce 8600m gt. im new when it comes to having to modify an .inf and have tried both macreloaded's and somebody32's methods, but without having a modified driver i have yet to instal anything. Thanks in advance.
jlambert1 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Tags
304.79, driver, nvidia, rmbp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:10 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC