Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old May 12, 2013, 09:48 PM   #1
linds15
macrumors 6502a
 
Join Date: Oct 2012
Location: Great White North
Question on Multiple ATVs

i recently hooked up a third apple TV, and so now there are 2 TVs who watch much of my content from iTunes. what i hadn't ever noticed before was that when one of the ATVs is being used, a second one takes VERY LONG to load content from my mac, but once the video starts playing there is no buffering. has anyone had this and found a way to decrease the wait? sometimes it takes up to 5 minutes to load the mac
__________________
2012 Mac Mini 2.6, 16GB Crucial Ram, 256 Samsung 830 SSD 2012 MBA 1.8Ghz, 4GB Ram, 128SSD JB iPhone 5 32GB JB iPad 2 32GB ATV3
Cord Cutter w/NBA, NHL, & NFL
linds15 is offline   0 Reply With Quote
Old May 12, 2013, 09:52 PM   #2
SandboxGeneral
Moderator
 
SandboxGeneral's Avatar
 
Join Date: Sep 2010
Location: Great Lakes State
Quote:
Originally Posted by linds15 View Post
i recently hooked up a third apple TV, and so now there are 2 TVs who watch much of my content from iTunes. what i hadn't ever noticed before was that when one of the ATVs is being used, a second one takes VERY LONG to load content from my mac, but once the video starts playing there is no buffering. has anyone had this and found a way to decrease the wait? sometimes it takes up to 5 minutes to load the mac
You're probably pushing the limit of the read speeds of the hard drive by accessing multiple, and different content simultaneously. The only way to overcome that is to switch out the HDD and put in an SSD.
__________________
...the tiger striping is so beautiful it makes me want to cry.
SandboxGeneral is offline   0 Reply With Quote
Old May 12, 2013, 10:16 PM   #3
waw74
macrumors 68020
 
Join Date: May 2008
i doubt he's pushing the read speeds of the drive, uncompressed blu-rays are in the 4-6 MB/s range. you should easily be able to simultaneously pull 3 of those off a USB2 drive (USB2 is about 20-30 MB/s)
standard internal hard drive should hit 70-100MB/s

the files that you get from apple are much much lower bandwidth, probably well under 1MB/s. probably closer to .5 MB/s

(blu-rays are about 40-50 GB in size, itunes 1080 files are about 4-5 GB in size)

i would go more the issue being network related. 802.11G tops out at maybe 5 MB/s if it's good strong signal.
If both the computer and aTV are wireless, the file has to go to the router, and then to the aTV, so it counts twice towards your total bandwidth.
and also add in any internet surfing you're doing, and you're choking your network. or if you're at the far end of your house from your router, with a weak signal, your bandwidth will be even further decreased.

if both are using wireless networking, wiring either the computer, the aTV or both should improve your performance.
waw74 is offline   0 Reply With Quote
Old May 12, 2013, 10:23 PM   #4
Mrbobb
macrumors 601
 
Join Date: Aug 2012
Sum1 recently had something similar, we all thought he had a cabling problem since it was location specific, but he re-encoded his videos and that fixed it. Go figure.
Mrbobb is offline   0 Reply With Quote
Old May 13, 2013, 12:37 AM   #5
linds15
Thread Starter
macrumors 6502a
 
Join Date: Oct 2012
Location: Great White North
To add some clarity to my situation
1 files are on a USB 3.0 external
2 both the Mac and atvs are on wifi, no chance if cabling.
3 using an airport express

My issue is not with watching content, it streams with no buffering, it's the initial connection to my mini when going into the computers section that can take a very long time

Thanks all
__________________
2012 Mac Mini 2.6, 16GB Crucial Ram, 256 Samsung 830 SSD 2012 MBA 1.8Ghz, 4GB Ram, 128SSD JB iPhone 5 32GB JB iPad 2 32GB ATV3
Cord Cutter w/NBA, NHL, & NFL
linds15 is offline   0 Reply With Quote
Old May 13, 2013, 12:44 AM   #6
blueroom
macrumors 603
 
blueroom's Avatar
 
Join Date: Feb 2009
Location: Toronto, Canada
It's most likely your WiFi is the congestion point. Can you hardwire some of your devices? Which ATV are you using, is it jailbroken?

PS what's an APE w/1TB attached?
__________________
My iOS devices are not jailbroken.
Bill
My Blog
blueroom is offline   0 Reply With Quote
Old May 13, 2013, 12:59 AM   #7
linds15
Thread Starter
macrumors 6502a
 
Join Date: Oct 2012
Location: Great White North
All ATV3. None jailbroken. Can't hardwire anything, not in my control. What makes it confusing for me is that there is no issues streaming, just the initial connection.

APE is an AirPort Extreme, with a 1Tb hdd attached. Outdated need to change that
__________________
2012 Mac Mini 2.6, 16GB Crucial Ram, 256 Samsung 830 SSD 2012 MBA 1.8Ghz, 4GB Ram, 128SSD JB iPhone 5 32GB JB iPad 2 32GB ATV3
Cord Cutter w/NBA, NHL, & NFL
linds15 is offline   0 Reply With Quote
Old May 13, 2013, 02:36 AM   #8
Mrbobb
macrumors 601
 
Join Date: Aug 2012
Quote:
Originally Posted by linds15 View Post
2 both the Mac and atvs are on wifi

I would too follow others and blame your WIFI EXCEPT once it gets going, is fine you say, and 5 minutes is just dang too long.

Crucial missing information:

Does this happen to ALL files (types)?
Does this happen consistently?

OK, I remember what the other guy did, he re-encoded one of his "trouble" file to OPTIMIZED FOR STREAMING and that fixed his problem.
__________________
Solution: FREE, Explanation: Is gonna cost ya.
Mrbobb is offline   0 Reply With Quote
Old May 13, 2013, 02:56 AM   #9
Michael CM1
macrumors 601
 
Join Date: Feb 2008
Have you tried streaming two videos at once over the Internet? Like watching a couple you have purchased? If those work much quicker, you can probably eliminate the network as a problem.
__________________
13.3" 2014 MacBook Air; Mid-2010 21.5" iMac; silver iPhone 5S 32GB; white iPad Air 32 GB; third-gen TV (x2)
Michael CM1 is offline   0 Reply With Quote
Old May 13, 2013, 04:03 AM   #10
hafr
Banned
 
Join Date: Sep 2011
To me it's obvious. Two different files are located in two different places on the same drive, meaning the drive will have to work hard as heck to be able to serve both files at once.

The ATV will not start playing the file until the average buffering time/speed is enough for the whole file to be able to be played without any buffering issues if that average is kept.

This means that when the drive is already working to send a file to one ATV, accessing and sending a second file to a second ATV will be a lot slower than only sending one file with nothing else accessing the drive, so startup/buffering times will be longer.

I dare to claim that this will NOT be an issue if the first ATV has buffered the first film completely before turning on the second film.

The bottleneck isn't in the theoretical or even real life maximum transfer speed of the drive, it's in the fact that the drive is mechanical. Meaning things will have to physically move. Want to try it yourself? Write two sentences in two different places on a piece of paper. First write them one after the other, then try writing them at the same time. I guarantee you it takes you more than twice as long
hafr is offline   0 Reply With Quote
Old May 13, 2013, 04:41 PM   #11
linds15
Thread Starter
macrumors 6502a
 
Join Date: Oct 2012
Location: Great White North
Quote:
Originally Posted by Mrbobb View Post
I would too follow others and blame your WIFI EXCEPT once it gets going, is fine you say, and 5 minutes is just dang too long.

Crucial missing information:

Does this happen to ALL files (types)?
Does this happen consistently?

OK, I remember what the other guy did, he re-encoded one of his "trouble" file to OPTIMIZED FOR STREAMING and that fixed his problem.
it happens all the time. its not trying to get a file that is the issue, its connecting to my mini from the computer section of the ATV, once i can get to a file within my mac mini, it starts playing right away with no buffering, its waiting to get to the Music/TV Shows/Movies section of the ATV
__________________
2012 Mac Mini 2.6, 16GB Crucial Ram, 256 Samsung 830 SSD 2012 MBA 1.8Ghz, 4GB Ram, 128SSD JB iPhone 5 32GB JB iPad 2 32GB ATV3
Cord Cutter w/NBA, NHL, & NFL
linds15 is offline   0 Reply With Quote
Old May 13, 2013, 04:52 PM   #12
arvacker
macrumors member
 
Join Date: Oct 2011
I think OP meant that it takes a long time to get past the 'Name of iTunes library' loading screen.
I also have 3 ATV's (but wired) to my Mac Mini, and i noticed that when one hasn't been used for a while (48+hours) or if a lot of content has been added to iTunes, it takes the ATV quite some time to get past the initial loading screen. So I don't think it's wireless or hdd related. I think it's like when you load your library in your music/video's app on iPad/iPhone, it remembers it for a while, but it still requires a reload at times.
arvacker is offline   0 Reply With Quote
Old May 13, 2013, 05:25 PM   #13
Mrbobb
macrumors 601
 
Join Date: Aug 2012
Quote:
Originally Posted by linds15 View Post
it happens all the time. its not trying to get a file that is the issue, its connecting to my mini from the computer section of the ATV, once i can get to a file within my mac mini, it starts playing right away with no buffering, its waiting to get to the Music/TV Shows/Movies section of the ATV
OK, lets make this clear, you can't even to get that screen/menu where it lets you select your second file.

OK, when you doing this, u may want to watch the Mac's CPU load meter, if it stays maxed out for the duration it means your Mac hardware has no more headroom to handle the task(s) smoothly.

Hardware aside, I never liked iTunes as a media server. It feels to me bloated and built in-pieces.

Watch that cpu load meter and whether it's swapping memory during the task 'coz that would REALLY slow things down. Aside from watching the Page-Out numeric (swapping), u kinda know it's swapping too if the startup HD blinks like crazy
__________________
Solution: FREE, Explanation: Is gonna cost ya.

Last edited by Mrbobb; May 13, 2013 at 05:32 PM.
Mrbobb is offline   0 Reply With Quote
Old May 14, 2013, 03:39 PM   #14
linds15
Thread Starter
macrumors 6502a
 
Join Date: Oct 2012
Location: Great White North
Quote:
Originally Posted by Mrbobb View Post
OK, lets make this clear, you can't even to get that screen/menu where it lets you select your second file.
this is correct, i get stuck at the black screen that reading "my computer name" is loading. that takes a long time and once im in i click on any file and it plays no issue.

i restored the ATV last night, and that did not help. I now notice that it happens whether or not the other ATVs are connected and playing something.
__________________
2012 Mac Mini 2.6, 16GB Crucial Ram, 256 Samsung 830 SSD 2012 MBA 1.8Ghz, 4GB Ram, 128SSD JB iPhone 5 32GB JB iPad 2 32GB ATV3
Cord Cutter w/NBA, NHL, & NFL
linds15 is offline   0 Reply With Quote
Old May 21, 2013, 08:58 AM   #15
arvacker
macrumors member
 
Join Date: Oct 2011
Quote:
Originally Posted by linds15 View Post
this is correct, i get stuck at the black screen that reading "my computer name" is loading. that takes a long time and once im in i click on any file and it plays no issue.

i restored the ATV last night, and that did not help. I now notice that it happens whether or not the other ATVs are connected and playing something.
I've been plating around a bit more with my ATV's and noticed that it's not, like I thought I my previous post, that I needs to reload after a certain amount if time, I can trigger the long loading screen by putting my mini to sleep and going into the 'computers' menu on Apple TV, that wakes up my mini, but it then takes a minute or two to load, instead of seconds.
arvacker is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Help me understand the 5 device limit for the ATVs in my home. Having problems..... GhostMac24 Apple TV and Home Theater 63 Mar 18, 2014 11:19 AM
Media server, 10 ATVs. What hardware The-Pro Apple TV and Home Theater 17 Aug 18, 2013 03:48 PM
Why do some of my ATVs have (2) after the name? imahawki Apple TV and Home Theater 3 Feb 8, 2013 08:13 PM
Another multiple ID, multiple device, multiple phone number iMessage question mrcalabash iOS 6 3 Jan 12, 2013 07:45 PM
How often do new ATVs come out? nmills Apple TV and Home Theater 6 Jun 8, 2012 04:43 PM

Forum Jump

All times are GMT -5. The time now is 11:28 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC