Color change when opening programs - Page 3 - MacRumors Forums
Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 19, 2013, 07:02 PM   #51
fvdm
macrumors newbie
 
Join Date: Feb 2013
Location: NL
Arrow Remove faulty color profiles

I had this problem with browsing file versions (the time machine universe). For me the trick was to remove bad color profiles. Somehow OSX added two color profiles to my system on its own initiative, but they were no match with my MBP. In the Displays preference pane I had three default profiles for my MBP display and a couple more for my other displays. Two profiles had the exact same name and clicking the second of those two was impossible. The selection auto-jumped to the top of the list.

In /Library/ColorSync/Profiles/Displays I had my regular profiles (including the good Color-LCD...icc) and the two faulty ICC's. Removing those 2 equally named profiles fixed the problem for me.

Now the graphics chips auto switch without visual difference.
fvdm is offline   0 Reply With Quote
Old Feb 26, 2013, 12:58 PM   #52
Ridgback
macrumors newbie
 
Join Date: Feb 2013
thanks random4t4x14

I have an early 2011 MacBook Pro with an OCZ Vertex 4 SSD and got this problem too. I experience the change in color when opening apps like Keynote or OmniGraffle (with a document open)

Resetting the SMC worked for me. Thanks random4t4x14
Ridgback is offline   0 Reply With Quote
Old Feb 28, 2013, 09:55 AM   #53
funnyent
macrumors regular
 
Join Date: Dec 2007
I had the same problem. I couldn't figure it out, and then I disabled auto-login and restarted. Not sure why, but it has been fine for a month now.

Tim
__________________
MacBook Pro 2.2Ghz, 2GB RAM, OSX 10.5.8
Final Cut Express 4, iPhone 3GS 32GB www.funnyent.com
funnyent is offline   0 Reply With Quote
Old Mar 1, 2013, 11:50 AM   #54
baronvonfunboy
macrumors newbie
 
Join Date: Mar 2013
I just started having this happen after a clean install of ML on a new SSD. Here's (I think) how I fixed it. I was trying so many things, so I apologize if this doesn't exactly work for you. But it's definitely possible to get auto-graphics switching without the color-temp changing.

1. With no other programs open (after a fresh reboot is probably best), calibrate your monitor as you like it under System Prefs -> Display -> Color
2. Turn off auto-graphics switching under System Prefs -> Energy Saver
3. Reboot
4. Navigate to /Library/ColorSync/Profiles/Displays and delete any profile that isn't your newly calibrated display profile. (In my case, two "Display" profiles were showing up)
5. Reboot
6. Turn on auto-graphics switching under System Prefs - Energy Saver
7. Reboot

I think that should do it. I realized that it was impossible to separately calibrate the discrete graphics card because whenever it opened up the calibration application, the computer would switch back to the integrated graphics card.
baronvonfunboy is offline   0 Reply With Quote
Old Feb 8, 2014, 03:35 PM   #55
jpost-design
macrumors newbie
 
Join Date: Feb 2014
Also check auto launch apps - disable auto launch chrome worked for me

I just had this problem, and was searching for help.

In particular, the color temp of my monitor was changing when different apps launched. For example, I noticed it every time I launched Photoshop CC.

Resetting the auto launch apps via system preferences seems to have fixed it for me. Chrome somehow got set to autolaunch, and I believe was messing up the monitor color.

Quick guide here on stopping programs from auto-launch:
http://machicolate.wordpress.com/201...ly-on-startup/

I also logged out and back in, and that may play some part as well. However, logging out and back in without disabling the auto launch of Chrome made no difference at all. So that has to be connected.
jpost-design is offline   0 Reply With Quote
Old Mar 3, 2014, 12:49 PM   #56
MarcusCarpenter
macrumors 6502
 
Join Date: Feb 2013
Location: London
Had the exact same issue on a Brand new MBP, i found the problem to be Teamviewer, once i uninstalled that it never came back, installed it again and it came back. Removed again and it was gone
__________________
 15'' rMBP, 2.0GHz QC i7, 16GB, 512GB PCI-E, Intel Iris Pro
 iPhone 5s Gold 16GB
MarcusCarpenter is online now   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Multiple programs quit unexpectedly on opening widestload OS X Mavericks (10.9) 1 May 15, 2014 01:31 PM
Opening programs charisma OS X Mavericks (10.9) 3 Dec 29, 2013 05:43 AM
Programs Randomly Opening rustyb99 OS X Mavericks (10.9) 2 Dec 17, 2013 11:01 AM
Help opening programs mattmertz77 Mac Basics and Help 1 Mar 24, 2013 07:23 PM
Command to open other programs when opening another program ISJB OS X 0 Jun 27, 2012 10:28 AM

Forum Jump

All times are GMT -5. The time now is 06:49 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC