Go Back   MacRumors Forums > Apple Hardware > Desktops > Mac mini

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 7, 2012, 04:02 PM   #1
ntlord
macrumors newbie
 
Join Date: Jul 2012
2011 Mac Mini HDMI issue

Hi,

I'm currently using my mid-2011 Mac Mini running latest version of Lion as an HTPC for my TV. It is hooked up via HDMI through a Yamaha receiver to a TV. The problem that I'm having is that any time I switch to a different device on my receiver, my mac mini apparently goes to sleep because when I switch back to the mac mini, I see white snow for a second then a couple of flashes and it comes back on. Is there anyway to stop this from happening? I'd prefer to just have my mac mini not go to sleep.

Interestingly enough, this does not occur in Windows under bootcamp, so it seems like it is clearly a software issue. For now, I've been using windows, but I'd prefer to keep everything in OS X, if possible

I know there is some HDMI device (HDMI detective?) that I could hook between the mac mini and my reciever, but I'd prefer not to spend the money on that if possible.

Thanks
ntlord is offline   0 Reply With Quote
Old Jul 8, 2012, 09:37 AM   #2
Alameda
macrumors 6502
 
Join Date: Jun 2012
Only a few things can cause this -- loss of video sync and CEC come to mind. Why don't you start by disabling CEC on your Yamaha? They might give it a different name, such as HDMI control.
Alameda is offline   0 Reply With Quote
Old Jul 8, 2012, 10:08 AM   #3
ntlord
Thread Starter
macrumors newbie
 
Join Date: Jul 2012
I thought about the CEC thing already and I tried disabling HDMI control, but that didn't seem to fix it. I'll give it a try again though, it can't hurt. I don't think its a video sync thing either, because as I said it works fine on Windows, although Bootcamp drivers are a bit finicky, so maybe it doesn't matter if they lose sync.

Is there a setting in OS X that I can toggle to turn off this sleeping feature?
ntlord is offline   0 Reply With Quote
Old Jul 8, 2012, 10:56 AM   #4
ntlord
Thread Starter
macrumors newbie
 
Join Date: Jul 2012
Yup, hdmi control off, it is still happening. Any other ideas?
ntlord is offline   0 Reply With Quote
Old Jul 8, 2012, 06:53 PM   #5
Alameda
macrumors 6502
 
Join Date: Jun 2012
I just re-read your post. It sounds like what's happening is HDCP authentication. When an HDMI source, such as your Mini, sends HDCP-protected content before the authentication has been completed, you'll see the "digital snow" that you've described. There's probably nothing you can do, unless you buy an AVR with InstaPort, which keeps HDCP authenticated at all times. But the good news is that what you're seeing is just cosmetic. It's a bug in Apple's driver, but it's only cosmetic. I see this in my daughter's Mini when the monitor resumes from sleep.

If it really bothers you, one thing you can try is a DisplayPort to HDMI converter. I haven't tried this, so I have no idea if it will work, but maybe you can borrow one and try it. I'll try to borrow one from work tomorrow, if I remember.

Last edited by Alameda; Jul 8, 2012 at 07:10 PM.
Alameda is offline   0 Reply With Quote
Old Jul 8, 2012, 06:58 PM   #6
ntlord
Thread Starter
macrumors newbie
 
Join Date: Jul 2012
CEC is turned off on TV too.
ntlord is offline   0 Reply With Quote
Old Jul 8, 2012, 08:52 PM   #7
Alameda
macrumors 6502
 
Join Date: Jun 2012
Quote:
Originally Posted by ntlord View Post
CEC is turned off on TV too.
Ok, so it's not CEC, so you can go ahead and turn it back on if you want.
Alameda is offline   0 Reply With Quote
Old Jul 8, 2012, 09:50 PM   #8
philipma1957
macrumors 603
 
Join Date: Apr 2010
Quote:
Originally Posted by ntlord View Post
Hi,

I'm currently using my mid-2011 Mac Mini running latest version of Lion as an HTPC for my TV. It is hooked up via HDMI through a Yamaha receiver to a TV. The problem that I'm having is that any time I switch to a different device on my receiver, my mac mini apparently goes to sleep because when I switch back to the mac mini, I see white snow for a second then a couple of flashes and it comes back on. Is there anyway to stop this from happening? I'd prefer to just have my mac mini not go to sleep.

Interestingly enough, this does not occur in Windows under bootcamp, so it seems like it is clearly a software issue. For now, I've been using windows, but I'd prefer to keep everything in OS X, if possible

I know there is some HDMI device (HDMI detective?) that I could hook between the mac mini and my reciever, but I'd prefer not to spend the money on that if possible.

Thanks
this normal if it comes back on in less then 30 seconds it is fine.
philipma1957 is offline   0 Reply With Quote
Old Jul 9, 2012, 12:50 PM   #9
ntlord
Thread Starter
macrumors newbie
 
Join Date: Jul 2012
So then there is nothing I can do?

It ruins a bit of its function as an HTPC if it goes to sleep everytime I switch to a different device on my reciever. Is there no way to turn this off? Clearly, it's just software, as it doesn't happen under bootcamp.
ntlord is offline   0 Reply With Quote
Old Jul 9, 2012, 02:26 PM   #10
Alameda
macrumors 6502
 
Join Date: Jun 2012
Quote:
Originally Posted by ntlord View Post
So then there is nothing I can do?

It ruins a bit of its function as an HTPC if it goes to sleep everytime I switch to a different device on my reciever. Is there no way to turn this off? Clearly, it's just software, as it doesn't happen under bootcamp.
I don't exactly understand what's happening that is a problem. What I understand is that if you switch inputs on your AVR, and then you switch back to your Mac Mini, the screen displays "static" and then resumes where you expect. I can understand that this would be aesthetically undesirable, but I don't understand how it fails to make it function as an HTPC, unless there is something else it's not doing correctly or some other problem you're having. Could you please explain?
Alameda is offline   0 Reply With Quote
Old Jul 9, 2012, 06:29 PM   #11
ntlord
Thread Starter
macrumors newbie
 
Join Date: Jul 2012
You're right its mostly that it is aesthetically undesirable. However, that doesn't change the fact that I would like to disable it. But from what I'm hearing that is not possible.

Not a surprise, considering its Apple. They seem to always know whats best for their customers

Edit: I missed your post about HDCP, I'll give the adapter a whirl. I was thinking somethign like that anyway, like just hook up an extra HDMI port directly to my TV
ntlord is offline   0 Reply With Quote
Old Jul 9, 2012, 07:06 PM   #12
Alameda
macrumors 6502
 
Join Date: Jun 2012
It's not Apple's plan, it's a bug. It appears that your Mini isn't going to sleep, it's just displaying a little garbage when the HDMI port switches.

A colleague at work will bring me a DisplayPort adapter to test tomorrow. I've reproduced your bug, so I'll try it with the DisplayPort adapter and see if it goes away.
Alameda is offline   0 Reply With Quote
Old Jul 9, 2012, 07:34 PM   #13
ntlord
Thread Starter
macrumors newbie
 
Join Date: Jul 2012
Wow, thanks!
ntlord is offline   0 Reply With Quote
Old Jul 10, 2012, 05:09 AM   #14
AtomicEdge
macrumors regular
 
Join Date: Mar 2009
I get this exact same issue with my 2011 Mac Mini on my Sony receiver.

Again, in Windows it comes back in about 2 seconds, in OS X I switch and I get about 5 seconds of black screen, then a tiny flash of the desktop, then another 5 seconds before it comes up. Really strange.

I know the Mini isn't going to sleep, but I think the video chip is powering down in some way. All my power settings are set to max. Would be interesting to hear what the mini DP adapter does. Thanks!
AtomicEdge is offline   0 Reply With Quote
Old Oct 29, 2012, 07:10 PM   #15
herk619kc130
macrumors newbie
 
Join Date: Oct 2012
Having similar issue on Yamaha RX-373

My setup consists of a:
JVC 42" LT-42P300 LCDTV
Yamaha RX-373
MAC MINI Mid 2010 w/ Mountain Lion
XBOX 360
ROKU 2 XD

My issue is that after changing the receiver inputs in the normal daily use, the HDMI ports on the receiver seem to stop passing video, the MAC MINI won't negotiate with the receiver / tv. I have to factory default my television and receiver for the desktop to come back. Funny thing is the XBOX 360 is fine...but if I move the the XBOX360 to the "bad" ports, it doesn't work.

Has there been any progress on the OP?
herk619kc130 is offline   0 Reply With Quote
Old Nov 8, 2012, 10:56 AM   #16
DeadMarshall
macrumors newbie
 
Join Date: Nov 2012
Late 2012 Mac Mini HDMI Sound and Dispay

I just purchased a new Mac Mini and when I wake it up from sleeping the display is enlarged and the sound does not come out right. I am using a 1080p 32inch Olevia tv as my display connected with and HDMI cable.

A few things that fix the issue are going into my display preferences and clicking on the underscan setting (which has not moved) and it immediately adjusts the screen back to where it was. So that fixes the screen however the sound is still very wrong. Very digital and robotic sounding. If I unplug the HDMI cable and plug it back in it fixes the screen and the sound without messing with any of the settings. The same fix happens if I restart the mini all together. I was wondering if there is a way to stop this from happening at all. I thought I would just ask in this thread instead of creating a new one. Let me know if you think this should be a separate thread.
DeadMarshall is offline   0 Reply With Quote
Old Nov 8, 2012, 06:03 PM   #17
Negritude
macrumors regular
 
Join Date: Jul 2011
Quote:
Originally Posted by DeadMarshall View Post
A few things that fix the issue are going into my display preferences and clicking on the underscan setting (which has not moved) and it immediately adjusts the screen back to where it was.
Can you disable or turn off overscan on your monitor/TV? That will fix the problem permanently.
Negritude is offline   0 Reply With Quote
Old Nov 9, 2012, 11:19 AM   #18
DeadMarshall
macrumors newbie
 
Join Date: Nov 2012
Quote:
Originally Posted by Negritude View Post
Can you disable or turn off overscan on your monitor/TV? That will fix the problem permanently.
I looked through the TV settings last night and couldn't find any settings for overscan it is an off brand TV so I didn't expect much from it anyway but for whatever reason I didn't experience this issue yesterday upon waking the mini on 2 separate occasions. It had happened every single time now I will have to see if it is intermittent or just no longer happening. Thanks for the suggestion though.
DeadMarshall is offline   0 Reply With Quote
Old Nov 11, 2012, 04:11 PM   #19
Negritude
macrumors regular
 
Join Date: Jul 2011
Quote:
Originally Posted by DeadMarshall View Post
I looked through the TV settings last night and couldn't find any settings for overscan...
It might also be called "PC" or "Computer" mode, or you might have something called "A/V" mode that you can disable.
Negritude is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > Mac mini

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Can the 2011 Mac Mini support 2560x1440 through HDMI port? omvs Mac mini 32 Nov 25, 2013 01:32 AM
2011 Mac mini HDMI flickering following Mavericks T'hain Esh Kelch Mac mini 4 Oct 25, 2013 05:34 AM
Mac Mini 2012 HDMI No Signal Issue bookspinner Mac mini 11 Jan 26, 2013 02:39 PM
Has the HDMI audio issue been solved in the new Mac mini? PiroPhosphoric Mac mini 4 Oct 31, 2012 02:18 AM
Mac Mini Mid 2011 - HDMI Output Issues pismobrat Mac mini 24 Oct 12, 2012 09:16 PM

Forum Jump

All times are GMT -5. The time now is 11:08 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC