Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 27, 2012, 12:54 AM   #1
adammusic
macrumors regular
 
Join Date: Jun 2007
youtube super slow. barely loads...

so i have comcast. 52meg download / 10 upload. Youtube , netflix, etc still takes forever to load. AT 52 MEG. Why? I recently upgraded my ram to 4gb. Installed a brand new hard drive bc my old one was going. So it should have nothing to do with my computer. & comcast says everything is good on there end. They ran all new lines, got a brand new router / modem from comcast. & still webpages take forever to load and youtube / netflix lag. Help !
adammusic is offline   0 Reply With Quote
Old Nov 7, 2012, 12:35 AM   #2
PerformaGuy
macrumors member
 
Join Date: Oct 2012
Try plugging into your router directly via ethernet to rule out any AirPort card problems.
__________________
First Mac: Performa 6200CD PowerPC 603e (75 Mhz) 8 MB RAM, Latest Mac: MBP i7 (2.2 Ghz) 8GB RAM
PerformaGuy is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:53 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC