Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 21, 2012, 05:34 PM   #1
ludayoda
macrumors newbie
 
Join Date: Jun 2012
Lion won't index external hard drive.

New mac user here. Running latest Lion (10.7.4) on a Macbook pro. I have Paragon NTFS installed, and reading/writing to NTFS volumes has worked fine. However, I am having an issue with spotlight on my external hard drive (500 gb, NTFS formatted). It simply does not work. Searching my internal main hd works fine.

I have tried several suggested solutions to this problem already. This includes adding and removing the hard drive from the privacy tab of spotlight. I also tried several terminal commands that I found online such as "sudo mdutil -E" and "sudo mdutil -i on". These all indicate that indexing on my external drive is in fact on. Spotlight does not seem to be indexing the drive. HOWEVER it does return results for folders that I have opened. Seems kind of strange. Doesn't help me much, as I am not about to open 1000's of folders and files just so they can be found through spotlight.

Any suggestions to fix this?
ludayoda is offline   0 Reply With Quote
Old Jun 21, 2012, 05:43 PM   #2
GGJstudios
macrumors Westmere
 
Join Date: May 2008
Have you verified your permissions on that drive?

Spotlight: How to re-index folders or volumes
Quote:
Note: You can only add folders or items to the Privacy tab that you have ownership permissions for. For more information about ownership and permissions, see Troubleshooting permissions issues in Mac OS X.
GGJstudios is offline   0 Reply With Quote
Old Jun 21, 2012, 06:07 PM   #3
Atius
macrumors newbie
 
Join Date: Apr 2012
Location: Iceland
Quote:
Originally Posted by ludayoda View Post
New mac user here. Running latest Lion (10.7.4) on a Macbook pro. I have Paragon NTFS installed, and reading/writing to NTFS volumes has worked fine. However, I am having an issue with spotlight on my external hard drive (500 gb, NTFS formatted). It simply does not work. Searching my internal main hd works fine.

I have tried several suggested solutions to this problem already. This includes adding and removing the hard drive from the privacy tab of spotlight. I also tried several terminal commands that I found online such as "sudo mdutil -E" and "sudo mdutil -i on". These all indicate that indexing on my external drive is in fact on. Spotlight does not seem to be indexing the drive. HOWEVER it does return results for folders that I have opened. Seems kind of strange. Doesn't help me much, as I am not about to open 1000's of folders and files just so they can be found through spotlight.

Any suggestions to fix this?

You can not index a NTFS drive, see this thread for more information:
http://forums.macrumors.com/showthread.php?t=679451
Atius is offline   0 Reply With Quote
Old Jun 21, 2012, 06:11 PM   #4
GGJstudios
macrumors Westmere
 
Join Date: May 2008
Quote:
Originally Posted by Atius View Post
You can not index a NTFS drive, see this thread for more information:
http://forums.macrumors.com/showthread.php?t=679451
I completely skimmed over that the drive was NTFS, despite how obvious it was. Thanks for catching that!
GGJstudios is offline   0 Reply With Quote
Old Jun 21, 2012, 06:17 PM   #5
ludayoda
Thread Starter
macrumors newbie
 
Join Date: Jun 2012
Quote:
Originally Posted by Atius View Post
You can not index a NTFS drive, see this thread for more information:
http://forums.macrumors.com/showthread.php?t=679451
Haha okay that settles it then. Won't waste any more time with this. Guess I will just have to use a third party search tool. Any suggestions for a good one? Thanks for the help!
ludayoda is offline   0 Reply With Quote
Old May 11, 2013, 04:15 AM   #6
lorcar
macrumors member
 
Join Date: Mar 2013
Quote:
Originally Posted by Atius View Post
You can not index a NTFS drive, see this thread for more information:
http://forums.macrumors.com/showthread.php?t=679451
this saved my day, so at least now i dont even try
What if I install Paragon or Tuxera? does it change?
lorcar is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:13 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC