Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Desktops > iMac

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 11, 2013, 05:15 AM   #1
2bcool2
macrumors regular
 
Join Date: Jan 2008
Late 2012 iMac wifi problem or Mountain Lion bug?

ive had my new imac for 1 week now and never thought to test the speed of my wireless speed.

i did a test at speediest.net and got a readout of 5mb download ...
i tried my 2012 air and it gave me the correct speed i should be getting 37mb download.

i then pluged in my ethernet cable and speedtest gave me 36mb download speed.

i unpluged the ethernet and refreshed the speediest page and did the test again only using wifi, and it gave me the correct 36mb.. i thought that had resolved it, but 5 mins later i did the test again on my imac only using wifi and it was back to a reading of 5mb download speed ..

anyone in uk know why this might be ?

when i first got my bt infinity my 2009 mbp was giving the same read out of 4mb download, only when i tried my neighbours pc laptop did i see iwas getting the full 36mb.

when i got my new air, it showed 36mb download so i thought it was old OS problem.

i never expected my new 2012 imac wifi to show the same problem..

i dont know if i am getting slow speed on iMac using wifi or if theres just a readout problem ?

ideas?

i did hear somewhere people were having wifi probs on new iMacs

thnx
2bcool2 is offline   0 Reply With Quote
Old Jan 11, 2013, 05:32 AM   #2
iWaiting
Registered User
 
Join Date: Dec 2012
it not your mac its that crap site called speedtest.net

99% of the sites are duff let me explain I have a 100mbs cable

site 1 gave 25 mbs
another gave 100 mbs

and so it goes on

try London Fidonet

dont try manchester I get 8 mbs on a good day
iWaiting is offline   0 Reply With Quote
Old Jan 11, 2013, 05:42 AM   #3
2bcool2
Thread Starter
macrumors regular
 
Join Date: Jan 2008
Quote:
Originally Posted by iWaiting View Post
it not your mac its that crap site called speedtest.net

99% of the sites are duff let me explain I have a 100mbs cable

site 1 gave 25 mbs
another gave 100 mbs

and so it goes on

try London Fidonet

dont try manchester I get 8 mbs on a good day
oh ok thanks .. on my air its always right, just was confused why the latest OS and imac would not work just as well as my air ..

it could be me but it does seem slower when on wifi than ethernet ( iknow thats probably normal, but on my air i feel no difference)


cheers ..
2bcool2 is offline   0 Reply With Quote
Old Jan 11, 2013, 06:10 AM   #4
Serban
macrumors 68000
 
Join Date: Jan 2013
Propose

I will propose to you a real test. try downloading something and see the result
And PLEASE let me know because in 2-3 months i will buy an 21.5" iMAC too.

thoughts about this new imac? how it works? You have the 21.5 or 27?
do you play games? (what games and if yes it plays smoothly), edit graphics programs?
Serban is offline   0 Reply With Quote
Old Jan 11, 2013, 09:38 AM   #5
2bcool2
Thread Starter
macrumors regular
 
Join Date: Jan 2008
Quote:
Originally Posted by Serban View Post
I will propose to you a real test. try downloading something and see the result
And PLEASE let me know because in 2-3 months i will buy an 21.5" iMAC too.

thoughts about this new imac? how it works? You have the 21.5 or 27?
do you play games? (what games and if yes it plays smoothly), edit graphics programs?
i have the new 27'
its great, i used to think 27" was way too big .. but now i guess we are all used to 50" tvs so it doesn't seem so big .. just right
i dont play games on it, i have an xbox :-P

the wifi is definitely pretty slow and laggy ... it feels like its something to do with the imac and not my wifi as my air is just super fast ...

any ideas ?
2bcool2 is offline   0 Reply With Quote
Old Jan 11, 2013, 02:32 PM   #6
Serban
macrumors 68000
 
Join Date: Jan 2013
Yea

Yea i have an idea but you dont play games...so..For example youve could compare a game like diablo 3 witch displays the latency of the game and youve could compare it between imac and air.
Serban is offline   0 Reply With Quote
Old Jan 11, 2013, 02:41 PM   #7
torana355
macrumors 65816
 
Join Date: Dec 2009
Location: Sydney, Australia
Quote:
Originally Posted by 2bcool2 View Post
i have the new 27'
its great, i used to think 27" was way too big .. but now i guess we are all used to 50" tvs so it doesn't seem so big .. just right
i dont play games on it, i have an xbox :-P

the wifi is definitely pretty slow and laggy ... it feels like its something to do with the imac and not my wifi as my air is just super fast ...

any ideas ?
I just did a test on my 2012 iMac and it is the same speed as my MBA though speedtest.net. 75Mb/s down and 2.4Mb/s up.
__________________
2012 27" iMac with 680mx | 2011 13" MBA 128gb | iPhone 4 32gb | Nexus 7 16gb | Nexus 4 on Carbon and Trinity.
torana355 is offline   0 Reply With Quote
Old Mar 26, 2013, 10:26 AM   #8
bartrek
macrumors newbie
 
Join Date: Sep 2010
I have the same problem with my imac 2012. After replacement SSD (was crashes, so i back imac to store) i have problem with wifi. It's really slow (0,2mb-4mb download, should be 60mb).On another devices (iPad, MacBook, iPhone, etc.) works great. Of course all devices there are in the same place.
I back mac to store/service again and store answer me that AirPort works OK... Service did all tests (service diagnostic and toolkit) and showed no abnormalities.

Now, i'm waiting for mac and i hope that will be good, but... i don't think so...


/SORRY FOR MY BAD ENGLISH
bartrek is offline   0 Reply With Quote
Old Mar 26, 2013, 11:13 AM   #9
JustMartin
macrumors 6502
 
Join Date: Feb 2012
Location: UK
speedtest.net gives me 46m download, 15m upload from a wifi link to my router from my late 2012 21" iMac.
JustMartin is offline   0 Reply With Quote
Old Mar 27, 2013, 09:05 AM   #10
platypus63
macrumors regular
 
Join Date: Feb 2006
Location: Zanzibar Land
Same problem here. All devices get 15mbps (what I'm paying for) and brand new iMac gets 5mbps. All devices are in same place, distance from router is not an issue (small apartment).

In the end as recommended by someone on this forum, I logged into the router, and changed the channel from automatic to test each channel one by one, to find the one that works best with the iMac.

I don't know why this computer is so picky when it comes to wifi, but seems to work so far, I'm getting 13mbps out of 15mbps. Better than lugging the 27" to the apple store.
__________________
Alu 27" iMac, 15" cMBP
platypus63 is offline   0 Reply With Quote
Old Mar 27, 2013, 12:24 PM   #11
Acorn
macrumors 68020
 
Acorn's Avatar
 
Join Date: Jan 2009
I would suggest trying to change the channel on your router. change channels then run the speedtest. keep trying different channels. I had a problem with a external monitor that was causing my wifi signal to drop. i could connect and disconnect the monitor and the wifi signal would react if it was connected. changing the channel solved it.

not saying thats your problem but maybe there is some other kind of interference that is on the same frequency. i would definitely give it a go.
Acorn is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > iMac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:20 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC