Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Desktops > iMac

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 27, 2013, 02:02 PM   #26
Laminar
macrumors newbie
 
Join Date: Jun 2013
Given the recent bump, I figured this thread was as good as any to respond to.

I just picked up an Early 2008 24" iMac 3.06 C2D. smcFanControl tells me that the ODD fan is running at full speed all of the time. I did an SMC reset and a PRAM reset to no avail.

I ran the Apple Hardware Test and got this code:
Code:
4SNS/1/40000000: T00P - 128.000
Some Googling tells me this is sensor-related. I believe my iMac uses this sensor and iFixit has a replacement guide for the same vintage 20" iMacs here. Is this process applicable to my 24" as well?

Does it seem like replacing this sensor should cure my issues? I see several temperature readouts in iStat but nothing seems out of line or failed, and there isn't a sensor listed for the optical drive. Am I missing something?

Thanks!
Laminar is offline   0 Reply With Quote
Old Jul 8, 2013, 06:57 PM   #27
Laminar
macrumors newbie
 
Join Date: Jun 2013
In case anyone finds this in the future, the optical drive temp sensor fixed my problem. Instead of paying $15 for the suction cups from iFixit, I found identical units at my local home improvement store for $2. I picked up a driver/bit set containing all of the torx bits I needed for about $6. I got part number 922-8222 from AppleComponents.com. It took nine days after ordering for the part to come in, but it did the job.

Before, as soon as the computer was turned on, the ODD temp sensor would climb to 127 degC and then blank out according to Temperature Monitor. Now it's holding steady at around 26 degC and the ODD fan is at 700rpm.
Laminar is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > iMac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
iMac Fan Control ZeD X iMac 85 Feb 25, 2013 10:19 AM
My late 2009 iMac is making clicking/cracking noises from the bottom-right hand corne GMsrgr8 iMac 5 Aug 11, 2012 05:23 AM
Temperatures & Fan Speeds for Late 2009 iMacs (Please Post Yours) spcdust iMac 60 Oct 21, 2010 04:28 AM
PSU fan always full song on MP2.1 - resolved!! gugucom Mac Pro 2 Oct 8, 2010 10:31 AM
HELP! 1.25 DP G4 WILL NOT BOOT, FANS AT FULL SPEED! frixr4kids Macintosh Computers 0 Mar 8, 2004 07:33 PM


All times are GMT -5. The time now is 11:39 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC