Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 6, 2014, 01:03 AM   #51
pencilcheck
macrumors member
 
Join Date: Sep 2010
Unhappy

I have experienced this problem as well, but it is not reproducible. It just happens sometimes but it's still annoying... I hope someone can contact his Apple friends and tell them to fix this!
pencilcheck is offline   0 Reply With Quote
Old Jan 22, 2014, 09:34 PM   #52
Scott90
macrumors 6502
 
Join Date: Jul 2008
I guess we'll keep this thread active as long as it's an issue, I've been experiencing it too for quite some time now.
Scott90 is offline   0 Reply With Quote
Old Feb 1, 2014, 08:16 AM   #53
ConnYoungy
macrumors regular
 
Join Date: Aug 2010
I get this problem all the time, incredibly frustrating
ConnYoungy is offline   0 Reply With Quote
Old Feb 26, 2014, 10:37 AM   #54
OSXFirePussy
macrumors newbie
 
Join Date: Aug 2012
Angry Me too!

+1

I can't believe it's a feature. I hate it. Checked to disable search engine suggestions.

Using Safari 7.0.1 on OS X Mavericks 10.9.1.
OSXFirePussy is offline   0 Reply With Quote
Old Mar 1, 2014, 06:20 AM   #55
ddanecki
macrumors newbie
 
Join Date: Mar 2014
I am under impression that it has been fixed in Safari 7.0.2. After I've updated my OS, it didn't happen so far....

So it just happened again. Only few minutes after I wrote this message :/

Mavericks 10.9.2, Safari 7.0.2

Last edited by ddanecki; Mar 1, 2014 at 06:32 AM.
ddanecki is offline   0 Reply With Quote
Old Mar 1, 2014, 06:29 AM   #56
jasoncodes
macrumors newbie
 
Join Date: Mar 2013
Iíve had this bug reoccur a couple of times already with Safari 7.0.2 on OS X 10.9.2.
jasoncodes is offline   0 Reply With Quote
Old Mar 1, 2014, 06:35 AM   #57
ddanecki
macrumors newbie
 
Join Date: Mar 2014
Quote:
Originally Posted by jasoncodes View Post
Iíve had this bug reoccur a couple of times already with Safari 7.0.2 on OS X 10.9.2.
Yeah, me too. During first few minutes when I was doing everything to trigger it, it did not happen. Then after posting my message, closing this forum and trying to open another website it happened again.

This is really frustrating. There are moments when my browser is useless as out of 5 pages I try to open, one after another, only one or none is the one I really wanted. What is it supposed to be anyway ? Feature or bug ? If it's a feature, where's the option to disable it ?
ddanecki is offline   0 Reply With Quote
Old Mar 6, 2014, 05:39 AM   #58
OSXFirePussy
macrumors newbie
 
Join Date: Aug 2012
Angry

Me too.
OSXFirePussy is offline   0 Reply With Quote
Old Mar 27, 2014, 02:52 AM   #59
muouyiyi
macrumors newbie
 
Join Date: Jun 2011
...what i should say...
glad to see so many are in the same boat...
muouyiyi is offline   0 Reply With Quote
Old Mar 27, 2014, 10:43 AM   #60
Fishrrman
macrumors 68040
 
Join Date: Feb 2009
[[ Feature or bug ? If it's a feature, where's the option to disable it ? ]]

Folks, please read carefully post #46 above...
Fishrrman is offline   0 Reply With Quote
Old Mar 31, 2014, 08:31 AM   #61
IceMustard
macrumors newbie
 
Join Date: Mar 2014
Quote:
Originally Posted by Fishrrman View Post
Folks, please read carefully post #46 above...
Excerpt from your post #46:
Quote:
Originally Posted by Fishrrman View Post
Type a space character BEFORE YOU TYPE ANYTHING ELSE. You want a space character to be the first character entered.
It is not that autocomplete is the problem.

The annoying issue this thread is about can be named Auto-Enter or Auto-Return. You start typing in the address bar and magically after one, two (or if you are fast more letters) Safari opens the first url found within the autocomplete list. And this depends on how many letters you actually typed. It is impossible to willingly enter letters in this situation, cause the auto return kicks in really fast, like after 0.3 secs or so. And it is intermittent. It does not always happen. Some people pointed out, it is more likely to happen if you did not open a url for a while.

The conclusion must be: This is not a feature, it is definitely a BUG. And it is still present in OS X 10.9.2 and Safari 7.0.2.
I came from OS X 10.6.8 directly to Mavericks and for me the issue started then. I am not sure if maybe some plugin/extension is the root of this issue. For example I have Glims for Safari installed.

Is there anyone with vanilla Safari experiencing this issue?

Also, I wonder if anyone has raised an issue at Apple support and how Apple comments on that?

Last edited by IceMustard; Mar 31, 2014 at 11:45 AM.
IceMustard is offline   0 Reply With Quote
Old Mar 31, 2014, 10:32 AM   #62
jbarley
macrumors 6502a
 
Join Date: Jul 2006
Location: Vancouver Island
What can I say, I feel for all of you with this problem.
But I must admit I've never experienced it myself.
I'm running 10.8.5 and Safari 6.1.2 and it always behaves as expected,
when I start typing in the address bar Safari takes it's best guess and adds characters, along with a dropdown menu of selections, but it NEVER autocompletes or opens any selection until I hit the return key, which is what I expect is the way it is designed to work.
__________________
If a man speaks out while in the forest, and there is no woman there to hear him, is he still wrong?
jbarley is offline   0 Reply With Quote
Old Mar 31, 2014, 11:15 AM   #63
IceMustard
macrumors newbie
 
Join Date: Mar 2014
I can add some more details on my usage pattern of Safari. Safari is opened all the time. I never close it. I have several windows of Safari open on multiple spaces (or in MissionControl speak: desktops). Some windows contain 5 or 6 tabs. Others contain 20 to 30 tabs, thanks to the Glims feature to have small tabs (they can shrink to the width of the favicon).

In total my current session contains 8 windows with in sum 104 tabs, I arranged my working sets on 4 Spaces (desktops). If I look at Activity Monitor this results in 20 WebContent processes each of 9 to 18 threads.

I often hotplug a second monitor. So sometimes I have a dual monitor setup, sometimes its just my little 13 inch mac book pro screen. So far I have not payed attention, if the issue is maybe restricted to only one of those setups. I ll try to do so now.

Right now I started experimenting with BetterTouchTool to maybe workaround the issue:

I try to use BetterTouchTool to automatically add some harmless key combination after activating the address bar. Atm I try CMD+A.
So if I type CMD+L Bettertouchtool opens File-->"Open URL ..." followed by a "CMD+A" which selects the url. The extra CMD+A does not change anything, cause the URL is already selected by default.

In BetterTouchTool looks like this:

(German "Ablage" = English "File")

Another possible harmless key stroke might be just "ESC". Or if anybody does not like that autocomplete is done within the address bar one could even use "SPACE" as suggested in #46.
But I like autocomplete in address bar, I just do not need auto enter.
Furthermore, if we use SPACE as prefix some urls from history cannot be found. For example if u enter
"[SPACE]forums.mac" then forums.macrumors.com will not be part of the autocomplete list. So prefix SPACE is a bad idea imho. It breaks autocomplete in many cases.

However, I will see if adding dummy key strokes helps with the original issue. As we all know we have to use the system for a while to experience the bug. It cannot be reproduced at will.
Attached Thumbnails
Click image for larger version

Name:	btt_safari_workaround.png
Views:	422
Size:	168.0 KB
ID:	466955  

Last edited by IceMustard; Apr 1, 2014 at 03:41 AM.
IceMustard is offline   1 Reply With Quote
Old Apr 1, 2014, 03:59 AM   #64
IceMustard
macrumors newbie
 
Join Date: Mar 2014
Ok, I had my first occurrence of the issue today with above BetterTouchTool experiment setup.

It happened on NewTab. That means the sequence CMD+T,CMD+A does not surpress the issue.
I have now setup BetterTouchTool like follows:

Code:
CMD+L triggers the sequence MenuItem-OpenUrl, CMD+A   (same as above)
CMD+T triggers the sequence MenuItem-NewTab, SPACE, BACKSPACE, ESC
CMD+N triggers the sequence MenuItem-NewWindow, SPACE, BACKSPACE, ESC
... will see if that helps. But my hope fades a bit.

Last edited by IceMustard; Apr 1, 2014 at 04:34 AM.
IceMustard is offline   0 Reply With Quote
Old Apr 2, 2014, 02:27 AM   #65
colloc
Thread Starter
macrumors member
 
Join Date: Jul 2012
It's been a while since I created this thread, and I'm surprised to see it's still alive and that many people are still experiencing this bug (or feature?). I confirm that it also happens in Mavericks, and can be quite annoying at times.

Anyway, I think our efforts of complaining finally paid off - after almost 2 years, Apple finally decided to release a patch for this bug:


I will give it a try and see if it fixes the problem
colloc is offline   1 Reply With Quote
Old Apr 2, 2014, 02:36 AM   #66
IceMustard
macrumors newbie
 
Join Date: Mar 2014
Yippee, so I immediately stop experimenting with dummy key strokes. Also, it did NOT work very well. I had the BUG occur 2 times since I started my experiment.

I am so happy about this news. Thanks for pointing to this. Downloading right now the update. I really hope they caught it ...

Last edited by IceMustard; Apr 2, 2014 at 02:59 AM.
IceMustard is offline   0 Reply With Quote
Old Apr 10, 2014, 11:08 AM   #67
jbarley
macrumors 6502a
 
Join Date: Jul 2006
Location: Vancouver Island
Can anyone who was having this Safari problem confirm the "fix" claimed in the Safari 7.0.3 update?
__________________
If a man speaks out while in the forest, and there is no woman there to hear him, is he still wrong?
jbarley is offline   0 Reply With Quote
Old Apr 10, 2014, 11:41 AM   #68
kronborg
macrumors member
 
Join Date: Apr 2011
Location: Copenhagen
I still experience the bug in 7.0.3. So annoying, but I've almost gotten used to it by now.
__________________
MacBook Air 13" (mid 2012) 1.8GHz, 128GB SSD, 8GB RAM ∑ iPad 2 16GB Wi-Fi Black ∑ iPhone 5 32GB Black ∑ iPhone 3GS 16GB Black ∑ ATV 3
kronborg is offline   0 Reply With Quote
Old Apr 11, 2014, 05:24 AM   #69
ddanecki
macrumors newbie
 
Join Date: Mar 2014
Seems to be fixed

Quote:
Originally Posted by jbarley View Post
Can anyone who was having this Safari problem confirm the "fix" claimed in the Safari 7.0.3 update?
I can confirm that it does not happen any more for me. OSX 10.9.2, Safari 7.0.3.

Quote:
Originally Posted by kronborg View Post
I still experience the bug in 7.0.3. So annoying, but I've almost gotten used to it by now.
That's strange. It seems to be fixed for me.

It is a little bit strange now when I don't have to type urls few times, however I think I'll manage to get used to it
ddanecki is offline   0 Reply With Quote
Old Apr 12, 2014, 03:22 AM   #70
IceMustard
macrumors newbie
 
Join Date: Mar 2014
OS X 10.9.2, Safari 7.0.3. The auto-return bug has not happened for 10 days now.
IceMustard is offline   0 Reply With Quote
Old Apr 12, 2014, 09:53 AM   #71
jbarley
macrumors 6502a
 
Join Date: Jul 2006
Location: Vancouver Island
Sounds like maybe Apple does listen, at times...
__________________
If a man speaks out while in the forest, and there is no woman there to hear him, is he still wrong?
jbarley is offline   0 Reply With Quote
Old Apr 21, 2014, 04:14 AM   #72
jasoncodes
macrumors newbie
 
Join Date: Mar 2013
This problem has started occurring for me on my new Mac running Safari 7.0.3.

The 7.0.3 update did seem to fix things on my old Mac though.
jasoncodes is offline   0 Reply With Quote
Old May 22, 2014, 03:56 AM   #73
kronborg
macrumors member
 
Join Date: Apr 2011
Location: Copenhagen
Quote:
Originally Posted by kronborg View Post
I still experience the bug in 7.0.3. So annoying, but I've almost gotten used to it by now.
The 7.0.4 update reminded me that I haven't had this bug happen for a long time now. Pretty good.
__________________
MacBook Air 13" (mid 2012) 1.8GHz, 128GB SSD, 8GB RAM ∑ iPad 2 16GB Wi-Fi Black ∑ iPhone 5 32GB Black ∑ iPhone 3GS 16GB Black ∑ ATV 3
kronborg is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Safari 6 search bar doesn't search themelz Mac Applications and Mac App Store 0 Aug 19, 2012 10:57 AM
Safari 6 search bar, 2-3 second lag? baryon OS X 10.8 Mountain Lion 6 Aug 7, 2012 04:39 PM
Safari address bar help ritmomundo Mac Applications and Mac App Store 4 Aug 1, 2012 01:02 PM
Safari 6 search bar dusk007 OS X 10.8 Mountain Lion 2 Jul 31, 2012 04:40 AM
How to do a google search from Safari bar? steffi OS X 10.8 Mountain Lion 2 Jul 27, 2012 04:12 PM

Forum Jump

All times are GMT -5. The time now is 05:52 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC