Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 11, 2010, 06:21 AM   #1
jhb104756
macrumors newbie
 
Join Date: Mar 2010
Problems typing in japanese characters on a MacBook!!

More specifically when typing one character...
When I type in Hiragana - わたし (watashi) it should convert to this character 私 however... it doesnt. the first character it converts to is this... わ足し!!

Watashi is one of the most common characters. It means "I" and I need to use it!
I used to be able to type it and only recently have noticed I can not do this.

Does anybody have a similar problem? heard of or seen this before? know how to correct the problem? All your help would be good?

My MacBook was purchased in Japan and has a Japanese keyboard!  
jhb104756 is offline   0 Reply With Quote
Old Mar 11, 2010, 09:15 AM   #2
jackerin
macrumors 6502a
 
Join Date: Jun 2008
Location: Finland
That sounds strange indeed. If 私 still shows up in the list when hitting the space-bar try typing it a few times and choosing it every time and see if it becomes the first choice.
jackerin is offline   0 Reply With Quote
Old Mar 11, 2010, 09:22 AM   #3
angelwatt
Moderator emeritus
 
angelwatt's Avatar
 
Join Date: Aug 2005
Location: USA
I haven't had issues with this either. Just make sure to hit the space bar at the end, and don't hit enter during the typing starting at wa. Does it matter what program you're typing in?
angelwatt is offline   0 Reply With Quote
Old Mar 11, 2010, 08:52 PM   #4
jhb104756
Thread Starter
macrumors newbie
 
Join Date: Mar 2010
Very strange

Thanks guys...
Thats the thing...

when I type わたし and press space-bar the "私" character doesnt even show up in the list, however it used to and it used to be first.

It doesnt matter whether I am using the internet... this site, facebook, google etc, Microsoft software ie Word & Excel, Apple software ie Aperture, Pages, & Keynote etc....

If anyone has any ideas or possible avenues to chase down that would be good... dont really want to pay apple $60 AUD for them to 'troubleshoot' and not guarantee a solution!!!
jhb104756 is offline   0 Reply With Quote
Old Mar 11, 2010, 09:01 PM   #5
zorahk
macrumors 6502
 
Join Date: Jul 2008
Location: North Korea
I have had this kind of problem. At the bottom there should be "others for watashi" or something, click on that and then find it, once you select it it will become the most common one used.
__________________
15" High Res Glossy Macbook Pro, 2.66GHz Intel Core i7, 8GB RAM, 500GB 7200RPM HDD, 512MB GT 330M.
32GB iPhone 3GS, 32GB iPad 3G, Airport Extreme.
zorahk is offline   0 Reply With Quote
Old Mar 11, 2010, 09:13 PM   #6
angelwatt
Moderator emeritus
 
angelwatt's Avatar
 
Join Date: Aug 2005
Location: USA
I wonder if the dictionary has become corrupt in some manner. I did a search and found this article. It doesn't describe your problem, but could be of help.

You can also take a look at the Kotoeri preferences, which is accessible from the menu bar item (keyboard menu) where it shows what typing mode you're in. Perhaps there is a setting in there that got changed that's causing this.
angelwatt is offline   0 Reply With Quote
Old Mar 12, 2010, 04:13 AM   #7
jhb104756
Thread Starter
macrumors newbie
 
Join Date: Mar 2010
No Progress...

Zorahk... not that because the [ 私 ] is no where to be found anywhere in the list even in the 'others' drop down

The article was interesting, however i tried it but didnt work... its really bugging me cos it seems to be some setting thing or software.. not hardware...

Keep thinking guys
jhb104756 is offline   0 Reply With Quote
Old Mar 12, 2010, 04:48 AM   #8
chill.
macrumors 6502
 
Join Date: Sep 2008
click on language pack icon

edit dictionary

add word
chill. is offline   0 Reply With Quote
Old Mar 12, 2010, 05:31 AM   #9
Makosuke
macrumors 603
 
Join Date: Aug 2001
Location: The Cool Part of CA, USA
Found The Solution!

Interesting. In the process of typing up suggestions for this, I figured out what the problem is, then took another 20 minutes to find the fix. I also, while looking, stumbled across two incredibly useful features that I did not know were even there, which is awesome. Seriously, AWESOME.

Here's what's going wrong: If you type わたし once and then bring up the suggested predictions list for it, but instead of selecting the correct character select わ足し instead, it remembers that as your preferred choice. You probably accidentally hit space an extra time without realizing it or something.

The PROBLEM is that once you've done that, the suggested prediction that pops up with わたし will ALWAYS assume you just want options for the first character, and will NEVER suggest all three. I'm nearly certain this is a bug, maybe quite recent (I'm using 10.6.2, and I'm sure it worked properly in 10.5.something, not to mention if it had been around for a while surely people would have complained and/or fixed it).

The prediction list that is causing the problem here is stored in ~/Library/Preferences/com.apple.JapaneseAnalysis/

That's a folder with a number of files in it, but I couldn't easily figure out which was the problem or how to edit them. If, however, you trash that whole folder, log out, and then log back in (or reboot), your preferred predictions will be forgotten and you're back in business. You'll also lose all the correct ones, but that's probably not a huge problem.

Perhaps someone else knows how to edit the dictionaries manually to remove the bad association, though really this issue should never happen in the first place, because the OS should be offering predictions for the whole word if the first-character suggestions aren't sufficient.

Also, it seems like the Kotoeri preferences aren't working; the check box for "Show predicted candidates" doesn't seem to do anything on my system, but if I understand what it's supposed to do correctly it should stop Kotoeri from suggesting any previously-used selections at all. Maybe I just don't get what it's supposed to do.


I'd be really interested if people could try this and see if it creates the same catch-22 for them. Particularly curious if it's new in 10.6.something, or if it has existed for longer. A little more data to submit a bug report to Apple would probably be useful.


Now for my two peripheral discoveries: First, I found out that the OS already has a huge Japanese-English dictionary, plus a pure-Japanese regular dictionary, built-in. You can turn them on via the preferences of Dictionary.app. Had no idea that was in there, but SO useful.

Second, I thought that Apple had dropped the preference that allowed you to switch between a per-document input method and a systemwide input method in 10.5. I preferred systemwide, so this didn't bother me, but my wife liked the other, as did some people here asking where it went a while back, and I thought there was no way to switch anymore. Turns out that it's there, it's just in a different place--it now appears to the right of the Input Sources list. I could swear that wasn't there in 10.5, so maybe they put it back in 10.6.

Either way, sweet for people who prefer the old style method.

Wasted a bunch of time digging myself out of the hole I created trying to help, but I'm happy anyway!
Makosuke is offline   0 Reply With Quote
Old Mar 12, 2010, 07:01 AM   #10
jackerin
macrumors 6502a
 
Join Date: Jun 2008
Location: Finland
I sort of suspected it could be a preference file myself, but couldn't be bothered to find where they were stored..

Curiously, I don't even get わ足し as an option when typing わたし. Using 10.4.11 here.
jackerin is offline   0 Reply With Quote
Old Mar 12, 2010, 12:20 PM   #11
Makosuke
macrumors 603
 
Join Date: Aug 2001
Location: The Cool Part of CA, USA
Follow-up note, I just tried on my machine running 10.5.8 at work, and while you can get it to incorrectly auto-suggest わ足し, if you hit space again it will offer 私 like it's supposed to.

Meaning this bug was introduced in 10.6. Maybe even 10.6.2--anybody running an earlier version?

Also, I wasn't just stupid--the option to set the input mode by document instead of systemwide was gone in 10.5--they put it back in 10.6. Bet that alone is reason enough for some people to upgrade.
Makosuke is offline   0 Reply With Quote
Old Sep 1, 2011, 12:47 AM   #12
dxintokyo
macrumors newbie
 
Join Date: Aug 2011
Problems typing in japanese characters on my MacBook!!

hi all,

for some reason, some japanese words get converted into letters ;(

when "shinjuku" is written in japanese kanji, it changes to "k"
when "seikatsu" is written in japanese kanji, it changes to "u" ;(

but other words like "shigoto" or "ryouhou" comes out in japanese like it's supposed to.

i currently use a macbook version 10.6.6. i did a disk utility check and everything is fine.

hope someone in this group can help!

thanks and arigato!
dxintokyo is offline   0 Reply With Quote
Old Feb 6, 2013, 12:45 AM   #13
RMurphy
macrumors newbie
 
Join Date: Dec 2011
Same kotoeri problem

Yes, I have the same kotoeri problems since getting my new iMac and Office 2011. Very frustrated. Tried going through the MS turn-on-japanese-language-features as suggested elsewhere on Macrumors but problem persisted after I closed doc and reopened it. Tried flipping first language choice in system prefs.

Most of previous posts were from 2011, wondering if there is anything new (solutions) by this time!
RMurphy is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Typing accuracy problems iPhone iOS7 BasilFawlty iOS 7 8 Nov 30, 2013 09:26 AM
MacBook will only type special characters Francine231 MacBook 1 Sep 26, 2013 12:18 PM
Problems typing in forums, is there a workaround? snerkler iOS 7 9 Jun 14, 2013 09:06 AM
unable to read chinese and japanese characters in my iMac aquazula OS X 16 Dec 18, 2012 08:02 PM
UK MacBook Pro with Japanese keyboard GameWeaver MacBook Pro 1 Dec 15, 2012 11:38 AM

Forum Jump

All times are GMT -5. The time now is 04:31 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC