Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 26, 2012, 03:33 PM   #26
aajlh
macrumors newbie
 
Join Date: Nov 2012
Bingo! I got it to work. Can now sign in!

Hi all

I had exactly the same catch 22 loop where it wanted me to create a new username (which I already had) and when I tried to use a new one it said one was already associated with my email address.

I used the instructions in post #16 in this thread (ie by DeZYnur). I also had two accounts, one with my email address and one with my username. The top one was checked/highlighted already as the default (which was my username). I tried changing it to the second option (email address) but that didn't work and I ended up in the same loop. I changed the password for my email address though. Then I went back in and re-checked the first option (username) and it prompted me to change the password so I changed it to the one I had just reset for my email address and BINGO, it now works and I can get into Apple support communities using my username.

I suspect at some point (perhaps when Lion came out but not sure when it was) those of us who have two account IDs and are now currently using the one we created last had the default changed by Apple back to our original IDs. When we couldn't sign in to the support forums with the second ID we were currenlty using, even if we tried using our old username we were still using our more recent password. Just a theory.

Anyway, I would suggest following the instructions in post#15 and doing what I did. This has bugged me for months so I was very pleased to get it working again and hope this works for everyone else.

Good luck.

Anne
aajlh is offline   0 Reply With Quote
Old Jan 3, 2013, 11:46 PM   #27
blossomdearie
macrumors newbie
 
Join Date: Jan 2013
Cannot login to Apple Communities, ID issue

I am going seriously nuts here with the same Catch 22 situation!
By the way, I can't get onto an Apple forum or the Apple site about this because of the following:

Today I upgraded from OS10.6.8 to 10.8. All fine, except Apple made me change my username from my name to my email address. Seemed innocent enough.
I am currently part of a few Apple discussions and I need to reply some posts of an urgent nature.
OK, so I go to log onto the Apple Communities and the page takes me to the main Apple logon page. Now, of course, my user name is my email address not the original username I used to login with.

So I put in the new username (email address), then it asks me to choose a public profile username for the Communities page. I put in the one I have used for years and was still using before I upgraded to 10.8. No good, tells me that name is already used! (Yes, by me of course, but Apple can't see that). So I decide I might have to slightly change my public profile name just to get me back onto the discussions. Fine, then it says 'An account utilising this email address already exists. Only one account per email address is allowed on Apple Support Communities'

I have tried the hints on this thread and nothing works. i.e., I have a secondary Apple email address which they allow you to have but can't login to Apple Communities with that either. I have also tried using my original login name (my name) but that doesn't work either.

And so I go nowhere. I can't login to any Apple Communities sites at all to pst about this, but there are obviously several people with this issue. I phoned Apple Care who don't seem to know of the problem (even though many, many people have posted about it online). This is MAD.
blossomdearie is offline   0 Reply With Quote
Old Jan 8, 2013, 08:06 AM   #28
HKverfechter
macrumors newbie
 
Join Date: Dec 2008
This IS Madness

I wholeheartedly agree with every post preceding this very post of mine!!! I have pretty much have just stopped trying to resolve this issue, since I have been able to find my answers from other sources. I cannot believe that this thread originated a year ago and still there is no fix. I must have changed my password six times in the last year, because each time that I try to signin with the username and password that I had used for the communty in the past, I am prompted to reset my password. I am revisiting this issue again because I just ordered a new MacBook Air and it will arrive on Thursday and I am in need of some community support. This is very upsetting.
Thanks for listening
HKverfechter is offline   0 Reply With Quote
Old Jan 16, 2013, 04:41 AM   #29
Gentfam
macrumors newbie
 
Join Date: Jan 2013
At the risk of sounding repetitious

.. the problem is still there as I have learned to my cost. Fiddling in the Apple iD site is not without its dangers either. You can inadvertently kill your iD too. I lost my old iD, where Apple so-called sent me an email which never arrived and then refused to go through the other process, saying my date of birth was wrong. Result; I lost a load of music and apps for which I could no longer authorise my computer.
Gentfam is offline   0 Reply With Quote
Old Jan 24, 2013, 11:41 AM   #30
h4lp m3
macrumors 6502
 
Join Date: Jun 2011
Location: New Orleans
Same problem here, I absolutely HATE their forums, it's a ********** epic fail! I wish they'd just use vB like the rest of the world and get it over with.
  • First they force you to change your password.
  • I can't stand all their new crazy password requirements. I don't use uppercase letters or 1 numbers so I always forget my password.
  • Then, when you use the "password recovery", instead of punching in your email address like most sites, you have to guess what your user ID was and where they sent that email!?
  • Then I reset my password and it wants me to create a new Apple ID? So I try and it's like
    Quote:
    "An account utilizing this email address already exists. Only one account per email address is allowed on Apple Support Communities. "
  • Then, for whatever reason, FireFox doesn't save the password so I have to play this 45 minute game every time I visit that god-forsaken site.
__________________
Hal leta puta pardeglea Macarena, HEEEEY Macarena! !!!
h4lp m3 is offline   1 Reply With Quote
Old Jan 27, 2013, 11:49 AM   #31
saneman1
macrumors newbie
 
Join Date: Jun 2010
Quote:
Originally Posted by Shemja View Post
I'm trying to view Apple communities to look at an iPad case thread I read a few months back, but apple.com keeps requiring me to sign in twice and then select a username to even view community topics. When I put in a username for my Apple ID, I get this error message, "An account utilizing this email address already exists. Only one account per email address is allowed on Apple Support Communities."
Not sure if this helps, but I noticed when I logged in with Chrome, instead of Firefox, I was able to get my Apple Communities to log me in.
saneman1 is offline   0 Reply With Quote
Old Feb 10, 2013, 03:58 PM   #32
politicaljules
macrumors newbie
 
Join Date: Feb 2013
Another dissatisfied apple user without an apple id

I am trying and trying and trying. The only thing I have been able to achieve with my failed sign in attempts to the support communities is changing my password to something I will never remember. I have changed it at least three times today.

Please someone help. Everything is locke up now. This is where I end up with no recourse.

"An account utilizing this email address already exists. Only one account per email address is allowed on Apple Support Communities."
politicaljules is offline   0 Reply With Quote
Old Apr 15, 2013, 01:52 AM   #33
rogerdpack
macrumors newbie
 
Join Date: Aug 2008
thanks

same fix "kind of" worked for me:
basically go to the mentioned "appleid.apple.com" page, click on "manage your apple id" and if it lists your ID as anything *other* than an email address (in my case it did) then you basically need to use that other thing as your login name for the community forums. Weird.
rogerdpack is offline   0 Reply With Quote
Old Apr 30, 2013, 02:47 PM   #34
9mmed
macrumors newbie
 
Join Date: Apr 2013
Location: Chicago, IL
 
see vendor information in user profile
April 30th, and I can't believe there is no resolution in a problem that dates back to 2011. Has anyone gone to the Geniuses with this issue?

Yes, yes, hi there! New to the forum, but the way Apple's going I'll be here a lot, I fear.
9mmed is offline   0 Reply With Quote
Old Jun 15, 2013, 09:17 AM   #35
dokterdok
macrumors newbie
 
Join Date: May 2010
Same issue here, I contacted Apple Support by phone but they couldn't solve it on the spot and asked me to provide screenshots by email. That was 3 days ago, I haven't heard back from them yet.
dokterdok is offline   0 Reply With Quote
Old Jun 26, 2013, 04:54 PM   #36
PJL500
macrumors newbie
 
Join Date: Nov 2011
Quote:
Originally Posted by HKverfechter View Post
I wholeheartedly agree with every post preceding this very post of mine!!! I have pretty much have just stopped trying to resolve this issue, since I have been able to find my answers from other sources. I cannot believe that this thread originated a year ago and still there is no fix. I must have changed my password six times in the last year, because each time that I try to signin with the username and password that I had used for the communty in the past, I am prompted to reset my password. I am revisiting this issue again because I just ordered a new MacBook Air and it will arrive on Thursday and I am in need of some community support. This is very upsetting.
Thanks for listening
Same issue here. Going around in circles trying to get in to address a REAL problem I am having with OS X!
PJL500 is offline   0 Reply With Quote
Old Aug 29, 2013, 02:51 PM   #37
dlaxague
macrumors newbie
 
Join Date: Aug 2013
FINALLY, the answer!

Thank you DeZYnur, I've been hassling with this (exactly as you described) for way too long before finding your solution. I did exactly as you instructed, and found that I had a second account associated, set up a new password, and I'm in. AppleCare said there is no support for the Apple Support Communities website, which seems pretty funny/ironic now but was not amusing when she told me in the midst of my frustrations.

Debbie
dlaxague is offline   0 Reply With Quote
Old Nov 19, 2013, 12:08 PM   #38
keith.f.kelly
macrumors newbie
 
Join Date: Nov 2013
Solution / explanation

The problem is that Apple Support Communities use a different Apple ID from the one you use for everything else. As another user here pointed out earlier, you need to search for all Apple IDs associated with your name and e-mail address, and then log into Apple Support Communities using the one that's just a username (not an e-mail address).
keith.f.kelly is offline   0 Reply With Quote
Old Dec 12, 2013, 08:53 PM   #39
brdeveloper
macrumors 65816
 
brdeveloper's Avatar
 
Join Date: Apr 2010
Location: Brasil
Still happens... weird.

I just wanted logging in to kick a member's ass:

Humble guy:
ThanhThuy
Jun 4, 2011 7:12 AM

I installed joikuspot light in my nokia E71, and my iPad recognized the wifi hotspot but I still can't access Internet. Pls help


Stupid guy:
Allan Sampson Central Texas
Re: Connect iPad 2 wifi to wifi hotspot with joikuspot
Jun 4, 2011 7:14 AM (in response to ThanhThuy)

You need to contact Nokia or joikuspot technical support.


Humble one, again:
ThanhThuy
Re: Connect iPad 2 wifi to wifi hotspot with joikuspot
Jun 4, 2011 7:34 AM (in response to Allan Sampson)

My Nokia E71 runs well with joikuspot, and my iPad did recognized Joiku wifi hotspot through E71. But I don't know how to set ad hoc WLAN for my iPad so that it can run safari. Pls help. Tks


Stupid one, to ensure he's really stupid:
Allan Sampson Central Texas
Re: Connect iPad 2 wifi to wifi hotspot with joikuspot
Jun 4, 2011 7:36 AM (in response to ThanhThuy)
Once again, you need to contact Nokia or joikuspot technical support.


These kind of answers make me really nervous
It's obvious for the sake of obviety that if an iOS device can't browse the internet through an ad-hoc connection, it's Apple's fault. I used JoikuSpot a lot for sharing access between cell phones and laptops and I'm thinking on using again... and looks like iOS devices still don't like ad-hoc connections for sharing internet access.
__________________
15" rMBP Early-2013, 2.4GHz. After 3 display replacements, I'm still seeing uniformity problems.
Late-2009 Unibody White MacBook, 250GB 840 EVO SSD, 8GB RAM
Early-2010 MacMini, 4GB RAM

Last edited by brdeveloper; Dec 12, 2013 at 09:20 PM.
brdeveloper is offline   0 Reply With Quote
Old Dec 19, 2013, 01:37 PM   #40
Cranky1
macrumors newbie
 
Join Date: Dec 2013
Two different solutions, no password reset

All-

Same problem, but I found two different solutions from above:

1) if all you want to do is _view_ the Apple support forums -- but you're stuck in the AppleID loop -- close the affected tabs, go to your browser's preferences and delete cookies, and re-open those tabs from your history.

2) if you actually want to post, then at least in my case the following worked, _without_ having to reset my AppleID password, etc.:

Apple makes it look like your "AppleID" is the email address you use to log in, but that's an oversimplification. It's more like the stuff an AppleID represents is the actual thing you're dealing with (the basket of iTunes purchases, services, etc. associated with an AppleID -- including your Apple Support username), and the email address=login is just a pointer to that collection of stuff.

In my case, I had an AppleID which used my primary email address as its login, which included an Apple Support username as well. I'll call this AppleID_1, and it used cranky1@domain as its email address/login.

Then for various reasons I changed the email address of AppleID_1 to SomethingElse@domain, and then created a new Apple ID_2 using cranky1@domain as its email address & login.

Now when I try to log into Apple Support using cranky1@domain as my AppleID login I get stuck in the dreaded username loop, have to delete cookies, etc.

And no, I could not remember whether I already had an Apple Support username, or what it was.

What I had to realize was that if I had had an Apple Support username, it was associated with AppleID_1, not AppleID_2. So I tried logging into Apple Support using SomethingElse@domain (thus logging in using AppleID_1) -- at which point Apple found my old Apple Support username, logged me in, and all is well.

Apple clearly has a problem, in that the Apple Support username associated with AppleID_1 is still somehow slightly connected to the cranky1@domain email address in a way that causes the Apple Support login system to schizophrenically conclude that the email address does/doesn't have an associated Apple Support username.
Cranky1 is offline   0 Reply With Quote
Old Feb 9, 2014, 11:43 AM   #41
macgig
macrumors newbie
 
Join Date: Dec 2010
same here. I seem to have 2 apple IDs different emails. . (this screen seems to imply it's the same email which im sure it's not). old ID i've not used in years... 7 yrs perhaps

one account says its for the forums... the new one I want to use will let me login to my apple account but NOT the support communities. it tells me to create a user name. when I create one, it says that email is already in use. duh I know it is I'm just trying to make a community ID to use the forums. it's broke. not working apple.

so I can login to my account. but cant create an ID to use the communities. stupid.
Attached Thumbnails
Click image for larger version

Name:	login error.png
Views:	5
Size:	413.6 KB
ID:	460217  
macgig is offline   0 Reply With Quote
Old Yesterday, 08:57 AM   #42
The UnDoug
macrumors newbie
 
Join Date: Apr 2010
Location: Philadelphia, PA
Same problem here. I am having the exact same problem that others have described. If I try to login to the Apple Support Community, I am prompted to login with my Apple ID email address and password. I do so, and it prompts me to login with them, again. After doing so, I'm prompted to pick an username. Regardless of what I enter, when I submit the form, it tells me that an Apple ID already exists, or something.
The UnDoug is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Resolved: MBP keeps making Guest account GuitarG20 Mac OS X 10.7 Lion 9 Oct 15, 2011 12:19 PM
how to make an iso into a img (does not work as an .iso) mud25 Mac Basics and Help 2 Jul 19, 2011 09:30 PM
Trying to add new partition to MBR-partitioned drive aarons510 Mac Peripherals 0 Mar 5, 2011 02:26 AM
Became a new member to the Apple Community today bt22 MacBook Pro 11 Dec 27, 2009 11:54 PM
Trying to add Hotmail account to Mail.. mrbeaverhousen Mac Basics and Help 5 Jun 15, 2009 04:00 PM


All times are GMT -5. The time now is 02:11 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC