Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 26, 2012, 12:18 AM   #26
jmantn
macrumors member
 
Join Date: Mar 2012
Location: Tn
Glad that worked for you. I've heard of that causing issues with other devices in the past but never thought of that for an appletv. My password is around 28 letters and numbers so I guess I just missed running into that myself.
jmantn is offline   0 Reply With Quote
Old Mar 26, 2012, 11:42 AM   #27
Just Switched
macrumors member
 
Join Date: Aug 2008
Quote:
Originally Posted by monkey28 View Post
Update: talked with tech over the phone, still no luck, went to apple store and exchanged new unit, problem still here. I think its gotta be the firmware issue.

I think I have wait until they come with new update in the mean time.
I had 2 defective 3rd gen apple TVs and 2 defective iPads. The third exchange was the charm. Now both my iPad and Apple TV stay connected to home share with out a hitch. I had read evry single thread on here and on apple support site and called apple care and had 2 different techs out 2 my house before the store verified that units were indeed defective. Not saying this will work for you but you may want to try another exchange. Not that it was worth the hassle but I got a 5% discount for my troubles.
Just Switched is offline   0 Reply With Quote
Old Mar 26, 2012, 04:00 PM   #28
monkey28
macrumors newbie
 
Join Date: Mar 2012
After I exchanged a second one, it's gets worst, iPhone and iPad won't even find the atv. Looks like you said, may need another unit.
monkey28 is offline   0 Reply With Quote
Old Mar 28, 2012, 09:45 AM   #29
smp99
macrumors newbie
 
Join Date: Mar 2012
Well, mine seems to be fixed.

My situation was a problem with Win7 64bit firewall. Issue was that it would connect then disconnect after a few minutes. I also have a Win XP desktop that has zero problems with home share to ATV3. I called Apple support and we focused on the Win7 pc since we both felt the router and network were fine. All connections are wired but I don't think that mattered for this issue.

We turned off all firewalls, and it worked. Turned back on, same problem, even though iTunes was set as a program allowed in the firewall settings - all ports. What I have to do was set up 2 new inbound rules that would open up 2 ports for ALL programs - TCP-3689 and UDP-5353. My guess is that Home sharing might use a program other than iTunes to monitor the streaming. You need to go to the Advanced Setting for the firewall to set these ( I am using the default firewall in Win7) You can also simply type "firewall" in the Search/Run bar and the Advanced Firewall application opens up.

Hope this helps some.
smp99 is offline   0 Reply With Quote
Old Mar 28, 2012, 11:00 AM   #30
monkey28
macrumors newbie
 
Join Date: Mar 2012
Glad it work for u! But I am still figure out what's going on! I am using iMac, and turn off firewall. Tried port forwarding in router and still dropping connections.
monkey28 is offline   0 Reply With Quote
Old Mar 28, 2012, 10:00 PM   #31
LFMNX
macrumors regular
 
Join Date: Feb 2011
- Make sure all devices are connected to the same (already working) SSID and not hopping to another one.
- Ensure all devices are on the SAME apple ID
- iTunes on the computer must be up
- Turn off home sharing and back on again on computer
- Turn on home sharing ATV
LFMNX is offline   0 Reply With Quote
Old Mar 29, 2012, 07:57 AM   #32
superx
Thread Starter
macrumors member
 
Join Date: Aug 2005
Well I finally figured out my issue. There are to many 5ghz networks in my area.

I switched to 2.4 and that fixed it. weird but it is working.
superx is offline   0 Reply With Quote
Old Jun 10, 2012, 12:46 PM   #33
mikeleire
macrumors newbie
 
Join Date: Jun 2012
Final Got Home Sharing Working

After reading through the Forum threads and combining all the info, i was able to finally get my ATV3 to see all the Itunes libraries in my home.

I was having this problem with home sharing prior to buying ATV, but thought it was due to an XP, a vista and a Windows 7 trying to communicate.

Here what i did.

Turn off IP6

Make sure firewall/ network map has all devices as trusted (depending on your firewall/ security software)

Then open the following TCP ports: 3282, 5900, 5988, 123, 3689, 5297, 5298, 443, 80.

Then open the following UDP ports: 3283, 123, 5353, 5298, 443, 80

Then try a combination of turning on and off home sharing on all devices.

Restart itunes.

Once wifi connected restart ATV3.

when i turned it on, it worked.

This also cleared up the issue of the Windows PC's not being able to see each other and my Samsung Smart TV now sees all the PC's!
mikeleire is offline   0 Reply With Quote
Old Jun 30, 2012, 11:36 PM   #34
ryedarrow
macrumors member
 
Join Date: Jun 2012
Network Channel

I tried all the tricks to help my Apple TV find my computer. After a restart of my Time Capsule, I changed the network channel from 'Automatic' to a random number. Another restart did the trick. I switched it back to Automatic and everything works great.

Strange...
ryedarrow is offline   0 Reply With Quote
Old Sep 2, 2012, 11:00 AM   #35
ooproject
macrumors newbie
 
Join Date: Sep 2012
This worked for me...

Couldn't figure this issue out either (neither my computer nor my iPhone would connect to the Apple TV 3), finally tried this and it worked:

jmantn: So this may not work for everyone but here's some more possible solutions I've came across in addition to my previous posts on this thread:

Try turning off Home Sharing in iTunes. Then turn Home Sharing back on. This time don't click on done in the last step. Try clicking on My Music instead. By just clicking My Music instead, Home Sharing would stay in place and Apple TV may work. - From Apple Support Community
ooproject is offline   0 Reply With Quote
Old Dec 14, 2012, 08:48 PM   #36
IfHereMad
macrumors newbie
 
Join Date: Dec 2012
Ok guys. One frustrated evening later. Here's the simple, simple answer. Put your apple products on the 2g channel. Except your Mac if its your iTunes holder. After much irritation over the "remote" app not seeing the ITV, the ITV not seeing the Mac mini etc. I came to this solution and it instantly fixed all. Note my set up, Mac mini, 2 iPads, 2 iPhones, 2 ATV3's. once I forced all but the mini to 2g, everything works flawlessly. Looks as though apple just can't swing 5g on devices quite yet.
IfHereMad is offline   0 Reply With Quote
Old Mar 18, 2013, 03:22 PM   #37
gordmartin
macrumors newbie
 
Join Date: Mar 2013
jmantn you ARE the man ! Thank you

My situation was: new Apple TV working fine with one homeshared computer but not the other. Tried EVERYTHING. Finally tried this (buried way down in this thread):
Lastly:
1. Close iTunes application
2. Remove all of the contents from inside of this folder - C:\Users\YOUR USERNAME\AppData\Roaming\Apple Computer\iTunes (it is recommended that you move them to your desktop as a backup - so that you can move them back in case this does not work).
3. Repeat step 2 for this folder as well - C:\Users\YOUR USERNAME\AppData\Local\Apple Computer\iTunes
4. Launch iTunes application.
At this point - itunes will re-create all of the data inside of these two folders that you just removed and you should be back up and running.

Up and running ... didn't even see a sniff of this solution in any of the hundreds of other pages I went searching for helps. Thank you jmantn
gordmartin is offline   0 Reply With Quote
Old Apr 23, 2013, 03:29 AM   #38
fizz7283
macrumors 6502a
 
Join Date: Jul 2010
Quote:
Originally Posted by jmantn View Post
Shot in the dark here but try these:

In your Network settings make sure TCP/IPv6 setting is unchecked but leave TCP/IPv4 checked.

Restart your router (I know most probably have).
In your Router's settings under security make sure Multicast is checked if you have that option.
Try a complete reset of your router.

Windows PC's check bonjour settings:
To enable, right click on My Computer and select Manage. Click on Services under Services and Applications. Right click Bonjour Service and select Properties. Change Startup type to Automatic. And, click Start under Service Status. Click Ok. Restart iTunes

Make sure if you have a firewall you don't have something apple related set to untrusted or blocked.

Check your ports for bonjour on a router:
https://discussions.apple.com/thread...art=0&tstart=0

In iTunes, click "Advanced". Turn OFF Home Sharing. Turn it back ON and it will ask for your iTunes password. Put that in and click "Done."

Try turning off wifi sync in iTunes for your iPhone and iPad, home sharing may now work.

Also check this thread:
https://discussions.apple.com/thread...art=0&tstart=0

Try assigning each device on the network a static IP.



I hope this helps.
Just wanted to say thank you!! All of a sudden my Apple TV would not connect with the remote app and I wasted the last three hours trying to figure out why.

I turned off wifi sync and that fixed the problem immediately. It makes no sense why this would prevent the remote app from working though? Anyway, I'd much rather the convenience of remote app than wifi sync, we should be able to use both though. Not being able to use the remote app kind of made my Apple TV just a pointless paper weight for me. So thank you again!
fizz7283 is offline   0 Reply With Quote
Old Apr 23, 2013, 05:15 AM   #39
opinio
macrumors 65816
 
Join Date: Mar 2013
Quote:
Originally Posted by superx View Post
Hey Guys,

Just got a new Appletv3 and got everything hooked up, but the apple tv only connected once to my iTunes Library.

Everything was working during that time. now a MSG on the apple tv says turn on home-sharing.

I have a Dlink dir-815. The Apple TV is connected through n 5ghz.
I went through and forwarded the ports.

I have turn off home-sharing and turn it on. Restarted my machine.

It is a windows Vista Machine.

As I said earlier I have only been able to connect once to my home-sharing and it stopped.

Thanks for any help.
you try a factory reset on the apple tv unit?
opinio is offline   0 Reply With Quote
Old Apr 23, 2013, 07:41 AM   #40
Deadeyeshark
macrumors regular
 
Join Date: Aug 2011
Location: England
Home Sharing was the bain of my life for many months, tried everything, posted many times on here and got lots of helpful solutions, nada.

I was in a fortunate enough position to test out different routers, all to no avail, Dlink Netgear etc. Then I bit the bullet and bought an Airport Extreme, and haven't had any issues since. It's not a cheap solution, but it works.
Deadeyeshark is offline   0 Reply With Quote
Old Apr 23, 2013, 05:41 PM   #41
freediverdude
macrumors 6502a
 
Join Date: Dec 2006
I was going to go buy one of the Apple routers, but I realized I have Verizon Fios with coax connection, so basically I have to use their router unless I want to put that one in bridge mode and then the Apple one on top of that, lol. Sigh, I've already gotten a replacement AppleTV3 so I'm going to troubleshoot some more tonight.
__________________
Apple TV3, iPhone 5, iPhone 5S, iPad mini, iPad Air
freediverdude is offline   0 Reply With Quote
Old Apr 25, 2013, 08:37 AM   #42
ColdCase
macrumors 68000
 
Join Date: Feb 2008
Location: NH
Quote:
Originally Posted by freediverdude View Post
I was going to go buy one of the Apple routers, but I realized I have Verizon Fios with coax connection, so basically I have to use their router unless I want to put that one in bridge mode and then the Apple one on top of that, lol. Sigh, I've already gotten a replacement AppleTV3 so I'm going to troubleshoot some more tonight.
Many actually do that (bridge the FIOS). The coax part serves your Cable TV connection, nothing to do with the internet connection. I don't subscribe to their cable, so I just have a straight in ethernet connection and can use a router of my choice.

I haven't kept up with latest tech, but you used to be able to insert your router in the ethernet connection prior to their box (connect their box to your router) and just use their box for the TV.
__________________
MiniServer (2012-2.3-i7-8-120SSD-1TBHD), rMBP15 (2014-SJE1-2.6-16-SM1024), LG27EA83D, SYDS212JK2, LaCie Big5s, MacBooks, iMacs, AppleTVs, Time Capsules, AEBSs, MacPro early 08, some older stuff.
ColdCase is offline   0 Reply With Quote
Old Apr 25, 2013, 11:15 AM   #43
Legios
macrumors regular
 
Join Date: Jan 2012
Quote:
Originally Posted by freediverdude View Post
I was going to go buy one of the Apple routers, but I realized I have Verizon Fios with coax connection, so basically I have to use their router unless I want to put that one in bridge mode and then the Apple one on top of that, lol. Sigh, I've already gotten a replacement AppleTV3 so I'm going to troubleshoot some more tonight.
There were some internal settings I have to change in the Fios Actiontec router. I switched from Comcast to Fios when we moved and ATV was rock solid until I tried to connect it to Fios. After changing some settings I have since been rock solid. I had to dig to find the posts. It was like a year ago.
Legios is offline   0 Reply With Quote
Old Apr 25, 2013, 04:52 PM   #44
freediverdude
macrumors 6502a
 
Join Date: Dec 2006
I actually have the Fios Westell router, but I hear they're pretty similar. The more I think about it, the more I wonder if connecting an Apple router via ethernet to the Fios router and then using the wifi from the Apple router might solve the wifi problems (or it could just add another layer of problems, lol).
__________________
Apple TV3, iPhone 5, iPhone 5S, iPad mini, iPad Air
freediverdude is offline   0 Reply With Quote
Old Apr 27, 2013, 04:06 AM   #45
KiwiAdventure
macrumors regular
 
Join Date: Dec 2010
Location: New Zealand
My Apple TV stopped AirPlay tonight from my Mac mini due to my time capsule started a back up from my Mac mini. I have spoken to AppleCare about this and they said this is correct as the their is to much information from the my Mac mini to my time capsule to be able to allow AirPlay to work as well. I never have had a problem when using my iPad on AirPlay to Apple TV but when my Mac mini backs up to the time capsule the iPad will not connect to AirPlay.
KiwiAdventure is offline   0 Reply With Quote
Old Sep 14, 2013, 09:08 AM   #46
frankmacman
macrumors newbie
 
Join Date: Sep 2013
Disabling wi fi syncing works!

Just wanted to let anyone who has this problem know, I had this problem on a new apple tv i just bought yesterday i could not connect to an itunes home share on a MBP, but could on other ios devices. After disabling wi fi syncing with my iPad as suggested below everything worked fine! (At least once as i am not streaming something at this moment).

Apple needs to fix this.


Quote:
Originally Posted by jmantn View Post
Shot in the dark here but try these:

In your Network settings make sure TCP/IPv6 setting is unchecked but leave TCP/IPv4 checked.

Restart your router (I know most probably have).
In your Router's settings under security make sure Multicast is checked if you have that option.
Try a complete reset of your router.

Windows PC's check bonjour settings:
To enable, right click on My Computer and select Manage. Click on Services under Services and Applications. Right click Bonjour Service and select Properties. Change Startup type to Automatic. And, click Start under Service Status. Click Ok. Restart iTunes

Make sure if you have a firewall you don't have something apple related set to untrusted or blocked.

Check your ports for bonjour on a router:
https://discussions.apple.com/thread...art=0&tstart=0

In iTunes, click "Advanced". Turn OFF Home Sharing. Turn it back ON and it will ask for your iTunes password. Put that in and click "Done."

Try turning off wifi sync in iTunes for your iPhone and iPad, home sharing may now work.

Also check this thread:
https://discussions.apple.com/thread...art=0&tstart=0

Try assigning each device on the network a static IP.



I hope this helps.
frankmacman is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Can't home share to Apple TV through VPN Router laevyboy OS X 1 Aug 25, 2013 08:48 AM
Weird WiFi issue (connect to Apple Store WiFi, but can't connect to home router) nicz888 iPad Tips, Help and Troubleshooting 0 Jul 29, 2013 07:47 AM
Connect to SMB share on reboot ks-man OS X 10.8 Mountain Lion 0 Mar 24, 2013 01:21 PM
iPad Remote with Apple TV and Home share m1ddy Apple TV and Home Theater 2 Feb 20, 2013 09:50 AM
Can't connect Apple TV 3rd gen to home stereo (need 1st gen?) spicynujac Apple TV and Home Theater 4 Dec 17, 2012 10:16 AM

Forum Jump

All times are GMT -5. The time now is 03:19 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC