Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 5, 2012, 06:58 PM   #1
kreekkrew
macrumors newbie
 
Join Date: Jul 2011
Completely Disable Airplay

Hello everyone--

I live in a college dorm, and someone else has an Apple TV. Since I've upgraded to Mountain Lion, I keep seeing the TV as an audio source for Airplay. This would be ok, except for the fact that Garageband keeps asking if I want to use it for the audio output. I have every setting I know of set to disable Airplay, but it keeps happening.

My question: is there a way to completely disable Airplay and/or block specific devices?

Thank you
kreekkrew is offline   0 Reply With Quote
Old Sep 5, 2012, 07:27 PM   #2
heisenberg123
macrumors 603
 
heisenberg123's Avatar
 
Join Date: Oct 2010
Location: Hamilton, Ontario
Quote:
Originally Posted by kreekkrew View Post
Hello everyone--

I live in a college dorm, and someone else has an Apple TV. Since I've upgraded to Mountain Lion, I keep seeing the TV as an audio source for Airplay. This would be ok, except for the fact that Garageband keeps asking if I want to use it for the audio output. I have every setting I know of set to disable Airplay, but it keeps happening.

My question: is there a way to completely disable Airplay and/or block specific devices?

Thank you
well you click the airplay icon and make sure its off
if it is I'm not sure why its detecting ATVs on the network
__________________
15" i7 Quad Core MBP (Early 2011) 2.0GHz, 16GB RAM, 1TB HD, AMD Radeon HD 6490M(Intel HD Graphics 3000) OSX 10.9
16GB Samsung Galaxy SIII with 32GB microSD
heisenberg123 is offline   0 Reply With Quote
Old Sep 5, 2012, 09:31 PM   #3
kreekkrew
Thread Starter
macrumors newbie
 
Join Date: Jul 2011
Quote:
Originally Posted by iisforiphone View Post
well you click the airplay icon and make sure its off
if it is I'm not sure why its detecting ATVs on the network
As far as I know, that only means that I'm not using airplay. It still gives me the option to use the TV, and the notifications pop up, even though mirroring is off. I'd like to just disable Airplay completely so it doesn't even look for devices, but I haven't found any options to do that.
kreekkrew is offline   0 Reply With Quote
Old Sep 6, 2012, 01:37 AM   #4
boto
macrumors 6502
 
Join Date: Jun 2012
No other option unless you can somehow create or join another network. At least you can scare the hell out of them when they are using the Apple TV system by randomly playing music or air playing.
boto is offline   0 Reply With Quote
Old Sep 6, 2012, 06:59 AM   #5
heisenberg123
macrumors 603
 
heisenberg123's Avatar
 
Join Date: Oct 2010
Location: Hamilton, Ontario
Quote:
Originally Posted by kreekkrew View Post
As far as I know, that only means that I'm not using airplay. It still gives me the option to use the TV, and the notifications pop up, even though mirroring is off. I'd like to just disable Airplay completely so it doesn't even look for devices, but I haven't found any options to do that.
is this specific for garage band? ive never had one popup asking me to airplay to my ATV
__________________
15" i7 Quad Core MBP (Early 2011) 2.0GHz, 16GB RAM, 1TB HD, AMD Radeon HD 6490M(Intel HD Graphics 3000) OSX 10.9
16GB Samsung Galaxy SIII with 32GB microSD
heisenberg123 is offline   0 Reply With Quote
Old Sep 7, 2012, 10:53 AM   #6
kreekkrew
Thread Starter
macrumors newbie
 
Join Date: Jul 2011
Quote:
Originally Posted by iisforiphone View Post
is this specific for garage band? ive never had one popup asking me to airplay to my ATV
The notifications are specific to Garageband, but I haven't found any options for directly turning them off. I figured it would be easier to get rid of Airplay altogether, since I never use it anyway.

Quote:
Originally Posted by boto View Post
At least you can scare the hell out of them when they are using the Apple TV system by randomly playing music or air playing.
I already tried rick-rolling him, but he has a password set up on the ATV.
kreekkrew is offline   1 Reply With Quote
Old Sep 7, 2012, 12:12 PM   #7
Risco
macrumors 65816
 
Join Date: Jul 2010
Location: United Kingdom
http://apple.stackexchange.com/quest...upport-airplay


Quote:
It's a Treasure Hunt!

On the iPad:

Click the wrench icon to open the Settings dialog. One of the settings is AirPlay - Bluetooth. Set that to On, and the usual audio output selector will appear in the toolbar.

On the iPhone:

Click the gear icon to open an untitled two-sheet settings dialog. Select the Song sheet. The AirPlay - Bluetooth selector is there
__________________
15" Macbook Pro 2012, 2.3ghz, 8GB Ram, 256GB SSD | iPhone 5s 32GB Space Grey
Risco is offline   0 Reply With Quote
Old Sep 7, 2012, 02:27 PM   #8
kreekkrew
Thread Starter
macrumors newbie
 
Join Date: Jul 2011
Quote:
Originally Posted by Risco View Post
This is happening on my desktop (specifically, my Mid-2011 iMac running Mountain Lion and Garageband '11). Thank you for the info though.
kreekkrew is offline   1 Reply With Quote
Old Sep 7, 2012, 02:35 PM   #9
Risco
macrumors 65816
 
Join Date: Jul 2010
Location: United Kingdom
Quote:
Originally Posted by kreekkrew View Post
This is happening on my desktop (specifically, my Mid-2011 iMac running Mountain Lion and Garageband '11). Thank you for the info though.
Oh, well I just checked Garageband on my mac and it gives an option to choose airplay under preferences audio section.
__________________
15" Macbook Pro 2012, 2.3ghz, 8GB Ram, 256GB SSD | iPhone 5s 32GB Space Grey
Risco is offline   0 Reply With Quote
Old Sep 8, 2012, 04:16 PM   #10
kreekkrew
Thread Starter
macrumors newbie
 
Join Date: Jul 2011
Quote:
Originally Posted by Risco View Post
Oh, well I just checked Garageband on my mac and it gives an option to choose airplay under preferences audio section.
I found that preference too, but again, that only asks if I want to use Airplay. Even if I decline, it still looks for devices, and a notification pops up whenever it finds a new one (said pop-up is shown below). My goal is to avoid looking for devices, so the pop-up doesn't show up whenever someone turns on an ATV.
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2012-09-08 at 4.58.32 PM.png
Views:	30
Size:	31.4 KB
ID:	356401  
kreekkrew is offline   1 Reply With Quote
Old Sep 26, 2012, 11:34 AM   #11
agumby
macrumors newbie
 
Join Date: Sep 2012
I have the exact same problem. As I move around my college campus and local coffee shops, new devices are detected all the time. It affect both Garage Band and also Hindenberg (another audio mixing program), and even interrupts the audio while I'm recording things.
agumby is offline   0 Reply With Quote
Old May 7, 2013, 10:00 PM   #12
dice k
macrumors newbie
 
Join Date: May 2013
Quote:
Originally Posted by kreekkrew View Post
I found that preference too, but again, that only asks if I want to use Airplay. Even if I decline, it still looks for devices, and a notification pops up whenever it finds a new one (said pop-up is shown below). My goal is to avoid looking for devices, so the pop-up doesn't show up whenever someone turns on an ATV.
I am having the same problem. But I found this for trying to block airplay to connect. . . It seems to not be bothering me any more with garage band.

Firewall security settings

If you use the firewall, make sure the following firewall security options have been set to allow AirPlay Mirroring to work:

Choose Apple menu () > System Preferences.
Click Security & Privacy, and then click Firewall.
Click the lock icon to unlock it if it's locked, then type an administrator name and password.
Click Firewall Options.
Select “Block all incoming connections” checkbox.
dice k is offline   0 Reply With Quote
Old Aug 15, 2013, 10:24 AM   #13
RicheeThree
macrumors newbie
 
Join Date: Dec 2012
Quote:
Originally Posted by dice k View Post
I am having the same problem. But I found this for trying to block airplay to connect. . . It seems to not be bothering me any more with garage band.

Firewall security settings

If you use the firewall, make sure the following firewall security options have been set to allow AirPlay Mirroring to work:

Choose Apple menu () > System Preferences.
Click Security & Privacy, and then click Firewall.
Click the lock icon to unlock it if it's locked, then type an administrator name and password.
Click Firewall Options.
Select “Block all incoming connections” checkbox.
Or, if you use multiple sharing services and you don't want to disable all of them, once in the Firewall options, you could just scroll down the list to GarageBand and only "Block incoming connections" for it.
RicheeThree is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 12:01 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC