Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 7

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 27, 2013, 10:06 AM   #26
Jayden0606
macrumors 6502
 
Join Date: Jul 2008
Location: Bergen County, NJ
I reset my Verizon FiOS router and that seemed to have fixed the issue with my home wifi not connecting.

How many did the update on the wifi network they are having the issues on?
Jayden0606 is offline   0 Reply With Quote
Old Jun 28, 2013, 06:17 AM   #27
touchu4g
macrumors member
 
Join Date: May 2012
iPad 3 Wifi on ios 7

For some reason, my friend cannot update his iPad to ios 7. In iTunes, he selects the ios 7 firmware, it updates. On his iPad, there is a black apple logo with a white background and stays that way. He is updating using the shift+update method. I told him to downgrade to 6.1.3 until I find a solution, he really wants ios 7 though. How can I fix this?
touchu4g is offline   0 Reply With Quote
Old Jun 28, 2013, 04:10 PM   #28
newtestleper
macrumors member
 
Join Date: Jun 2013
The problem rectifies itself (temporarily, no doubt) after you've joined a non-home network. I couldn't connect this morning, but after using my (protected) work wifi it connected first time when I got home. Last night and this morning it couldn't connect for love nor money. I hadn't rebooted my router.
newtestleper is offline   0 Reply With Quote
Old Jun 28, 2013, 05:10 PM   #29
Armen
macrumors 68000
 
Join Date: Apr 2013
Quote:
Originally Posted by eaglesteve View Post
My experience with iOS7 wifi connection is the reverse of what the OP has.

I have two wifi in my house. With iOS7, changing from one to the other is almost instant whereas with iOS6 it takes a little longer to complete.
Same
Armen is offline   0 Reply With Quote
Old Jun 30, 2013, 12:33 PM   #30
Perth12
macrumors member
 
Join Date: Jun 2013
My device (iPhone 4s) has never had any troubles with wifi connectivity until installing ios 7 beta 1. No trouble connecting to whatever routers/ connections whatsoever but the connection keeps dropping out even in range requiring me to re-enter the wifi password. This happens with beta 2 aswell and is very frustrating.
Perth12 is offline   0 Reply With Quote
Old Jun 30, 2013, 05:48 PM   #31
8CoreWhore
macrumors 68000
 
8CoreWhore's Avatar
 
Join Date: Jan 2008
Location: Big D
My WiFi was fine on 7 beta 1. Then in 7 beta 2 my settings won't stick. I manually connect, it works for awhile, but if I turn wifi off or leave and come back, it will not connect... it doesn't remember the network.

EDIT===

Ok, I updated my AEBS firmware to it's latest version, and I also set up my laptop and iPhone MAC address up in "Timed Access" inside Network options in the base station to only connect to those two devices (recommended anyway) and I changed all the passwords.

It now works fine... not sure which action did it but I needed to do all of those anyway.
__________________
Late 2013 Haswell 15" rMBP... 2011 13" MBP 2.3Ghz... iPhone 5S iOS7... AEBS 802.11AC ... iPod Shuffle... AppleTV2 (JB aTV Flash [Black] )

Last edited by 8CoreWhore; Jun 30, 2013 at 06:13 PM.
8CoreWhore is offline   0 Reply With Quote
Old Jun 30, 2013, 10:19 PM   #32
prtcool1193
Thread Starter
macrumors member
 
Join Date: Jun 2010
is there any easier way to go about fixing this problem? :/
prtcool1193 is offline   0 Reply With Quote
Old Jun 30, 2013, 11:46 PM   #33
benji888
macrumors 6502a
 
Join Date: Sep 2006
Location: United States
I think iCloud keychain is the culprit:

I didn't turn on icloud keychain when I first put ios 7 beta 2 on my iphone 5, but when I turned it on ios became unstable overall, it would lose wifi connection, and my password at home, once I turned icloud keychain off, wifi issues subsided, and iOS 7 is a bit more stable.
__________________
MacBook Pro 13" (mid2010), 4GB RAM, DIY Fusion drive , OS X 10.9. Viewsonic VX2370SMH 23" IPS
iPhone 5 16GB (A1428) iOS 7 iPad Mini 16GB iOS 7
Macs since 1998
benji888 is offline   0 Reply With Quote
Old Jul 1, 2013, 02:08 AM   #34
Jimrod
macrumors 6502
 
Join Date: Jun 2010
Quote:
Originally Posted by Rift View Post
No, there's nothing changed. It's not just a bit faster, more stable or something like that... Too sad.
Does Apple know about the wifi problems? I don't think so because nothing was changed now and in the notes I can't find something related to these wifi problems.
I doubt it, they do seem to be in a bit of a bubble. As with the iPhone 4 "holding it wrong" issues, I expect they test in-house on all Apple gear and decide if it works on that it'll be fine everywhere. My Wi-Fi would only come back last night after a phone reset.

It's like all these companies trying to force us down the cloud route - in an ideal world yes, it makes sense, in reality people travel and end up with data roaming charges that could amount to $$$$'s if they were to put everything in "the cloud".
Jimrod is offline   0 Reply With Quote
Old Jul 2, 2013, 12:36 AM   #35
benji888
macrumors 6502a
 
Join Date: Sep 2006
Location: United States
iCloud Keychain is the culprit for me.

I tried turning this function on again, went through all the steps and then got home and it had difficulty connecting and then I had to select it and the password was gone. I did not have this problem for all the days I had iCloud Keychain off. So, I turned iCloud Keychain off and, after getting on wifi w/password and such, back to normal.

This is the first iteration of iCloud Keychain, so I'm sure it'll improve in future beta releases, I'm staying away from it myself, will try again in beta 3 (next week!)
__________________
MacBook Pro 13" (mid2010), 4GB RAM, DIY Fusion drive , OS X 10.9. Viewsonic VX2370SMH 23" IPS
iPhone 5 16GB (A1428) iOS 7 iPad Mini 16GB iOS 7
Macs since 1998
benji888 is offline   0 Reply With Quote
Old Jul 7, 2013, 03:19 PM   #36
Jayden0606
macrumors 6502
 
Join Date: Jul 2008
Location: Bergen County, NJ
Quote:
Originally Posted by benji888 View Post
iCloud Keychain is the culprit for me.

I tried turning this function on again, went through all the steps and then got home and it had difficulty connecting and then I had to select it and the password was gone. I did not have this problem for all the days I had iCloud Keychain off. So, I turned iCloud Keychain off and, after getting on wifi w/password and such, back to normal.

This is the first iteration of iCloud Keychain, so I'm sure it'll improve in future beta releases, I'm staying away from it myself, will try again in beta 3 (next week!)
I'm trying it now... doesn't seem to be working for me.

May have to do a reset?

I did a soft reset (reboot) and still not working. This is the only change for me as well... turning iCloud Keychain on!
Jayden0606 is offline   0 Reply With Quote
Old Jul 7, 2013, 03:59 PM   #37
Jayden0606
macrumors 6502
 
Join Date: Jul 2008
Location: Bergen County, NJ
Quote:
Originally Posted by Jayden0606 View Post
I'm trying it now... doesn't seem to be working for me.

May have to do a reset?

I did a soft reset (reboot) and still not working. This is the only change for me as well... turning iCloud Keychain on!
Fixed. Rebooted my router and that did the trick.
Jayden0606 is offline   0 Reply With Quote
Old Jul 12, 2013, 08:44 AM   #38
nhlfreak98
macrumors 6502
 
Join Date: Apr 2013
My iphone 5 always disconnects from wifi on iOS 6 idk why. I was at my cousins house and it didn't do this only at my house
nhlfreak98 is offline   0 Reply With Quote
Old Aug 3, 2013, 09:21 PM   #39
newtestleper
macrumors member
 
Join Date: Jun 2013
Quote:
Originally Posted by benji888 View Post
iCloud Keychain is the culprit for me.

I tried turning this function on again, went through all the steps and then got home and it had difficulty connecting and then I had to select it and the password was gone. I did not have this problem for all the days I had iCloud Keychain off. So, I turned iCloud Keychain off and, after getting on wifi w/password and such, back to normal.

This is the first iteration of iCloud Keychain, so I'm sure it'll improve in future beta releases, I'm staying away from it myself, will try again in beta 3 (next week!)
Seems to have worked for me too. Keychain was already active from an earlier beta, but I just entered my password, enabled Keychain and then immediately disabled it. Connected to wifi first time after this.
newtestleper is offline   0 Reply With Quote
Old Sep 19, 2013, 04:44 PM   #40
Wali
macrumors newbie
 
Join Date: Sep 2013
Quote:
Originally Posted by prtcool1193 View Post
Does anyone else seem to have major wifi problems with the beta? My iPhone 5 has wifi turned on, recognizes the network but continuously fails to join. This has happened at numerous locations. I've tried resetting network settings but it still is giving me problems. The interesting thing is that this has only started happening yesterday. Before then it was fine with ios 7


Yes I I have the same problem even my brother we got the iPhone 5 it's the ios. 7 fualt apple fix it!!!!!
Wali is offline   0 Reply With Quote
Old Sep 22, 2013, 08:17 AM   #41
Lisa M
macrumors newbie
 
Join Date: Sep 2013
IOS 7 Wifi Login Issue

Can someone please reply with what error message you are getting when trying to log on to Wifi with IOS 7? Reason is that I have an IPhone 4. I upgraded because someone who lives where I work said he was having trouble logging on to our Wifi. I'm a concierge at a high rise with free wifi for residents. With my old operating system that came with my phone, I was having no troubles & no one else had reported an issue, as well as our IT guy said prob was not with the wifi. Ever since upgrading to IOS 7, I get error message something about hotspot note being able to log on because server can't be found. I have no trouble logging on to my wifi at home. Another strange thing....I changed my settings so that I am not using so much of my cell data plan. If I set it right, it is not supposed to log on to internet unless there is wifi available. After I click "done" on the error message, I am able to view my facebook and my emails. When I was someplace without wifi yesterday, it would not log on to facebook.
Lisa M is offline   0 Reply With Quote
Old Sep 23, 2013, 07:16 PM   #42
saolis
macrumors newbie
 
Join Date: Sep 2013
Wifi signal disconects easily

I just upgraded to ios7, and it is pretty obvious that this new OS has a problem with wifi. In my office not so far from the wireless router my ip5 never lost the wifi connection, but now with ios7 it looses it pretty fast and does not re-connect automatically, i have to go to wifi and wait for it to show the network and tap on it to connect again. Does anyone have the same problem?
saolis is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:45 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC