Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 14, 2012, 06:52 PM   #1
gadgetmonster
macrumors regular
 
Join Date: Feb 2011
Problem with off/on button?

Anyone had an issue with their top right hand side button either not turning the screen off or on, or a delayed action? Mine has been doing this. It is quite annoying.
gadgetmonster is offline   0 Reply With Quote
Old Nov 14, 2012, 08:43 PM   #2
gadgetmonster
Thread Starter
macrumors regular
 
Join Date: Feb 2011
Um, thanks.
gadgetmonster is offline   0 Reply With Quote
Old Nov 14, 2012, 10:54 PM   #3
bawuva
macrumors newbie
 
Join Date: Jul 2010
I actually was just going to post the same thing. I just started experiencing this the last 2 days. Throughout the day I would have to push the on/off button several times for it to go to sleep. Is anyone else experiencing this problem?
bawuva is offline   0 Reply With Quote
Old Nov 14, 2012, 10:56 PM   #4
MXSkier62
macrumors regular
 
Join Date: Dec 2006
Same thing has been happening to me. I posted about it a few days ago but no one really supported me. Any thoughts about what you all want to do? Exchange? Will Apple do that for this?
__________________
13" 2011 MBA, 1.7 GHz i5, 4 GB RAM, 256 GB SSD;
iPad 2 32 GB; iPhone 4 32 GB
MXSkier62 is offline   0 Reply With Quote
Old Nov 14, 2012, 11:08 PM   #5
bawuva
macrumors newbie
 
Join Date: Jul 2010
I saw some other threads where people had the same problem. It looks like if you press on the left side of the button it works fine. If you press on the middle or more to the right that is where it has issues.

Sounds like others have gone to the Apple store and they replaced it with a new one.
bawuva is offline   0 Reply With Quote
Old Nov 15, 2012, 12:26 AM   #6
Aaleck
macrumors 6502a
 
Join Date: Oct 2007
Location: Michigan, USA
Mine stopped working like yours. I would have to push it a few times to turn it off/on, sometimes it would recognize all of the pushes and the screen of flash on and off. Called apple and they shipped me a refurb replacement
Aaleck is offline   0 Reply With Quote
Old Nov 15, 2012, 06:59 AM   #7
gadgetmonster
Thread Starter
macrumors regular
 
Join Date: Feb 2011
same thing happens to me; looks like i'll need to bring it to a store for a replacement.
gadgetmonster is offline   0 Reply With Quote
Old Nov 15, 2012, 08:41 AM   #8
cheeeeesus
macrumors newbie
 
Join Date: Jun 2012
Same thing here. Sometimes it works okay tho, so I hesitated to go to the Apple Shop, since it's quite unpredictable whether I can show them the problem.
cheeeeesus is offline   0 Reply With Quote
Old Nov 15, 2012, 08:46 AM   #9
joeyboyyy91
macrumors member
 
Join Date: Aug 2010
same happened to mine.

Got it exchanged a couple of days ago at the apple store. It becomes annoying, and after a while even the pressing the left side stopped working for me.

might as well get it exchanged.
__________________
13" MacBook alu 2.0 GHz core 2 duo - 8GB RAM - 64GB SSD + 750GB HDD - Optibay adapter

iPhone 5
joeyboyyy91 is offline   0 Reply With Quote
Old Nov 15, 2012, 11:52 AM   #10
tvith
macrumors member
 
Join Date: Nov 2012
---

Last edited by tvith; Nov 16, 2012 at 02:12 PM.
tvith is offline   0 Reply With Quote
Old Nov 15, 2012, 02:00 PM   #11
MXSkier62
macrumors regular
 
Join Date: Dec 2006
Going in a few hours. Set up the appt in store so they saw the defect and admitted it wasn't normal. I'll let you all know how it goes.
MXSkier62 is offline   0 Reply With Quote
Old Nov 15, 2012, 07:23 PM   #12
MXSkier62
macrumors regular
 
Join Date: Dec 2006
Walked in. Showed them the problem. Walked out 15 minutes with a new perfect phone. Easy as that.
__________________
13" 2011 MBA, 1.7 GHz i5, 4 GB RAM, 256 GB SSD;
iPad 2 32 GB; iPhone 4 32 GB
MXSkier62 is offline   0 Reply With Quote
Old Nov 15, 2012, 08:45 PM   #13
gadgetmonster
Thread Starter
macrumors regular
 
Join Date: Feb 2011
They replaced mine with a new one today as well, no big deal and it only took 15min.
gadgetmonster is offline   0 Reply With Quote
Old Nov 15, 2012, 08:49 PM   #14
tgi
macrumors 6502a
 
tgi's Avatar
 
Join Date: Aug 2012
How long of a delay are we talking about? Has it done it right of the box?
tgi is offline   0 Reply With Quote
Old Nov 15, 2012, 09:06 PM   #15
Matthew9559
macrumors 6502a
 
Matthew9559's Avatar
 
Join Date: Apr 2007
Location: Texas
I had the same thing with my iPhone 4 last year. They handed me a new one after a few seconds of showing the guy the issue.
Matthew9559 is offline   0 Reply With Quote
Old Nov 16, 2012, 05:44 AM   #16
SarZ
macrumors newbie
 
Join Date: Mar 2008
I had the same problem with my iPhone 5 and it was replaced by Apple.
Here is the thread where I mention the problem http://forums.macrumors.com/showthread.php?t=1484788

Out of curiosity do any of you use a magnetic case on your iPhone?
My problem started a few days after I started to use a magnetic case
SarZ is offline   0 Reply With Quote
Old Nov 16, 2012, 01:25 PM   #17
Erock2
macrumors member
 
Join Date: Jun 2012
I went into a Apple store on tuesday and the Apple jerk basically blamed me saying that I was looking to much into it and that it looks perfectly normal to him, so he did a "DFU Wipe" and said it should be better... a couple days later and it's worse! Made an appointment to go back today... hopefully it gets fixed this time.
Erock2 is offline   0 Reply With Quote
Old Nov 16, 2012, 04:41 PM   #18
Ih8reno
macrumors 6502a
 
Join Date: Aug 2012
Mine wouldn't work when clicking in the right side. I brought it to an apple store and the employee said its a hardware defect and switched it out for me in 5 min.
__________________
Check out my new blog! In progress
Mac Montreal
Ih8reno is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Lock button problem chrisd0pher iPhone 1 Dec 28, 2012 09:04 PM
Problem with i5 volume button prism iPhone 3 Oct 3, 2012 02:58 PM
iPhone 4 Sleep/wake button, vibrate button, and volume button not responsive McEggrolls iPhone 6 Sep 20, 2012 10:16 AM
Power button problem NoName94 iPhone Tips, Help and Troubleshooting 0 Sep 14, 2012 09:04 PM
power button problem macguru911 Mac Pro 2 Jul 12, 2012 06:23 AM

Forum Jump

All times are GMT -5. The time now is 08:19 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC