Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Desktops > iMac

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 11, 2012, 12:44 PM   #1
ThatGreekMacGuy
macrumors member
 
Join Date: Jul 2012
Location: Sparta, Greece
iMac slow graphics?

Hey guys I installed Windows 8 64bit via Bootcamp. You can see my specs in my signature. For some reason when i run a game (assassins creed or need for speed) the frame rate is REALLT LOW. I get 6-10 fps. My sisters vaio is much worse but runs the game fine. all the drivers are updated. anyone ever had the same problem? what should i do?
__________________
 27" iMac: Quad-Core i7 @2.93GHz, 8GB DDR3 @1333MHz, 5750 with 1GB VRAM & 1TB HDD (Mid 2010 model)
 iPhone 4 32GB (Black)
 iPod Touch 2G 16GB
ThatGreekMacGuy is offline   0 Reply With Quote
Old Dec 11, 2012, 12:46 PM   #2
MacsRgr8
macrumors 604
 
MacsRgr8's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Tried installing the "real" ATi/AMD drivers (from their site) for the grfx card?
__________________
Steve Jobs. 1955 - 2011. My Hero.
MacsRgr8 is offline   0 Reply With Quote
Old Dec 11, 2012, 01:01 PM   #3
ThatGreekMacGuy
Thread Starter
macrumors member
 
Join Date: Jul 2012
Location: Sparta, Greece
Quote:
Originally Posted by MacsRgr8 View Post
Tried installing the "real" ATi/AMD drivers (from their site) for the grfx card?
Yes I installed the latest ones from amd/ati. any ideas?
__________________
 27" iMac: Quad-Core i7 @2.93GHz, 8GB DDR3 @1333MHz, 5750 with 1GB VRAM & 1TB HDD (Mid 2010 model)
 iPhone 4 32GB (Black)
 iPod Touch 2G 16GB
ThatGreekMacGuy is offline   0 Reply With Quote
Old Dec 11, 2012, 02:59 PM   #4
ThatGreekMacGuy
Thread Starter
macrumors member
 
Join Date: Jul 2012
Location: Sparta, Greece
Anyone help?
ThatGreekMacGuy is offline   0 Reply With Quote
Old Dec 12, 2012, 11:58 AM   #5
ThatGreekMacGuy
Thread Starter
macrumors member
 
Join Date: Jul 2012
Location: Sparta, Greece
is it a problem with windows 8? do you think that windows 8 drivers might cause it? should i install win 7 x64? does anyone else has a partition of win 8?
__________________
 27" iMac: Quad-Core i7 @2.93GHz, 8GB DDR3 @1333MHz, 5750 with 1GB VRAM & 1TB HDD (Mid 2010 model)
 iPhone 4 32GB (Black)
 iPod Touch 2G 16GB
ThatGreekMacGuy is offline   0 Reply With Quote
Old Dec 12, 2012, 12:05 PM   #6
Fried Chicken
macrumors regular
 
Join Date: Jun 2011
Don't install the graphics from the ATI website, instead use windows updater.
Fried Chicken is offline   0 Reply With Quote
Old Dec 12, 2012, 03:24 PM   #7
ThatGreekMacGuy
Thread Starter
macrumors member
 
Join Date: Jul 2012
Location: Sparta, Greece
Quote:
Originally Posted by Fried Chicken View Post
Don't install the graphics from the ATI website, instead use windows updater.
Could this be the problem?
__________________
 27" iMac: Quad-Core i7 @2.93GHz, 8GB DDR3 @1333MHz, 5750 with 1GB VRAM & 1TB HDD (Mid 2010 model)
 iPhone 4 32GB (Black)
 iPod Touch 2G 16GB
ThatGreekMacGuy is offline   0 Reply With Quote
Old Dec 13, 2012, 09:01 PM   #8
Fried Chicken
macrumors regular
 
Join Date: Jun 2011
Quote:
Originally Posted by ThatGreekMacGuy View Post
Could this be the problem?
I spent like 2h trying to get the drivers to work on my imac,
and it was a pain in the ass involving a bunch of amd bloatware. Finally I did windows update and voila, graphics drivers installed and worked no problem.. Was very impressed with MS at that point, very well done.
Fried Chicken is offline   0 Reply With Quote
Old Dec 14, 2012, 05:57 PM   #9
ThatGreekMacGuy
Thread Starter
macrumors member
 
Join Date: Jul 2012
Location: Sparta, Greece
Quote:
Originally Posted by Fried Chicken View Post
I spent like 2h trying to get the drivers to work on my imac,
and it was a pain in the ass involving a bunch of amd bloatware. Finally I did windows update and voila, graphics drivers installed and worked no problem.. Was very impressed with MS at that point, very well done.
Everything works like a charm now mate! Thanks!
ThatGreekMacGuy is offline   1 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > iMac

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Very slow graphics - 3FPS - iMac 27" 2011 BradClarke iMac 4 Mar 25, 2013 12:18 PM
Retina MBP - Slow graphics performance in some cases Mork MacBook Pro 3 Feb 18, 2013 04:42 PM
Windows 7 nVidia Graphics Issues -- Lag/Slow aar3n Windows, Linux & Others on the Mac 0 Nov 25, 2012 09:23 PM
Very slow Graphics Performance with rMPB GuitarNut MacBook Pro 8 Sep 16, 2012 07:57 AM
Intel HD 4000 Graphics Drivers slow bootup. ilkevinli Windows, Linux & Others on the Mac 3 Jul 3, 2012 05:22 PM

Forum Jump

All times are GMT -5. The time now is 09:43 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC