Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 7, 2012, 12:09 PM   #1
IzzyJG99
macrumors 6502
 
Join Date: Oct 2007
iTunes 11 Incoming Request Bug.

Just updated to iTunes 11 after doing a restore. iTunes 11 was working fine for a while. I get around to adding my iPad and iPhone to iTunes, which I wirelessly sync. Instantly every time I open iTunes 11 it asks me to allow or deny incoming connections. iTunes is already allowed to come through the firewall. Never had this problem before. I switched my iPhone and iPad to connect only via the cable and not wirelessly and the bug stops. Obviously iTunes 11 in some cases is viewing incoming connections via Wi-Fi from iOS devices as a threat and requests permission each time.

Reported the bug to Apple. I doubt anything will come of it. But I thought I'd share to see how many people are experiencing this issue.
__________________
20" iMac 3.06GHz Intel Core 2 Duo, 4GB RAM, 500GB HD; iPod Touch 16GB 2nd Gen; iPhone 4 16GB, iPad 2 16GB.
IzzyJG99 is offline   1 Reply With Quote
Old Dec 11, 2012, 11:06 AM   #2
redseagoby
macrumors newbie
 
Join Date: Dec 2012
incoming request bug

same here on 2012 Retina Macbook Pro, except in my case I sync using the cable, directly with iTunes. Stumped Level 2 Apple Support (but this was after Level 1 support told me to delete my entire system cache, which introduced a serious Time Machine bug/error causing it to never complete. I got rid of that after some serious hacking and terminal command line repair sequences. Be careful - the bug is far less of a problem than that "cure" which didn't work was).
redseagoby is offline   0 Reply With Quote
Old Dec 11, 2012, 12:48 PM   #3
Macmonter
macrumors member
 
Join Date: Aug 2008
Location: Vermont, USA
iTunes 11 Incoming Request Bug

Yes! I have it, too! It keeps coming back every time I open iTunes even though I click "ALLOW" every time. Aggravating, but I'll live with it until fixes it.
__________________
Macmonter

2008 Mac Pro 3.1, 2X 2.8 GHz Quad, 6 GB RAM, 320 GB + 1.5 TB + 3TB internal HD, 2 TB external HD, OS 10.6.8, 27" NEC Multisync EA273WM
Macmonter is offline   0 Reply With Quote
Old Dec 11, 2012, 12:51 PM   #4
Peace
macrumors P6
 
Peace's Avatar
 
Join Date: Apr 2005
Location: Space--The ONLY Frontier
What apps on your iDevices might you have in common ?
Peace is offline   0 Reply With Quote
Old Dec 11, 2012, 08:53 PM   #5
Macmonter
macrumors member
 
Join Date: Aug 2008
Location: Vermont, USA
Quote:
Originally Posted by Peace View Post
What apps on your iDevices might you have in common ?
I have no iDevices! The message returns repeatedly even when "DENY" selected, and no boxes checked under "STORE" in Preferences
__________________
Macmonter

2008 Mac Pro 3.1, 2X 2.8 GHz Quad, 6 GB RAM, 320 GB + 1.5 TB + 3TB internal HD, 2 TB external HD, OS 10.6.8, 27" NEC Multisync EA273WM
Macmonter is offline   0 Reply With Quote
Old Dec 11, 2012, 09:50 PM   #6
JRoDDz
macrumors 68000
 
JRoDDz's Avatar
 
Join Date: Jul 2009
Location: NJ
Quote:
Originally Posted by IzzyJG99 View Post
Just updated to iTunes 11 after doing a restore. iTunes 11 was working fine for a while. I get around to adding my iPad and iPhone to iTunes, which I wirelessly sync. Instantly every time I open iTunes 11 it asks me to allow or deny incoming connections. iTunes is already allowed to come through the firewall. Never had this problem before. I switched my iPhone and iPad to connect only via the cable and not wirelessly and the bug stops. Obviously iTunes 11 in some cases is viewing incoming connections via Wi-Fi from iOS devices as a threat and requests permission each time.

Reported the bug to Apple. I doubt anything will come of it. But I thought I'd share to see how many people are experiencing this issue.
I was having the same exact issue with iTunes 11 always requesting permission.. I had to uninstall iTunes 11 (which wasn't easy) and reinstall from Apple.com website instead of AppStore update. Now that that is fixed.. I'm having an issue now where my Apple TV2 will disconnect from home sharing when the iMac goes to sleep after 10 minutes.. frustrating! I seem to think the firewall is the culprit.. going to disable the firewall completely and see if it improves.
JRoDDz is offline   0 Reply With Quote
Old Dec 12, 2012, 02:45 AM   #7
bucksaddle
macrumors regular
 
Join Date: Dec 2008
Although you may have not seen it in previous versions of iTunes I've had this issue periodically since about iTunes 9, including point releases, on different Macs. It's happended to me again in iTunes 11 so I wouldn't hold out hope on Apple fixing it.
There is a solution as JRoDDz mentions but it means removing iTunes.app by the Terminal, as you can't just drag the app to the Trash, and then re-install from apple.com.
Just Google for "sudo remove itunes". Don't worry, it will only remove the app and not your Library and when you re-install from the download the firewall message should be gone.
bucksaddle is offline   0 Reply With Quote
Old Jan 2, 2013, 02:52 PM   #8
Mike MA
macrumors 6502a
 
Mike MA's Avatar
 
Join Date: Sep 2012
Location: Germany, Europe
Quote:
Originally Posted by bucksaddle View Post
Although you may have not seen it in previous versions of iTunes I've had this issue periodically since about iTunes 9, including point releases, on different Macs.
Same for me - and for some reason it always disappeared sooner or later. Don't know why, but I certainly didn't remove and reinstalled the app.

This time it started with a clean install which I've done some days ago, iTunes 11 wasn't the reason, as I used it before.
__________________
Macbook Air 13" (late 2010) - Apple TV2 - Time Capsule - iPhone 4
Mike MA is offline   0 Reply With Quote
Old Jan 16, 2013, 05:42 AM   #9
e4xit
macrumors newbie
 
Join Date: Dec 2012
I have a completely fresh install of ML on late 2012 iMac 21.5" and it happens.

Basically, I added my music and imported my old library from my windoze 7 machine, then enabled the firewall in system prefs and its happening.!?

This can't be right, surely this isn't the hassle-free OSX I've been bearing so much about!

But seriously, it is a little annoying; if anyone has a fix, please let me know...

Also here:
http://discussions.apple.com/thread/4692937
e4xit is offline   0 Reply With Quote
Old Jan 16, 2013, 05:46 AM   #10
LPZ
macrumors 65816
 
Join Date: Jul 2006
Quote:
Originally Posted by e4xit View Post
I have a completely fresh install of ML on late 2012 iMac 21.5" and it happens.

Basically, I added my music and imported my old library from my windoze 7 machine, then enabled the firewall in system prefs and its happening.!?

This can't be right, surely this isn't the hassle-free OSX I've been bearing so much about!

But seriously, it is a little annoying; if anyone has a fix, please let me know...

Also here:
http://discussions.apple.com/thread/4692937
See http://forums.macrumors.com/showthread.php?t=1525142
LPZ is offline   0 Reply With Quote
Old Jan 16, 2013, 05:49 AM   #11
e4xit
macrumors newbie
 
Join Date: Dec 2012
Will try. Thanks!

this won't delete my iTunes library file or backups or anything right?
e4xit is offline   0 Reply With Quote
Old Jan 16, 2013, 06:39 AM   #12
LPZ
macrumors 65816
 
Join Date: Jul 2006
Quote:
Originally Posted by e4xit View Post
Will try. Thanks!

this won't delete my iTunes library file or backups or anything right?
If you follow the steps in that thread, the only thing you will delete is the iTunes application in the Applications folder. Your library will not be touched.
LPZ is offline   0 Reply With Quote
Old Jan 16, 2013, 06:44 AM   #13
e4xit
macrumors newbie
 
Join Date: Dec 2012
Lovely job.

Will try tonight when I get home, perhaps making a backup of the library file first, just in case y'know!...

e4xit is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Incoming Friend Request: ticketcover Kilamite Site and Forum Feedback 3 Apr 24, 2014 01:02 PM
iTunes Error: We could not complete your iTunes Store request eneisch Mac Applications and Mac App Store 2 Jun 27, 2013 09:04 AM
ML Do you want the application “iTunes.app” to accept incoming network connections? ravinder08 OS X 10.8 Mountain Lion 13 Apr 26, 2013 07:43 AM
After iTunes upgrade being asked to allow incoming permissions every time. Why? michial MacBook Pro 2 Dec 6, 2012 08:33 AM
After iTunes upgrade being asked to allow incoming permissions every time. Why? michial Mac Applications and Mac App Store 6 Dec 4, 2012 08:44 AM

Forum Jump

All times are GMT -5. The time now is 08:07 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC