Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread Display Modes
Old Jan 8, 2013, 11:13 AM   #1
macrumors newbie
Join Date: Jan 2013
WD 2TB My Passpost does not show up on MBA

I had this external hard drive for 6 months now. Today I was using my computer like usual with the hard drive plugged in when suddenly it shows a dialog saying that my external hard drive has been incorrectly removed.

I haven't been able to use my hard drive since. When I plug it in, there's no running noise, the hard drive doesn't show up on the desktop or in the disk utilities. The LED activity light on the hard drive is out too.

Please help, lots of important data on it.
kchirayus is offline   0 Reply With Quote
Old Jan 8, 2013, 11:23 AM   #2
Join Date: Nov 2010
Location: located
Either the enclosure or the HDD itself could have died.

You could remove the HDD from its enclosure and try it in a different one (USB <> SATA adapters can be had for 10 €) and see, if that works.

If that does not work, you have to contact WD about your warranty. I do not know, what WD's warranty says about data recovery or similar, but I presume, that it is not covered and they will probably just send you a replacement.

If you have an experienced computer repair store nearby, you could also employ their help.

And for the future, as backing up is important:
I have one 500 GB HDD for my photographs (digital and analog), libraries and editing documents, one 500 GB HDD with my personal video footage in an editing friendly format.
Both 500 GB HDDs get backed up to one 1 TB HDD via CarbonCopyCloner.
And that 1 TB HDD gets backed up to another 1 TB HDD via CarbonCopyCloner.
Therefore I have three copies of my important data.
simsaladimbamba is offline   0 Reply With Quote
Old Jan 8, 2013, 12:00 PM   #3
macrumors 6502a
goinskiing's Avatar
Join Date: Jun 2008
Location: Meridian, ID
Just bought exactly one of these the other day and it works fine for my MBA. I store my entire Aperture library on it backed up to a 4TB drive at home.
2013 15" rMBP 2.4GHz 256GB w/8GB; 27" iMac, 2.8GHz i5, 16GB,SSD 128GB+1TB; 32GB Silver Verizon iPhone 5s; 16GB iPad Mini Retina Space Gray; TV2
goinskiing is offline   0 Reply With Quote
Old Jan 9, 2013, 05:45 AM   #4
macrumors 6502
Join Date: Dec 2009
Go into Disk Utility and see if it's picked up the drive but is showing as unmounted. If so, try to mount it, also try to Verify Disk.
JonLa is offline   0 Reply With Quote
Old Jan 9, 2013, 09:40 AM   #5
macrumors newbie
Join Date: Jan 2013
I know it might be obvious, but have you tried a new lead for the HDD in case it's the cause of the failure.

The other option have you tried some other device in the USB, in case the port has lost power

Last edited by mctintin; Jan 9, 2013 at 09:42 AM. Reason: additional info
mctintin is offline   0 Reply With Quote
Old Jan 9, 2013, 01:44 PM   #6
macrumors 65816
Join Date: May 2009
Location: Hamilton Island, Whitsundays, QLD Australia
I stay well away from Western Digital products.
their controllers are 'integrated' so recovery of data is nigh impossible when they stuff up.
halledise is offline   0 Reply With Quote

MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
*Roll up!* It's 2013 MBA season: Show us a realistic spec that would make YOU buy it! Jobsian MacBook Air 77 May 7, 2013 04:22 PM
MBA wont show DVD sharing? harleymhs MacBook Air 0 Feb 9, 2013 08:13 AM
Moving from MBP with 1tb to MBA with 256gb and 2tb ext hdd Hexley MacBook Air 3 Nov 27, 2012 04:17 AM

Forum Jump

All times are GMT -5. The time now is 03:03 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013,, LLC