Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 15, 2013, 06:51 PM   #1
ccy-mba
macrumors newbie
 
Join Date: Jan 2013
Angry MBA wifi connection problem

Hi,

I have a 2012 MBA, OS X 10.8.2, i5. I am having problems with my wifi. When I am at home, my MBA automatically connects to my school's wifi network because I live just a couple blocks away. In order to connect to my Motorola wifi at home, I would have to manually open Network, and it would take me several tries for it to successfully connect to Motorola. I have even prioritized the network preferences so that Motorola would be at the top of the list and my school's network at the very bottom. Any help would be greatly appreciated.

Thanks!

PS I went to the Genius Bar with this problem. The guy there suggested me to change the setting of my Motorola wifi from WPA2 to WEP, but Motorola doesn't give me that option.
ccy-mba is offline   0 Reply With Quote
Old Jan 15, 2013, 07:27 PM   #2
Nimravus
macrumors member
 
Join Date: Jan 2013
Hmm, that's strange. That's what the Preferred Network setting is for, so you can put in order which one to connect first. Maybe it's seeing the school WiFi before it sees the Motorola? Have you gone into the Admin settings of the Motorola and disabled any power saving feature it may have? Maybe start over with the network connections? Wipe them all out and then connect to them and order them again? Computers are glitchy sometimes..

Oh, and don't take the crazy advice of going WEP. You can easily look up how to hack onto a WEP WiFi on the web and leech free wifi from your router. Its highly unlikely that anyone would, but they could. Stay with WPA2, has nothing to do with it I would imagine as I'm using WPA2 and mine connects in order just fine.
Nimravus is offline   0 Reply With Quote
Old Jan 16, 2013, 08:48 PM   #3
ccy-mba
Thread Starter
macrumors newbie
 
Join Date: Jan 2013
Hi, thanks for responding. I'm not very savvy with ALL of this. I went into the Admin Settings of Motorola, and I don't recognize if it has any power saving features. And when you mentioned starting over with the network connections, do you mean unplugging the router and plugging it back in again? haha I've definitely tried that when I've lost complete connection. But if you were suggesting starting over from the very beginning, I am a tad afraid because I don't even know how I got it all ?configured? in the first place. I think it was a miracle, haha.

Quote:
Originally Posted by Nimravus View Post
Hmm, that's strange. That's what the Preferred Network setting is for, so you can put in order which one to connect first. Maybe it's seeing the school WiFi before it sees the Motorola? Have you gone into the Admin settings of the Motorola and disabled any power saving feature it may have? Maybe start over with the network connections? Wipe them all out and then connect to them and order them again? Computers are glitchy sometimes..

Oh, and don't take the crazy advice of going WEP. You can easily look up how to hack onto a WEP WiFi on the web and leech free wifi from your router. Its highly unlikely that anyone would, but they could. Stay with WPA2, has nothing to do with it I would imagine as I'm using WPA2 and mine connects in order just fine.
ccy-mba is offline   0 Reply With Quote
Old Jan 16, 2013, 09:00 PM   #4
Nimravus
macrumors member
 
Join Date: Jan 2013
Hello, when I said to start over with the network settings I meant on your Mac. Delete all preferred connections and then add them again. I think what is happening is somehow your Mac is seeing the school WiFi first before your Motorola, this connecting to it first. Maybe to confirm this, turn off your wifi radio, then turn it on and watch what signals pop up first?

I tend to still think its just seeing the school wifi signal first. In which case maybe just make sure the Motorola is always transmitting and not on any power save passive mode?

Good luck, I know computers can be finicky sometimes working together with different brands and components.
Nimravus is offline   0 Reply With Quote
Old Jan 16, 2013, 09:25 PM   #5
ccy-mba
Thread Starter
macrumors newbie
 
Join Date: Jan 2013
Oh, I see. Yes, I've tried that. And without fail, it has always recognized the school's wi-fi first.

What's strange is that my roommate doesn't have this problem with her MacBook Pro. So I think that it's a problem with my MBA, unfortunately.
ccy-mba is offline   0 Reply With Quote
Old Jan 16, 2013, 09:38 PM   #6
ccy-mba
Thread Starter
macrumors newbie
 
Join Date: Jan 2013
Oh my gosh, oh my gosh, oh my gosh. I did what you said, and it worked! When I replied to your post earlier saying that I tried your suggestion, I never purposefully erased and added again the wifi networks. I did with the school wifi recently, but not Motorola. So I deleted and re-added Motorola, and voila! Thank you again for your help and for being patient. I am very, very grateful!
ccy-mba is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:27 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC