Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Mac Peripherals

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 3, 2012, 10:20 PM   #26
AndyDiamond
macrumors regular
 
Join Date: Jul 2004
I read something that said you need to make sure the first USB device you plug in to your USB3 hub is a USB3 device. If you plug a USB2 device in first it will set the whole hub at that speed!
__________________
"Today's Macs are blazingly fast but people still whine about them not having stuff they'll never use on them anyway."
AndyDiamond is offline   0 Reply With Quote
Old Dec 4, 2012, 09:21 PM   #27
joeblough
macrumors member
 
Join Date: Oct 2006
while building a hackintosh, i came across this:

http://via-labs.com/en/support/downloads.jsp

the changelog for firmware 0.9.6 says that they have improved OSX compatibility. i'm not entirely sure if this VIA chip is used in standalone USB 3.0 hubs, or just on motherboards.

also they say that end users should not try to use the firmware update, and besides, you need windows to do the update. but i think it could mean that some older hubs could be buggy. assuming this chip shows up in external USB3.0 hubs, perhaps apple has worked around whatever problems there are with the older firmware by now.
joeblough is offline   0 Reply With Quote
Old Dec 4, 2012, 10:01 PM   #28
Mr. Retrofire
macrumors 601
 
Mr. Retrofire's Avatar
 
Join Date: Mar 2010
Location: www.emiliana.cl
Quote:
Originally Posted by joeblough View Post
while building a hackintosh, i came across this:

http://via-labs.com/en/support/downloads.jsp

the changelog for firmware 0.9.6 says that they have improved OSX compatibility. i'm not entirely sure if this VIA chip is used in standalone USB 3.0 hubs, or just on motherboards.
The STARTECH HUB (ST4300USB3EU) uses the VLI VL810 chipset:
http://www.cclonline.com/content/pdf...LQeA-3d-3d.pdf
(and is compatible with Mac OS X 10.8, after the firmware update)

Quote:
Originally Posted by joeblough View Post
...also they say that end users should not try to use the firmware update, and besides, you need windows to do the update
You can do this probably via Bootcamp or newer versions of VMware Fusion.

Quote:
Originally Posted by joeblough View Post
but i think it could mean that some older hubs could be buggy. assuming this chip shows up in external USB3.0 hubs, perhaps apple has worked around whatever problems there are with the older firmware by now.
No, firmware updates for such chips are normal. They can improve the performance on certain systems, which have buggy drivers. Hardware needs a official certification, Apples xHCI driver does not have a official certification, so i think the problem is Apples xHCI driver. Not the only driver which has problems.
__________________

“Only the dead have seen the end of the war.”
-- Plato --
Mr. Retrofire is offline   0 Reply With Quote
Old Dec 5, 2012, 08:15 PM   #29
joeblough
macrumors member
 
Join Date: Oct 2006
Quote:
Originally Posted by Mr. Retrofire View Post
The STARTECH HUB (ST4300USB3EU) uses the VLI VL810 chipset:
http://www.cclonline.com/content/pdf...LQeA-3d-3d.pdf
(and is compatible with Mac OS X 10.8, after the firmware update)


You can do this probably via Bootcamp or newer versions of VMware Fusion.


No, firmware updates for such chips are normal. They can improve the performance on certain systems, which have buggy drivers. Hardware needs a official certification, Apples xHCI driver does not have a official certification, so i think the problem is Apples xHCI driver. Not the only driver which has problems.
i haven't looked at that firmware updater, but in the past i've had reasonable luck using one of those "ultimate boot CD" things with SATA hard drive firmware updaters. those almost always run in DOS mode.

i guess i'm just so used to USB2.0 "just working" that i was surprised by the need for a firmware update for a USB hub. but yeah, it's early enough days that i should not be surprised to see FW updates for USB3.0 hubs.
joeblough is offline   1 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Mac Peripherals

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:06 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC