Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 15, 2013, 06:06 PM   #1
jcmoney1010
macrumors newbie
 
Join Date: Sep 2007
Problems creating my own server

Alright, I'm working on some web design projects and I've been dissatisfied many of the free servers I have tried. I don't want to pay for a server service because most of the projects I'm working on are really just for learning purposes, as a result I decided to try and set up my own server with an old Macbook Air.

1.I went into my Sharing settings and turn on web sharing, then proceeded to turn on the firewall for extra security.

2.After this I went into my router(Arris) settings and enabled DMZ for that computer, which opened up port 80. I then set up port forwarding and port triggering

3.From here I went to No-IP.com and set up an account, where I signed up for a subdomain name and then added a host where I selected the DNS Host(A) option.

4. Lastly, I downloaded their client update manager and set it up to where it "should" work.

The issue though, is that when I type in the subdomain that I setup, it just says page cant be found. What am I missing, clearly there is a step i have overlooked. Is there anyone here who has dealt with no-ip.com, or at least know what I need to do to get this going?
jcmoney1010 is offline   0 Reply With Quote
Old Jul 15, 2013, 10:28 PM   #2
mwhities
macrumors 6502a
 
Join Date: Jul 2011
Location: Mississippi
Send a message via AIM to mwhities Send a message via MSN to mwhities
Can you open up a browse on this system and type: http://127.0.0.1 ?

If so, how about on a secondary system, type in the LAN IP of the system serving the webpage? Maybe: http://10.0.1.201 ?

If those work I'd check the port forwarding. Also, if they don't work, you don't have the web server configured correctly.

Good luck.
__________________
Late '11 MBP 17" - Blue Nano 8G - Black 4S 16G/64G - Black iPad2 16G - Black iPad mini 16G - 2TB TC
mwhities is offline   0 Reply With Quote
Old Jul 16, 2013, 05:09 PM   #3
jcmoney1010
Thread Starter
macrumors newbie
 
Join Date: Sep 2007
Quote:
Originally Posted by mwhities View Post
Can you open up a browse on this system and type: http://127.0.0.1 ?
Thanks for the reply, I tried this one first and it said page cannot be found. You think it's a misconfiguration of the web server?
jcmoney1010 is offline   0 Reply With Quote
Old Jul 16, 2013, 07:17 PM   #4
jcmoney1010
Thread Starter
macrumors newbie
 
Join Date: Sep 2007
So after some research I realized that port 443 needs to open as well, and mine is closed. I managed to do port forwarding for port 80 to open that up, but I can't seem to open port 443 in the same manor
jcmoney1010 is offline   0 Reply With Quote
Old Jul 19, 2013, 12:19 PM   #5
talmy
macrumors 68040
 
talmy's Avatar
 
Join Date: Oct 2009
Location: Oregon
Port 443 is for https. You shouldn't need that. In fact for what you are doing there is no need to do any port forwarding or dynamic DNS setup. You can access that computer by its name or IP address on your LAN. No need to go outside especially since ISPs don't allow running servers (unless you have a business account) and typically block port 80. If the MBA sees it's web server at http://127.0.0.1 you should be good to go.
__________________
27" i7 iMac, 15" MacBook Pro, Mac mini with Mavericks Server, 5 other Macs and an unused Apple TV.
talmy is online now   1 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X Server, Xserve, and Networking

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Geektool: Problems creating my first custom script kiercardo UI Customization 3 Feb 5, 2014 04:24 AM
Creating a server for my Mac ASKendrew Mac OS X Server, Xserve, and Networking 2 Oct 27, 2013 10:31 AM
Creating A Mac and Windows Net Server? WAM2 Mac Basics and Help 2 May 21, 2013 03:58 PM
Creating an updated OSX server install disc Yoursh Mac OS X Server, Xserve, and Networking 2 Mar 21, 2013 10:11 PM
Correct method for creating IPP printers to Mac server 10.8 djzolla OS X 10.8 Mountain Lion 1 Dec 3, 2012 04:40 PM

Forum Jump

All times are GMT -5. The time now is 11:17 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC