Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 15, 2013, 04:18 PM   #1
Brandon0448
macrumors regular
 
Join Date: Aug 2011
Location: Wasilla, Alaska
Music AirPlay Issues

I've been having issues with the audio AirPlay on my Apple TV2 for a looong time. Most of the time when i connect my iPhone 5/iPad 3/MBA to my Apple TV2 and start playing music it will start skipping. It will play a quarter of a second of sound then nothing for a second. Then another quarter second of sound then nothing and continue. But randomly sometimes when I try a different day it will work perfectly, very seldom does this happen though.

Well the weird thing is that it doesn't do this with anyone else's phones but mine. No matter what device I use! My roommate which is using my old iPhone 4(which I couldn't get to play music to my Apple TV when it was mine) can get music to play every time perfectly. Anyone that uses it always gets it to work the first time. I'll cycle through every single apply device I own and none work. Then someone else connects and it works the first time. It's like my Apple TV hates me.

It has always done this since I owned it. Music AirPlay was the main reason I bought my Apple TV and it has rarely ever worked for me... The only thing I can think of causing the problem across all of my devices is my apple ID. But I have no idea how that would effect something like this. I have even restored my iPhone, iPad, and Apple TV to new and nothing helped.
__________________
2011 13" Macbook Air i7 256g / iPhone 5 64GB / iPad 3 64GB / ATV2
Brandon0448 is offline   0 Reply With Quote
Old Apr 15, 2013, 05:25 PM   #2
ToddClemmer
macrumors newbie
 
Join Date: Apr 2013
Is your

AppleTV up to date? The current version is 5.2.1.
Router up to date with most current firmware?
What format is your music in?
ToddClemmer is offline   0 Reply With Quote
Old Apr 15, 2013, 07:15 PM   #3
Brandon0448
Thread Starter
macrumors regular
 
Join Date: Aug 2011
Location: Wasilla, Alaska
Quote:
Originally Posted by ToddClemmer View Post
Is your

AppleTV up to date? The current version is 5.2.1.
Router up to date with most current firmware?
What format is your music in?
I frequently update everything I own. I updated it and jailbroke it with my iPhone at 6.1.2, so I believe it is on 5.2. I've already read through the log of 5.2.1 and it has nothing to do with AirPlay so i know they didn't fix it in that update.

Before someone says that it is messing up because of the jailbreak I know it's not the problem because it has been doing this ever since I bought it years ago. Back then both my apple TV and iPhone were stock. Plus my girlfriend can stream music with her jailbroken iPhone just fine.

I mainly use Spotify to stream my music but I have tried .mp3's through the music app.

I have tried all the basic troubleshooting methods. Update and reupdate everything hoping something was missed. Mess with settings endlessly hoping something might work. Try new cords, try a different router and try a different audio receiver. Nothing seems to work, except of course just give up and use someone else's iPhone...
__________________
2011 13" Macbook Air i7 256g / iPhone 5 64GB / iPad 3 64GB / ATV2
Brandon0448 is offline   0 Reply With Quote
Old Apr 15, 2013, 11:06 PM   #4
waw74
macrumors 68020
 
Join Date: May 2008
Is it possible you have an unusual character in your device name, that is common to all your devices? like punctuation or a character with an accent?

download airfoil and see if that works.

google "airplay" and your router model, sometimes there are a few settings that can affect compatibility. (my router would reboot every time i tired to airplay to one airport express) doesn't explain other people devices working though.

do the other people connect to a guest network, or the same wireless network that you do.
waw74 is offline   0 Reply With Quote
Old Apr 16, 2013, 04:09 AM   #5
Brandon0448
Thread Starter
macrumors regular
 
Join Date: Aug 2011
Location: Wasilla, Alaska
Quote:
Originally Posted by waw74 View Post
Is it possible you have an unusual character in your device name, that is common to all your devices? like punctuation or a character with an accent?

download airfoil and see if that works.

google "airplay" and your router model, sometimes there are a few settings that can affect compatibility. (my router would reboot every time i tired to airplay to one airport express) doesn't explain other people devices working though.

do the other people connect to a guest network, or the same wireless network that you do.
No special characters, just Brandon's iPhone, iPad, Macbook.

I will try airfoil in a bit. What is weird with it is that I can stream videos just fine. Youtube seems to work every time, but music only works about 1/10 the time.

Everyone is connecting to the same network. I don't even have the guest mode enabled.

If my phone wasn't jailbroken I would restore it as new and not use anything from my old phone and see if that works. I tried a restore from new before but synced all my accounts and the such.
__________________
2011 13" Macbook Air i7 256g / iPhone 5 64GB / iPad 3 64GB / ATV2
Brandon0448 is offline   0 Reply With Quote
Old Apr 16, 2013, 05:51 AM   #6
slothrob
macrumors 6502
 
Join Date: Jun 2007
Quote:
Originally Posted by waw74 View Post
Is it possible you have an unusual character in your device name, that is common to all your devices? like punctuation or a character with an accent?
Quote:
Originally Posted by Brandon0448 View Post
No special characters, just Brandon's iPhone, iPad, Macbook.
I think he's saying that something like the apostrophe could cause problems.
slothrob is offline   0 Reply With Quote
Old Apr 16, 2013, 10:20 AM   #7
jlehman
macrumors member
 
Join Date: Apr 2013
Same

Pretty much same issue. I really think it has something to do with the AirPlay protocol. I'm going to double check for special characters. I first noticed the issue with my PC and Mac with iTunes dropping out here and there. Never had the issue with the iPhones or iPads. Now here and there i have the issue with them as well. One day it works fine. One day it doesn't. Wireless or Wired. I know everyone complains that "your router sucks" but I only have this issue with AirPlay.

Home Sharing Works fine. I can use the Remote app on the iPhone or iPad and Home Share my music and HD Movies (Handbraked from .mkv with 5.1) from PC and Mac and do not have any issues. I've tried different routers, different cables, different ways of hooking up the ATV, TV, and Receiver and some days or even weeks its fine. Then some days it drops out every 10 seconds. But never ever had an issue playing the exact song using Home Sharing.

The only thing I can conclude from all of this is the AirPlay Protocol is just temperamental and to just deal with it. If the songs i'm listening to are from Spotify and it starts skipping out i just plug my iPhone into the receivers Aux jack. If I own the music, i'll just use Home Sharing.

The main reason I like AirPlay on the PC and Mac is because you can have multiple audio outputs. I have Bose Companion 5's on the Mac ( don't worry i only paid $50 bucks for them) and a 5.1 system in the Living room and its nice to have both going at the same time. But like i said. I just deal with it. I've gone crazy trying to figure out why Home Sharing works, but AirPlay doesn't.
jlehman is offline   0 Reply With Quote
Old Apr 16, 2013, 08:10 PM   #8
Brandon0448
Thread Starter
macrumors regular
 
Join Date: Aug 2011
Location: Wasilla, Alaska
Quote:
Originally Posted by slothrob View Post
I think he's saying that something like the apostrophe could cause problems.
I tried removing the apostrophe and it didn't help. I'm currently sitting in my living room with my roommates streaming music to my apple TV. I will every once in a while try to connect and it will just skip.
__________________
2011 13" Macbook Air i7 256g / iPhone 5 64GB / iPad 3 64GB / ATV2
Brandon0448 is offline   0 Reply With Quote
Old Apr 18, 2013, 04:05 PM   #9
waw74
macrumors 68020
 
Join Date: May 2008
Quote:
Originally Posted by slothrob View Post
I think he's saying that something like the apostrophe could cause problems.
nope, apple puts the apostraphe in by default, was referring to something like or
i do not know of this being a problem, but was trying to think of something that only affected his devices, while others played fine.

"airplay video" and "airplay audio only" are 2 separate things, the audio only is using the airtunes protocol that's been around since the airport express came out.

Quote:
Originally Posted by jlehman View Post
I know everyone complains that "your router sucks" but I only have this issue with AirPlay.

Home Sharing Works fine.
...
Then some days it drops out every 10 seconds. But never ever had an issue playing the exact song using Home Sharing.
home sharing just sends the file to the remote location and plays it there. simple file sharing, so much easier on your network. airplay w/video uses pretty much the same thing.

as i said earlier,
Quote:
Originally Posted by waw74 View Post
google "airplay" and your router model, sometimes there are a few settings that can affect compatibility. (my router would reboot every time i tired to airplay to one airport express) doesn't explain other people devices working though.
the setting that did it for me was called WMM.

I've been using airplay (airtunes) since i got my first airport express, at least 6 years ago, i've had some problems here and there, and the problems were all caused by a third party router in the middle. and fixed by changing settings there.
waw74 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Airplay Issues Izzy2000 Apple TV and Home Theater 6 Dec 9, 2012 05:08 AM
Airplay issues Philpug Apple TV and Home Theater 5 Oct 4, 2012 09:13 PM
Airplay issues mac00l iOS 6 1 Sep 22, 2012 01:24 PM
Anyone had any new AirPlay issues with ML? steve-p Apple TV and Home Theater 3 Jul 28, 2012 04:11 PM
AirPlay Issues ugp OS X 10.8 Mountain Lion 0 Jul 25, 2012 08:27 PM

Forum Jump

All times are GMT -5. The time now is 06:40 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC