Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 19, 2013, 07:37 PM   #1
mrs1986
macrumors member
 
Join Date: Apr 2011
Location: Uruguay
Help with system folder...

Hi...

I was having problems with the wifi connection on my just purchased macbook air 2012...

I read a comment on Internet about deleting the systemconfiguration folder on preferences... But stupid enough I deleted the System/Lybrary/Systemconfiguration

Now my apps won't work and the wifi says no hardwareinstalled...

Please, can ssomeone be so kind of upload for me the folder?

The thing is, i can't reinstall the OS it says it would take days...
mrs1986 is offline   0 Reply With Quote
Old Apr 19, 2013, 08:17 PM   #2
gr8tfly
macrumors 603
 
gr8tfly's Avatar
 
Join Date: Oct 2006
Location: ~119W 34N
…and that's why it asks for admin authentication.

But, lesson learned.

I'm gonna guess no backup. Another hard lesson learned?
</end lecture>

Really, your only option is to re-install OS-X. It will install in-place; you won't have to erase the partition. But, you should still have a backup of at least your personal user files (images, video, docs, etc.) before starting this (I would backup your entire drive, even with the folder is missing). Restart on the Recovery Partition to do the installation (though it sounds like you did check that out).

It shouldn't take days, unless you're on a very slow connection. If you can get to an Apple Store, you can use their connection (or local copy). Make a Genius appointment and see if you can get some help. If nothing else, they should be able to let you use their fast connection.

Think about getting a drive to use for Time Machine. 1TB WD My Passport USB 3 drives are around $90 at Amazon (2.5" portable bus powered). Bought one myself last month to use for image backups (new rMBP) - it's a nice drive.
__________________
Macs from 1984 to 15" Retina MBP 768GB SSD 16GB RAM, from Newton to iPhone 5 S⃣ , iPods, and tv (3). 128GB Wifi iPad Air
gr8tfly is offline   0 Reply With Quote
Old Apr 19, 2013, 08:50 PM   #3
mrs1986
Thread Starter
macrumors member
 
Join Date: Apr 2011
Location: Uruguay
Hi...

My connection is fine, is not superase, but is 5mb or so... It shouldn't take more than a couple of hours...

All the problem started because the connection was slow... My others pc work just fine...

I don't have any data on it.. I bought it today...

And don't have a genius bar in uruguay...
mrs1986 is offline   0 Reply With Quote
Old Apr 19, 2013, 09:16 PM   #4
gr8tfly
macrumors 603
 
gr8tfly's Avatar
 
Join Date: Oct 2006
Location: ~119W 34N
Quote:
Originally Posted by mrs1986 View Post
Hi...

My connection is fine, is not superase, but is 5mb or so... It shouldn't take more than a couple of hours...

All the problem started because the connection was slow... My others pc work just fine...

I don't have any data on it.. I bought it today...

And don't have a genius bar in uruguay...
At least having a virtually clean install makes things easier - you don't have to worry about losing anything in the re-install.

When you get a clean install on it, come back and I'm sure someone will give you a hand with wifi problems (do a search of the forums first, though).
__________________
Macs from 1984 to 15" Retina MBP 768GB SSD 16GB RAM, from Newton to iPhone 5 S⃣ , iPods, and tv (3). 128GB Wifi iPad Air
gr8tfly is offline   0 Reply With Quote
Old Apr 19, 2013, 09:22 PM   #5
mrs1986
Thread Starter
macrumors member
 
Join Date: Apr 2011
Location: Uruguay
The thing is I doubt it will ever finish... It says more than 48 hours... My connection reset in 12 hours periods... Don't have a fix ip adress...

No one could give me the system/library/systemconfiguration folder to try out? Is a base 2012 air...

please...
mrs1986 is offline   0 Reply With Quote
Old Apr 20, 2013, 07:31 AM   #6
DisplacedMic
macrumors 65816
 
Join Date: May 2009
Quote:
Originally Posted by mrs1986 View Post
The thing is I doubt it will ever finish... It says more than 48 hours... My connection reset in 12 hours periods... Don't have a fix ip adress...

No one could give me the system/library/systemconfiguration folder to try out? Is a base 2012 air...

please...
i don't think deleting the Systemconfiguration folder is your problem - that should have been recreated when you rebooted the machine which i am assuming you did....?

i agree with gr8fly - a clean install is the way to go.

i'm not really understanding your problem - it was running slow so you deleted that folder (cleared trash and rebooting in the process?) and now it's not finding the hardware? do you have an option to turn on airport in the top right?

really, a fresh install or taking it back are your two best options here IMO.
Not really sure why a fresh install would "take days"
DisplacedMic is offline   0 Reply With Quote
Old Apr 20, 2013, 09:20 AM   #7
Weaselboy
macrumors G4
 
Weaselboy's Avatar
 
Join Date: Jan 2005
Quote:
Originally Posted by mrs1986 View Post
The thing is I doubt it will ever finish... It says more than 48 hours... My connection reset in 12 hours periods... Don't have a fix ip adress...

No one could give me the system/library/systemconfiguration folder to try out? Is a base 2012 air...

please...
Here is a ZIP of mine. I doubt this will work, but I guess it won't make things any worse at this point.
Weaselboy is offline   0 Reply With Quote
Old Apr 20, 2013, 10:47 AM   #8
mrs1986
Thread Starter
macrumors member
 
Join Date: Apr 2011
Location: Uruguay
Thanks you all for the answers, it finally finished and everything is smooth back again...

Systemconfiguration folder was the one on System/Library... And that seems to not regenerate as I thought...

Thanks again!!!
mrs1986 is offline   0 Reply With Quote
Old Apr 20, 2013, 03:13 PM   #9
gr8tfly
macrumors 603
 
gr8tfly's Avatar
 
Join Date: Oct 2006
Location: ~119W 34N
Quote:
Originally Posted by mrs1986 View Post
Thanks you all for the answers, it finally finished and everything is smooth back again...

Systemconfiguration folder was the one on System/Library... And that seems to not regenerate as I thought...

Thanks again!!!
Glad you're up and running again!

Enjoy!
__________________
Macs from 1984 to 15" Retina MBP 768GB SSD 16GB RAM, from Newton to iPhone 5 S⃣ , iPods, and tv (3). 128GB Wifi iPad Air
gr8tfly is offline   0 Reply With Quote
Old Apr 20, 2013, 03:56 PM   #10
mrs1986
Thread Starter
macrumors member
 
Join Date: Apr 2011
Location: Uruguay
Quote:
Originally Posted by gr8tfly View Post
Glad you're up and running again!

Enjoy!
Thanks!
mrs1986 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:55 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC