Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 29, 2012, 06:27 AM   #1
amalprasad
macrumors newbie
 
Join Date: Nov 2012
Unhappy iPhone 3GS restore error (-1)

My iPhone3gs was working fine with ios 5.1.1. After I upgraded to 6.0.1 it frequently going restore mode.2-3 times I sucessfully restored it but now this time seems no luck with me.I tried with DFU mode and restore with itunes.I will show the progress bar completing to 100%.But after waiting for 30-40 seconds a message pop up with error code (-1).Anybody can help me?I have no shsh blobs with me.How can I make cusom shsh blobs in restore mode.Now battery is also getting empty as red ring screen is always there.Can I make my iphone usable?I am going to be sick with this error code -1.Is there any use with redsnow?
amalprasad is offline   0 Reply With Quote
Old Nov 29, 2012, 06:46 AM   #2
luisadastwin
macrumors regular
 
Join Date: Oct 2010
Location: Moreira - Maia - Porto - Portugal - Europe
I got that error too, but then I tryed Redsn0w to do the restore and it worked!!!
__________________
Luis Moreira (Luisadas Twin)
Electrotechnical & Computer Eng.
iPhone 5 32Gb JB 6.1.2 / Win7@PentiumE6700
luisadastwin is offline   0 Reply With Quote
Old Nov 29, 2012, 06:54 AM   #3
Prawnstar69
macrumors regular
 
Join Date: Sep 2012
If your iphone was jailbroken on 5.1.1 your shsh blobs are saved .. Use tiny umbrella to get the shsh blobs and see YouTube videos on how to downgrade
Prawnstar69 is offline   0 Reply With Quote
Old Nov 29, 2012, 07:08 AM   #4
luisadastwin
macrumors regular
 
Join Date: Oct 2010
Location: Moreira - Maia - Porto - Portugal - Europe
You can also use Redsn0w to get remote SHSH Blobs with no worries. Don't even have to use TinyUmbrella.
__________________
Luis Moreira (Luisadas Twin)
Electrotechnical & Computer Eng.
iPhone 5 32Gb JB 6.1.2 / Win7@PentiumE6700
luisadastwin is offline   0 Reply With Quote
Old Nov 30, 2012, 10:58 AM   #5
amalprasad
Thread Starter
macrumors newbie
 
Join Date: Nov 2012
Unhappy

Yes I was able to create a ShSh Blob with redsnow.But no other use with redsnow.In select IPSW option when I select 5.0.1 IPSW (which I downloaded ) a message comes "That IPSW not supported by this version of Redsnow". Restore option also ended up with an error.
Is there any difference with DFU and pwned DFU?I am confused with this.

I am not able to use Tiny umbrella in my system because unable to start TSS server error.(Unable to stop PID4)

I think the battery is empty now because I see red ring on screenalways after charging for sometime it will change to apple logo and usb+itunes screen but only for a little time.Then again to red ring battery screen.

I am no more like iphone and planning to throw away this and go for an android phone.
amalprasad is offline   0 Reply With Quote
Old Nov 30, 2012, 11:12 AM   #6
luisadastwin
macrumors regular
 
Join Date: Oct 2010
Location: Moreira - Maia - Porto - Portugal - Europe
Some questions here:

1. How old is your battery? Because if it is older than 2 years, your description seems to me that it can be a faulty battery... and that's also an issue!

2. Have you tried to use "Recovery Fix" in RedSn0w? It can also be in a recovery loop! Does TinyUmbrella detect correctly you iPhone (with it's name one the left panel) or just a crazy number?

3. Have you safely turned off your phone? And do you know how to enter next in DFU mode?

4. About TinyUmbrella and TSS.... Have you killed the process with that PID? Use windows "task manager" to see what process has that PID and kill it (probably you'll have to show PID column in the process list). Example: you cannot have Teamviewer running when using TSS Server...
__________________
Luis Moreira (Luisadas Twin)
Electrotechnical & Computer Eng.
iPhone 5 32Gb JB 6.1.2 / Win7@PentiumE6700
luisadastwin is offline   0 Reply With Quote
Old Dec 1, 2012, 04:39 AM   #7
amalprasad
Thread Starter
macrumors newbie
 
Join Date: Nov 2012
Today when I tried a restore with itunes, restore completed successfully.I thought it is done.But iphone not restarting and showing empty battery screen.

Luis for ur questions:

1.I think battery is older than 2 years,but it was working fine until last restore.I bought this from ebay may be they give me a crap!

2. I have to try recovey fix after this.When I tried yesterday it was not working.

3.Slide to swith off option not coming as it was in recovery mode.I used to enter DFU mode as follows. Redsnow recognizing this as pwnedDFU mode.
---------------------------------------------------------------------
1.Connect your device to your computer.
2.Make sure iTunes is running and all necessary drivers are installed. During the following process ignore any messages from iTunes. There is no need to click on any messages that might appear.
3.Do a reset by pressing and holding both home and power buttons for several seconds.
4.As soon as it resets (screen goes black), immediately release both buttons.
5.Immediately press and hold the power button again.
6.Wait until you see the Apple logo plus one second longer.
7.Now press additionally the home button (still don't let go of the power button).
8.Wait until the screen disappears (gets black) plus one second longer.
9.Now release the power button, but keep pressing the home button.
10.Wait until you hear a "connected" sound from iTunes.
11.You should now be in DFU mode and your screen should be black. If you see the USB logo instead, try again.

-----------------------------------------------------------------------
4 Unable to kill PID4 as it is a system process pls see the attached picture.

Thank you ver much Luis for your supports.
amalprasad is offline   0 Reply With Quote
Old Dec 1, 2012, 07:45 AM   #8
janitor3
macrumors regular
 
Join Date: Aug 2010
Location: Glasgow, Scotland
Your original fault (-1) indicates a hardware fault. If your still having problems the phone may need serviced.

Good luck.
janitor3 is online now   0 Reply With Quote
Old Dec 1, 2012, 11:14 AM   #9
amalprasad
Thread Starter
macrumors newbie
 
Join Date: Nov 2012
Smile

Hi Thanks all
iphone is ok now after 1 weeks of my desparate tries.My umpteenth try to restore with itunes worked.After keeping sometime for charging it automatically restarted and then i did setup it as new iphone.Before when it went to restore mode two times after ios 6.0.1 updation, i took back up from icloud.I had so many application installed on it and I dont want to take the risk of any faulty application cause any malfunction.

there was a problem with my USB charger.I have to adjust it to a particular position in my laptops USB port then only it is charging.Otherwise it will show "charging is not supported with this accessory".But im sure restore error was not caused by USB cable problem because I also tried with another cable of my friend which is working properly.

Now my battery is full and green color.What a relief.

I dont know if apple has done any updation regarding this error -1.
This time there was a message from itunes that there is a new version available but i didn't update it.I hope iphone will stay like this forever with out any further restore mode.

Now I will make sure to take a IPSW and shsh blob backup,and I will appreciate if somebody can give me a better advice on that.
amalprasad is offline   0 Reply With Quote
Old Dec 1, 2012, 11:24 AM   #10
luisadastwin
macrumors regular
 
Join Date: Oct 2010
Location: Moreira - Maia - Porto - Portugal - Europe
Great!

I was going to say that you had a faulty battery, a faulty USB cable or a faulty DOCK contector assembly!

Remember that the batteries bought on eBay are really crap (I am on my 5th battery now!!!!!). They just break from one moment to another!

About SHSH blobs, just use Tiny Umbrella to save them! It's all automatic.
__________________
Luis Moreira (Luisadas Twin)
Electrotechnical & Computer Eng.
iPhone 5 32Gb JB 6.1.2 / Win7@PentiumE6700
luisadastwin is offline   0 Reply With Quote
Old Dec 1, 2012, 11:37 AM   #11
amalprasad
Thread Starter
macrumors newbie
 
Join Date: Nov 2012
I even had no time to back up it again lost wifi and cellular connetion and again a message came to restore.What the hell is this?
amalprasad is offline   0 Reply With Quote
Old Dec 1, 2012, 03:33 PM   #12
luisadastwin
macrumors regular
 
Join Date: Oct 2010
Location: Moreira - Maia - Porto - Portugal - Europe
It is asking you to restore again?

Have you installed Cydia yet with redsn0w? (using just the jailbreak option)
__________________
Luis Moreira (Luisadas Twin)
Electrotechnical & Computer Eng.
iPhone 5 32Gb JB 6.1.2 / Win7@PentiumE6700
luisadastwin is offline   0 Reply With Quote
Old Dec 1, 2012, 10:24 PM   #13
amalprasad
Thread Starter
macrumors newbie
 
Join Date: Nov 2012
not yet jail broken and not installed cydia.Should I try that?
amalprasad is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone can't restore (error 36) iPhone2684 iOS 7 1 Jan 5, 2014 12:28 AM
[FIXED] iPhone 3GS stuck in pwned DFU - Restore error 1600 guideo iPhone Tips, Help and Troubleshooting 2 Oct 5, 2013 03:40 PM
Iphone 3gs, stuck in recovery mode, cannot restore because of "Error -1" Iphonesareprone iPhone Tips, Help and Troubleshooting 1 Apr 25, 2013 11:24 PM
iPhone 4s Restore Error (-1) avi95nagpal iPhone 2 Feb 1, 2013 10:49 PM
iPhone: iPhone 3GS itunes can not restore error -1 BDog21 Jailbreaks and iOS Hacks 3 Jan 28, 2013 04:41 AM

Forum Jump

All times are GMT -5. The time now is 03:59 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC