Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 7, 2012, 04:31 PM   #1
medi.freak
macrumors regular
 
Join Date: May 2011
Unhappy iPhone 4 acting really weird...

Lately my iPhone 4 has been acting strange. When I press the 'on' button (the one at the top) the iPhone sometimes does't react, and when I press it again it only flashes the unlock screen and goes back to black. Then, when I press it again everything is normal. Sometimes it doesn't do the black screen, but something else that is unusual is that the flash that comes on the 'unlock' word looks like it is fast forwarded at first and the goes back to being normal (I don't know how to explain this one). Also, when I unlock it (after I typed my pin) it has a black screen only for a short period of time (like half a second) and then it is normal again. That stuff all usually happens when the phone has been in "sleep" mode for a certain period of time. So when it behaved like this it won't do it again unless I let it "sleep" for like 15 or 20 minutes.
I did do a reset yesterday and it is still exactly the same as it was before. It is already a phone that I got from the Apple Store as an exchange for a phone that had problems with the Home Button. What do you guys think I should do? Go to the Apple Store because of it? I just bought Apple Care for the phone, so it is under warranty.....Do you think it is a software issue? It seems like one to me, but with a software issue you don't get a new phone, as a replacement right? Any other ideas except for resetting it? Thanks for he help!
medi.freak is offline   0 Reply With Quote
Old Feb 7, 2012, 04:48 PM   #2
DerekRod
macrumors Demi-God
 
Join Date: Jan 2012
Location: NYC
If its under warranty go right to a genius PROBLEM solved haha
DerekRod is offline   0 Reply With Quote
Old Feb 7, 2012, 05:23 PM   #3
medi.freak
Thread Starter
macrumors regular
 
Join Date: May 2011
do you think it is something that will be gone with a new phone. Meaning: Would replacing it actually help, or is it something with the software (Apps, or similar). Because otherwise I'm quite happy with the phone =) (No actually NEED to replace it. There is just that annoyance factor...) What would you do?
medi.freak is offline   0 Reply With Quote
Old Feb 7, 2012, 05:25 PM   #4
Alaerian
Guest
 
Join Date: Jan 2005
Location: A barstool, Innis & Gunn in hand
It's fine. You're overreacting.
Alaerian is offline   0 Reply With Quote
Old Feb 7, 2012, 05:33 PM   #5
medi.freak
Thread Starter
macrumors regular
 
Join Date: May 2011
I do that sometimes. And need people to tell me exactly that =) Thanks Alaerian
medi.freak is offline   0 Reply With Quote
Old Feb 7, 2012, 05:33 PM   #6
cynics
macrumors 603
 
cynics's Avatar
 
Join Date: Jan 2012
Mine 4s has done something similar. I think it lags a little so pressing power you no reaction so you press it again. Now the screen lights up for the first press then back off for the second.

I've also had the slider not slide yesterday. Like it would start to move but slow down, almost like it was programmed to **** with me. Lol

Both events have only happened 3-4 times together.
__________________
27" iMac (late 2013), iPad 3, iPhone 4S, Apple TV (3rd Gen), Airport Extreme (6th Gen), assorted Android and Windows devices
cynics is online now   0 Reply With Quote
Old Feb 7, 2012, 05:34 PM   #7
Alaerian
Guest
 
Join Date: Jan 2005
Location: A barstool, Innis & Gunn in hand
Just bookmark that post. Then it's there whenever you need it.
Alaerian is offline   0 Reply With Quote
Old Feb 7, 2012, 08:06 PM   #8
AlexJaye
macrumors regular
 
Join Date: Jul 2010
Location: Texas
Quote:
Originally Posted by cynics View Post
Mine 4s has done something similar. I think it lags a little so pressing power you no reaction so you press it again. Now the screen lights up for the first press then back off for the second.

I've also had the slider not slide yesterday. Like it would start to move but slow down, almost like it was programmed to **** with me. Lol

Both events have only happened 3-4 times together.
Mine has done the same thing! When it won't respond as I try to slide it, putting it to sleep & waking it up again fixes it. It's weird and new to iOS 5.
__________________
Bette Davis, we love you.
AlexJaye is offline   0 Reply With Quote
Old Feb 7, 2012, 08:25 PM   #9
PNutts
macrumors 601
 
PNutts's Avatar
 
Join Date: Jul 2008
Location: Pacific Northwest, US
Do you have it in a case? The symptoms are similar to when I had an Otterbox silicone case stretch out and interfere with the proximity sensor.
PNutts is offline   0 Reply With Quote
Old Feb 8, 2012, 12:00 AM   #10
maliu
macrumors 6502
 
Join Date: Jun 2010
Try pressing the home button instead the "on" button.
maliu is online now   0 Reply With Quote
Old Feb 8, 2012, 05:49 AM   #11
barryl85
macrumors regular
 
Join Date: Jul 2010
iPhone 4 here and mine does this very frequently and its not in any kind of case, and I use the on/off button to check the time when pulling it out my pocket as its the top of the phone comes out first.

Sometimes i press the on/off button to wake the screen and it just stays black and does nothing until I press it, i've tested it as it happens frequently and can be 20secs + until i press it again and i get the screen flash on and off then I have to press it again for it to function.

I've also had the slider not sliding and also the phone not vibrating when toggling the silent switch (that one only fixes itself after the phone is switched on and off).


All of these issues have been apparent since iOS5.

It seems like the phone is slowing down with every update too and I have plenty free space, restored the phone, reset the phone, uninstalled apps, reinstalled apps, just seems to be software related.

Oh and my home button is showing signs of malfunction as it sometimes doesn't function when pressed and I have seen myself having to press it a few times just for it to work, other times it works perfect.
barryl85 is offline   1 Reply With Quote
Old Jan 18, 2013, 05:09 PM   #12
Tinhat
macrumors newbie
 
Join Date: Jan 2013
Hi - I have this exact problem too with the random wake lag and black screenshot on iPhone 4 16gb, ios 5.0.1. Did anyone work out a fix?

Last edited by Tinhat; Jan 18, 2013 at 05:09 PM. Reason: Typo
Tinhat is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone's touch screen acting weird when charging Baconstripss iPhone 0 Mar 30, 2014 12:59 AM
Iphone 5 battery acting weird. what to do? bhigh8 iPhone 1 Dec 18, 2013 10:09 AM
iPhone 5 acting weird! phil87 iPhone 2 Sep 8, 2013 02:10 PM
iPhone 5 acting really weird jshin100 iPhone 5 Apr 26, 2013 05:13 PM
iPhone has been acting weird since visiting a website anonjd iPhone 8 Jan 1, 2013 04:12 PM

Forum Jump

All times are GMT -5. The time now is 02:58 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC