Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 31, 2010, 08:29 PM   #1
maxmaxsmith
macrumors newbie
 
Join Date: Aug 2010
PM G5 2.7GHz goes into overdrive, no chime

I've had this G5 (2.7GHz, 1.5GB Apple RAM) since around February or March and for quite some time it made two clicking sounds and that was it. Today at around 6:40 I was just about to go pick up another G5 also a 2.7GHz for parts to replace the power supply. Right before I left, I plugged my Mac in one last time and poof, it turned on. I couldn't believe it, right before I went to replace it the G5 came back almost as if to say "not so fast".

Now what's happening when I press the power button is:
fans spin up, then slow down to normal speed
hard drive spins up
no chime
front LED only comes on when it is pressed
red LED on one of the processors
after approx. five minutes fans speed up and after ten minutes they are at terminal velocity
will not communicate with any peripherals
only way to turn it off is pressing the CUDA or pulling the plug

Things tried:
CUDA reset
cold start

Some more info on the machine:
RAM is tested and good
DVD-RW is good
all fans run
I don't have the original disks
I don't have a monitor for it (since it never worked)

Any help would be greatly appreciated, as my iMac is really showing its age and finances are tight.

Thanks!
maxmaxsmith is offline   0 Reply With Quote
Old Aug 31, 2010, 09:01 PM   #2
raysfan81
macrumors 6502a
 
raysfan81's Avatar
 
Join Date: Oct 2009
Location: North Carolina
Quote:
Originally Posted by maxmaxsmith View Post
I've had this G5 (2.7GHz, 1.5GB Apple RAM) since around February or March and for quite some time it made two clicking sounds and that was it. Today at around 6:40 I was just about to go pick up another G5 also a 2.7GHz for parts to replace the power supply. Right before I left, I plugged my Mac in one last time and poof, it turned on. I couldn't believe it, right before I went to replace it the G5 came back almost as if to say "not so fast".

Now what's happening when I press the power button is:
fans spin up, then slow down to normal speed
hard drive spins up
no chime
front LED only comes on when it is pressed
red LED on one of the processors
after approx. five minutes fans speed up and after ten minutes they are at terminal velocity
!
The dual 2.7's were liquid cooled and were infamous for leaking. Sometimes a leaking system can cause the fans to run at full speed. When you are looking around in the case make sure you don't see any liquid or corrosion near the processors. Also, make completely sure all the sticks of ram are working (try them one at a time if necessary) good luck!
__________________
Broken Ipod Touch 1st gen 16gb & Zune HD 64gb
eMac 1.42 ghz,80gb hd & 500mhz Snow iMac g3, 2ghz Unibody MB
400 mhz G4 "Sawtooth", Dual 1.42 ghz MDD, 17" 1.83 ghz C2D iMac
raysfan81 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
IPhone 5S Line in Jack distorion / overdrive elmariachi5150 iPhone 0 Oct 23, 2013 01:49 AM
Well OCD is on overdrive, clicking sound on iPhone 5 screen Krissypantz2828 iPhone 14 Sep 19, 2013 05:03 AM
MacBook Air Noise Like Fan in Overdrive ryan101 MacBook Air 3 Mar 14, 2013 06:20 AM
Logitech Trackman Marble FX & USB Overdrive software personas Mac Peripherals 0 Sep 7, 2012 07:25 PM
USB Overdrive Update 3.0.2 Kiki61 Mac and PC Games 1 Aug 20, 2012 12:02 AM

Forum Jump

All times are GMT -5. The time now is 08:15 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC