Audio/Video syncing (audio lag) issues over Airplay for you guys? - MacRumors Forums
Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 2, 2010, 11:16 PM   #1
erinh
macrumors newbie
 
Join Date: Sep 2010
Audio/Video syncing (audio lag) issues over Airplay for you guys?

So, I've ripped a couple DVDs to m4v format via handbrake. Same ol', Same ol'...

Drop them into iTunes and allow it to stream video off their stored location on external HDD.
Video and audio sync up just fine when playing directly on the imac, but when playing over the new atv setup, the audio lags a bit.

I'm not sure if this isn't just my reciever or not, as the audio from the atv goes into my receiver and the video goes to the TV, thus possibly creating a differential. So, before I go getting wound up over this, I'm curious if anyone else here has noticed any audio lag when watching video?

I've not had any issues when watching some TV shows, but it's done it to two movies so far. My wife says it doesn't bother her, but it drives me batty. I feel like I'm watching an old Jackie Chan (English dubbed) movie.
I'm wondering if it's just not something in handbrake, though, the fact that it works fine on the imac itself kind of rules that possibility out.
erinh is offline   0 Reply With Quote
Old Oct 3, 2010, 12:40 AM   #2
Jim82
macrumors member
 
Join Date: Jun 2007
Location: Seattle
Send a message via AIM to Jim82 Send a message via Yahoo to Jim82
Quote:
Originally Posted by erinh View Post
So, I've ripped a couple DVDs to m4v format via handbrake. Same ol', Same ol'...

Drop them into iTunes and allow it to stream video off their stored location on external HDD.
Video and audio sync up just fine when playing directly on the imac, but when playing over the new atv setup, the audio lags a bit.

I'm not sure if this isn't just my reciever or not, as the audio from the atv goes into my receiver and the video goes to the TV, thus possibly creating a differential. So, before I go getting wound up over this, I'm curious if anyone else here has noticed any audio lag when watching video?

I've not had any issues when watching some TV shows, but it's done it to two movies so far. My wife says it doesn't bother her, but it drives me batty. I feel like I'm watching an old Jackie Chan (English dubbed) movie.
I'm wondering if it's just not something in handbrake, though, the fact that it works fine on the imac itself kind of rules that possibility out.


While I haven't had the problem with videos I do have the problem with simple audio files of music. There is probably a half second lag between the music playing on my MBP in my bedroom and the ATV in my living room. Drives me crazy. Hopefully a near future update fixes the problem.
__________________
Unibody Macbook 2.4, 8Gb, 320GB HD, "New iPad", iPod 80gig, iPod Nano 16, iPhone 5 slate-32gb
Jim82 is offline   0 Reply With Quote
Old Dec 9, 2010, 12:43 AM   #3
dvdsmth
macrumors newbie
 
Join Date: Dec 2010
airplay lag

I've got the same thing. TV (ATV attached) and stereo (MacBook attached) are, as you say, a fraction of a second apart. Too much - unusable unless you close a door between the rooms, which is inconvenient.

I'm assuming the lag doesn't change, so hopefully there's a way to write something to slow it down in tiny increments at one end.
dvdsmth is offline   0 Reply With Quote
Old Dec 9, 2010, 01:55 AM   #4
KeithJenner
macrumors 6502a
 
Join Date: Sep 2010
Quote:
Originally Posted by dvdsmth View Post
I'm assuming the lag doesn't change, so hopefully there's a way to write something to slow it down in tiny increments at one end.
I hope it isn't slowed down as mine are so perfectly in sync that, when testing it I had to put my ear quite close to each speaker to confirm that they were all on.

I haven't seen any previous posts on this so I suspect it is an issue with your setups or something, rather than an Apple TV bug.
KeithJenner is offline   0 Reply With Quote
Old Dec 9, 2010, 04:05 AM   #5
dvdsmth
macrumors newbie
 
Join Date: Dec 2010
My problem's probably got something to do with the fact that one system is usb connected and the other is air connected.

What I - and the other guy - need is something to introduce a lag as needed - tweakable.

The problem of multiple rooms being out of sync is, I believe, a not uncommon problem these days with audio setups. You're lucky not to experience it.
dvdsmth is offline   0 Reply With Quote
Old Dec 9, 2010, 04:48 AM   #6
KeithJenner
macrumors 6502a
 
Join Date: Sep 2010
Quote:
Originally Posted by dvdsmth View Post
The problem of multiple rooms being out of sync is, I believe, a not uncommon problem these days with audio setups. You're lucky not to experience it.
Yes, I was very sceptical about how well Airplay would sync multiple devices but it does seem to be extremely good.

In a case like yours, an adjustment would be handy, but I suspect that Apple would just say that you should connect everything by HDMI or audio out and it should sync. I wouldn't hold your breath for a fix.
KeithJenner is offline   0 Reply With Quote
Old Jun 4, 2011, 06:31 PM   #7
tslewis
macrumors member
 
Join Date: Oct 2008
Quote:
Originally Posted by Jim82 View Post
While I haven't had the problem with videos I do have the problem with simple audio files of music. There is probably a half second lag between the music playing on my MBP in my bedroom and the ATV in my living room. Drives me crazy. Hopefully a near future update fixes the problem.
ive still got the same problem. Has anyone found a fix?
tslewis is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
audio and video lag both offline and online jiclo MacBook Pro 0 Jan 14, 2014 10:31 PM
Audio issues with AirPlay & Netflix (ATV3) KeegM480 Apple TV and Home Theater 6 Jan 13, 2014 07:36 PM
Apple dev's say there is NO issues with UI lag/Audio glitching on rMBP/ML peejack OS X 10.8 Mountain Lion 2 Feb 22, 2013 11:32 AM
iPad: Video app only streaming audio over airplay, everyone else airplay wise works great. shenfrey iPad 11 Feb 10, 2013 12:51 PM
ATV3 AirPlay Mirroring - Video, no audio sdilley14 Apple TV and Home Theater 8 Sep 24, 2012 05:55 PM

Forum Jump

All times are GMT -5. The time now is 07:38 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC