Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 4, 2010, 12:27 PM   #1
knucles
macrumors regular
 
Join Date: Aug 2006
Location: Portugal
Imac g4 boot problems - Solved + Pic

Hi, i am a new wave mac lover (2006) and a couple of months ago i bought a used imac g4 simply to sit and look at me at my bedroom.

But the imac sometimes boots, sometimes don't, and the light of the screen turns on and nothing happens...... It is a g4 800mhz with 750mb of ram any ideas ? faulty hdd?

It came with tiger 4.11 pre-installed, should i format it ?

Very stange sounds as soon as i hit the power button and no chime....

Last edited by knucles; Oct 9, 2010 at 06:02 PM.
knucles is offline   0 Reply With Quote
Old Oct 4, 2010, 03:22 PM   #2
knucles
Thread Starter
macrumors regular
 
Join Date: Aug 2006
Location: Portugal
I noticed that when the computer is cold i can boot but it can not restart nor start after shut down.

Can this be due to a faulty battery?

I need some help here guys...
knucles is offline   0 Reply With Quote
Old Oct 4, 2010, 03:24 PM   #3
Intell
macrumors G5
 
Intell's Avatar
 
Join Date: Jan 2010
Location: Inside
If it only boots when it is cold, then it may be having overheating problems. If you are good with computers, you can try opening it to clean it out. Just remember, if you open it, you must replace the thermal paste on the contact points between the two halves.
__________________
Last edited by Intell; Yesterday at 10:24 AM.
Intell is offline   0 Reply With Quote
Old Oct 4, 2010, 05:40 PM   #4
raysfan81
macrumors 6502a
 
raysfan81's Avatar
 
Join Date: Oct 2009
Location: North Carolina
Quote:
Originally Posted by Intell View Post
If it only boots when it is cold, then it may be having overheating problems. If you are good with computers, you can try opening it to clean it out. Just remember, if you open it, you must replace the thermal paste on the contact points between the two halves.
Its always good to clean out the insides of any computer to prevent overheating. As you can see in the post by machamster the insides of the iMac G4 can get quite dusty. http://forums.macrumors.com/showthre...4#post11104644
__________________
Broken Ipod Touch 1st gen 16gb & Zune HD 64gb
eMac 1.42 ghz,80gb hd & 500mhz Snow iMac g3, 2ghz Unibody MB
400 mhz G4 "Sawtooth", Dual 1.42 ghz MDD, 17" 1.83 ghz C2D iMac
raysfan81 is offline   0 Reply With Quote
Old Oct 8, 2010, 08:54 AM   #5
knucles
Thread Starter
macrumors regular
 
Join Date: Aug 2006
Location: Portugal
Quote:
Its always good to clean out the insides of any computer to prevent overheating. As you can see in the post by machamster the insides of the iMac G4 can get quite dusty. http://forums.macrumors.com/showthre...4#post11104644

So i opened it and cleaned it nice, changed the internal battery and nothing.......

Sometimes it boots, sometimes it doesn't, it's a very moody imac, any ideas?

Reformat? Faulty hard drive?

The weird thing is that when it boots works nicely and everything is as fast as any g4......

ideas?
knucles is offline   0 Reply With Quote
Old Oct 8, 2010, 04:02 PM   #6
666sheep
macrumors 68030
 
666sheep's Avatar
 
Join Date: Dec 2009
Location: Poland
I've had one of them (1.0 GHz one) with similar issue. From cold start it booted without probs. It worked fine until I wanted to restart it. I had toforce shut down it. After some time (when it got cooled) it booted normally. I've found the culprit later, it was physically damaged coil (see picture). One of them had broken cover (inside is scrolled copper wire).



Examine your logic board for any visual damages then (coils, capacitors). Second what comes to my mind is dying PSU.
666sheep is offline   0 Reply With Quote
Old Oct 9, 2010, 02:29 PM   #7
knucles
Thread Starter
macrumors regular
 
Join Date: Aug 2006
Location: Portugal
It is working .............for now....

IT turned on!!!!!!!!!!!! i tried the shift key when i was pushing the power button and it turned on in safe mode

Now i am afraid of turning it off..... should i do something?

Usually when it boots like this as soon as i restart it gets moody and stop working, should i fresh install tiger now?
knucles is offline   0 Reply With Quote
Old Oct 9, 2010, 03:19 PM   #8
themaccoder
macrumors newbie
 
Join Date: Jun 2010
Location: Louisiana
Send a message via Skype™ to themaccoder
Quote:
Originally Posted by knucles View Post
IT turned on!!!!!!!!!!!! i tried the shift key when i was pushing the power button and it turned on in safe mode

Now i am afraid of turning it off..... should i do something?

Usually when it boots like this as soon as i restart it gets moody and stop working, should i fresh install tiger now?
A fresh install might help
__________________
I am a Mac son, recognize
themaccoder is offline   0 Reply With Quote
Old Oct 9, 2010, 06:00 PM   #9
knucles
Thread Starter
macrumors regular
 
Join Date: Aug 2006
Location: Portugal
Good new- problem solved

IT works!!!!!!!

After trying to boot like 40 times i managed to do it and inserted the install disk, ereased it - partition - fresh install.....

After the new fresh install everything is working, tested it with several restarts and shut downs. everything working fine, after a week of cleaning and troubleshooting my "new" imac g4 i am finally happy with this classic

knucles is offline   0 Reply With Quote
Old Oct 10, 2010, 04:44 AM   #10
VanneDC
macrumors 6502a
 
Join Date: Jun 2010
Location: Dubai, UAE
Freaking sweet bro. Congrats on the solve job.

Btw, looks like Midnight Oil in the background, but I know it ain't...
__________________
2008 Mac Pro 3,1
2.8Ghz V8/12GB/GTX470/8800GT/SSD
Wacom Cintiq 21UX 1x24" Sony PS3 3D display.
VanneDC is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
iMac G4 Advice MBP13 Buying Tips and Advice 10 May 5, 2011 02:49 AM
iMac G4 Upgrade Question Cuba46 iMac 3 Feb 2, 2011 02:01 PM
Updated to 10.6.4 - iMac won't boot. symmetry OS X 0 Nov 21, 2010 07:07 PM
Imac g4 boot problems knucles iMac 0 Oct 4, 2010 12:39 PM


All times are GMT -5. The time now is 12:11 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC