Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 8, 2010, 09:24 AM   #1
poe8
macrumors member
 
Join Date: Apr 2010
ATV2 Slow Accessing my iTunes library

I have a pretty speedy wifi network, but the atv seems to be taking forever to access any content in my library. It says "accessing" for a good 15 seconds Plus between pages. How long should this take, I thought it would be nearly instant.
poe8 is offline   0 Reply With Quote
Old Oct 8, 2010, 10:14 AM   #2
DJinTX
macrumors 6502
 
Join Date: Sep 2010
When I go into computers and select my iTunes library, it will say Accessing or Loading xxxxx's Library, and give me the spinning gear for about 5-7 seconds I would say. This is with about 2,500 songs, and 1000 photos, one music video, and 3 episodes of Heroes. I haven't decided if I want to take the time to handbrake my DVDs yet, so my library is much smaller than most. So, it is possible it may be related to how large your library is. Although, if your library is similar in size to mine, then maybe something else is going on.

I will also add that when trying to watch Movie Trailers and Podcasts on my ATV, it does spin alot longer than it does directly on my mac. Movie trailers start nearly instantly in Front Row on both my MacBook and my wife's iMac (both wireless). I hope that Apple fixes this. If our Macs can start streaming near-instantly, then so should the ATV. I know it's a new unit, and so Apple will just have to put in time to squash a few bugs. Hopefully it will all be working like a well-oiled machine soon.
DJinTX is offline   0 Reply With Quote
Old Oct 8, 2010, 12:34 PM   #3
poe8
Thread Starter
macrumors member
 
Join Date: Apr 2010
Cool

Quote:
Originally Posted by DJinTX View Post
When I go into computers and select my iTunes library, it will say Accessing or Loading xxxxx's Library, and give me the spinning gear for about 5-7 seconds I would say. This is with about 2,500 songs, and 1000 photos, one music video, and 3 episodes of Heroes. I haven't decided if I want to take the time to handbrake my DVDs yet, so my library is much smaller than most. So, it is possible it may be related to how large your library is. Although, if your library is similar in size to mine, then maybe something else is going on.

I will also add that when trying to watch Movie Trailers and Podcasts on my ATV, it does spin alot longer than it does directly on my mac. Movie trailers start nearly instantly in Front Row on both my MacBook and my wife's iMac (both wireless). I hope that Apple fixes this. If our Macs can start streaming near-instantly, then so should the ATV. I know it's a new unit, and so Apple will just have to put in time to squash a few bugs. Hopefully it will all be working like a well-oiled machine soon.
It may be around the same 7-8 seconds as yours between menus, but that still seems like a long time. Im not actually streaming video, just trying to browse my iTunes library. I ended the night just giving up on it, was taking way too long to just get into my artist list. I have about the same content volume you do, which doesn't seem nearly as large as some I've seen. Maybe if both or one were hardwired it would speed things up, but that was clearly not the intent of this.
poe8 is offline   0 Reply With Quote
Old Oct 8, 2010, 12:40 PM   #4
DJinTX
macrumors 6502
 
Join Date: Sep 2010
Just to clarify, the 5-7 seconds is just the initial wait when I click on my library. Once I get in, I don't believe there is much lag, but I haven't really played with it much yet. If I see anything helpful over the weekend I will post back and let you know.
DJinTX is offline   0 Reply With Quote
Old Oct 8, 2010, 01:02 PM   #5
techguy40
macrumors regular
 
Join Date: Mar 2008
Everything was working well for a week.

Now today when I goto my library on the new apple tv , it just says loading my library message and nothing happens. Just the spinning wheel.

I wait and wait but it doesn't show my library. I have home sharing on my itunes and apple tv 2 on.

I try turning both off and turn them on again and still get the loading my library message with spinning wheel.



Update: I did a hard reset and everything works now. I can goto my library.

Very weird.

Last edited by techguy40; Oct 8, 2010 at 01:09 PM.
techguy40 is offline   0 Reply With Quote
Old Oct 8, 2010, 01:34 PM   #6
NEBaghead
macrumors member
 
Join Date: Oct 2009
Location: Omaha, NE
Send a message via Skype™ to NEBaghead
Restarting iTunes will help too. Also, make sure you have the latest version of iTunes installed.
__________________
|21.5" iMac, i5 2.5ghz QC Ghz 12GB|13" MBP 2.26GHZ 4GB -160GB SSD|
|White 16gb iPhone 4s|TV2|iPad 2 16gb White|
NEBaghead is offline   0 Reply With Quote
Old Oct 8, 2010, 06:14 PM   #7
DJinTX
macrumors 6502
 
Join Date: Sep 2010
So I have played with my ATV a bit, and can give more precise info.

The first time I accessed my library, it took about 5-7 seconds to load, but now that it has been done once it seems pretty instant. Likewise, the first time i went into music, and tv shows and photos (and other subcategories) it also took about 5-7 seconds on the first try, but each time i go in now it seems instant.

I think on this initial access it has to cache some info. I tried sleeping the ATV and then going back in, but it still seems instant when i move between menus. I'm not sure how long tis lasts or how often it might want to re-cache.

I then watched a movie trailer to add data to the buffer, then went back into my iTunes library accessing all the subcategries and all still seems instant.
DJinTX is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Help with ATV2 and accessing hard drive using Airport Extreme? thorpey0 Apple TV and Home Theater 21 Sep 15, 2014 05:28 PM
iTunes 10 Library has suddenly become very slow and buggy...corrupted? ryanstewart Mac Applications and Mac App Store 0 Feb 11, 2013 11:39 AM
Moving iTunes library from PC to NAS then accessing Music on NAS from new MAC dtos01 Mac Applications and Mac App Store 3 Aug 13, 2012 09:41 PM

Forum Jump

All times are GMT -5. The time now is 10:08 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC