Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 14, 2010, 11:23 AM   #1
mezameyo
macrumors newbie
 
Join Date: Oct 2010
Location: Ithaca, NY
Question iMac G5 input audio dead + weirdness

My iMac G5 (10.5.8) is acting very strange lately.

For some reason it will not recognize any sources of audio input. In the Sound pref pane, the "internal microphone" option under the Input tab is not even there anymore. Only line-in. In addition, when I check input levels with an external (USB) mic, I get zilch. Otherwise, this same mic works without a hitch on a G4 Powerbook.

Since this is happening on two very different hardware channels, I gather it must be a software issue.

However, there are other indications that something odd is happening. I reset the PRAM to try to get the audio input back. It didn't work. Instead, I lost audio output as well. Since then, every time I start up the machine, it sits with a dark screen for a long time before eventually booting up, and it seems entirely random as to whether or not audio output is working. Literally, I start up once and it works, the next time it doesn't, and the next time it does again.

PLUS, a couple of times it did not recognize USB peripheries, including an Apple mouse, an iPod touch, and a flash drive. Once, I had the flash drive and the iPod plugged in at the same time, and the machine wasn't seeing either one, but when I removed the flash drive the machine immediately recognized the iPod.

So this makes me think there is a hardware (PRAM?) issue after all.

I am thoroughly flummoxed. Anyone have something a bit closer to a clue than I have?
mezameyo is offline   0 Reply With Quote
Old Oct 14, 2010, 11:49 AM   #2
XaPHER
macrumors member
 
Join Date: Oct 2010
Location: In the Underworld
corrupted prefs ?
XaPHER is offline   0 Reply With Quote
Old Oct 14, 2010, 03:21 PM   #3
mezameyo
Thread Starter
macrumors newbie
 
Join Date: Oct 2010
Location: Ithaca, NY
Re: Prefs

Hi XaPHER, that one had escaped me -- thanks for the suggestion. I tried deleting all the audio prefs I could find in both the system and user libraries, but unfortunately it didn't help.

Also ran Cocktail and fixed permissions on the drive. That didn't help either.

Any other suggestions? I'm on the verge of giving up audio input for dead.
mezameyo is offline   0 Reply With Quote
Old Oct 14, 2010, 04:01 PM   #4
XaPHER
macrumors member
 
Join Date: Oct 2010
Location: In the Underworld
Do you have any FireWire device?If yes, try installing a system on it. If you're able to boot from this one, verify if the audio and the usb devices works. If everything is working, the problem is in your system. Otherwise, i think the problem could be on the motherboard.
XaPHER is offline   0 Reply With Quote
Old Oct 14, 2010, 07:27 PM   #5
mezameyo
Thread Starter
macrumors newbie
 
Join Date: Oct 2010
Location: Ithaca, NY
Re: external startup

XaPHER, another great idea! I did what you suggested, starting from my cloned backup drive. (It was cloned before the problems started, so that shouldn't be an issue.) Still had the same problems.

So, perhaps this is some kind of audio processing chip on the motherboard? That's the only hardware explanation I can think of that would deal with input channels from two different sources. Not sure if the USB issues are related or not.
mezameyo is offline   0 Reply With Quote
Old Oct 14, 2010, 09:11 PM   #6
XaPHER
macrumors member
 
Join Date: Oct 2010
Location: In the Underworld
Well, i don't know if the audio in board is integrated on the motherboard for the isight model.
XaPHER is offline   0 Reply With Quote
Old Oct 16, 2010, 11:40 AM   #7
mezameyo
Thread Starter
macrumors newbie
 
Join Date: Oct 2010
Location: Ithaca, NY
Thumbs up fixed!

XaPHER, just to follow up -- so, I tried using Audio MIDI Setup to configure audio input, and that worked. I've now got all my audio input channels back. Frankly, I have no clue why this would work, but it did.

Cheers!
mezameyo is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPad Mini audio input help rexone iPad Tips, Help and Troubleshooting 5 Mar 27, 2014 02:20 AM
How do I change audio output to input? abhithegreat MacBook Pro 2 Jul 27, 2013 04:07 PM
New iMac...where is audio input rjpcbean iMac 25 Mar 25, 2013 05:52 PM
How to use the audio jack on my 2012 MBP as audio/mic input? blaake MacBook Pro 4 Feb 9, 2013 04:16 PM
Audio Input Alternatives MegaSignal Digital Audio 0 Jan 13, 2013 08:29 PM

Forum Jump

All times are GMT -5. The time now is 11:38 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC