Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 3, 2010, 09:53 PM   #1
redsockeye
macrumors newbie
 
Join Date: Nov 2010
Unhappy Internal hard drive not recognized, not even in disk utility

Hi,
I have a 2009 13 inch macbook pro with 2.4 ghz processor, 4 gb ram, all stock from apple. Machine has been working great until 2 days ago when my system froze, had to push the power off button, tried to reboot but got the flashing folder and the internal hard drive was no longer recognized. I did all the usual things and read the apple support page to no avail. I booted from the install CD and the drive is not recognized in disk utility.

I took the drive out, put it in an external case and booted from there and the drive appears to be working. I put in another internal drive, a Hitachi 500 GB/7200 RPM that looks mac compatible, disc utility will not even recognize it either with the external hard drive OS running or from the install CD. In system profiler, under hardware, it says this computer doesn't contain any ATA drives. Any thoughts?

Could this be a problem with the SATA cable internally? The rest of the logic board appears to be working as I am typing this on the affected machine running the OS from my former internal hard drive that is now in a casing.

Last edited by redsockeye; Nov 3, 2010 at 10:02 PM.
redsockeye is offline   0 Reply With Quote
Old Nov 3, 2010, 10:26 PM   #2
alust2013
macrumors 68040
 
alust2013's Avatar
 
Join Date: Feb 2010
Location: On the fence
In system profiler check Serial - ATA drives rather than ATA. You should at least see your SuperDrive.
__________________
a computer with some GHz and a few GB, some stuff to play music.
-witty comment here-
alust2013 is offline   0 Reply With Quote
Old Nov 4, 2010, 12:05 AM   #3
kfscoll
macrumors 6502a
 
Join Date: Nov 2009
Funny you should mention this...my mid-2009 15" MBP just recently stopped seeing my HDD, even in Disk Utility and even when booting to the Snow Leopard install disc. I tried swapping drives to no avail, and took it to the Genuis Bar, where the Genius agreed with my supposition that it was either a bad SATA cable or a bad logic board. It turned out to be a bad cable, so it's definitely possible (and even likely) that that's your problem.
__________________
Late '13 nMP (6-core / 512GB SSD / D700 / 32GB RAM) Mid '12 15" 2.7GHz i7 rMBP iPad Air 128GB+AT&T LTE iPhone 5s 64GB iPod classic 160GB iPod nano 7G 16GB
kfscoll is offline   0 Reply With Quote
Old Nov 4, 2010, 03:43 PM   #4
redsockeye
Thread Starter
macrumors newbie
 
Join Date: Nov 2010
thanks for your replies, alust2013 - good point, the s-ata did show the superdrive, but was missing the HD. kfscoll, now it is working intermittently. I think it must be a bad cable, unless I was unlucky enough to have 2 (a brand new and 1.5 year old) bad drives, which seems unlikely.
redsockeye is offline   0 Reply With Quote
Old Nov 4, 2010, 03:44 PM   #5
dukebound85
macrumors P6
 
dukebound85's Avatar
 
Join Date: Jul 2005
Location: 5045 feet above sea level
i had that happen and it was a faulty drive. Bought a new one and was good to go

The one that died was like 6months old and never made any death click noises but just dead.
dukebound85 is offline   0 Reply With Quote
Old Nov 30, 2010, 09:47 PM   #6
redsockeye
Thread Starter
macrumors newbie
 
Join Date: Nov 2010
Well, I ended up buying a SATA cable for my mid-2009 macbook off ebay. It completely fixed the problem! I guess there are some bad cables in that batch.
redsockeye is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Disk Utility Restore to backup internal boot drive to a disk image? nagromme Mac OS X 10.7 Lion 0 Nov 1, 2013 12:10 PM
Disk utility stuck in unmounting internal drive ZillaG OS X 2 Aug 22, 2013 02:39 PM
Old Story...but new to me. Failed hard drive in target disk mode not recognized. LizardLizard Mac Basics and Help 6 Jul 26, 2013 09:41 AM
Disk utility will not see internal drive. roontoon MacBook Pro 7 Jul 5, 2013 05:01 PM
Trying to clone hard drive, but new internal hard drive not recognized seeweed Mac Basics and Help 10 Feb 3, 2013 05:38 PM

Forum Jump

All times are GMT -5. The time now is 01:29 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC