Go Back   MacRumors Forums > Apple Systems and Services > Programming > Mac Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 24, 2010, 04:34 PM   #1
blue-lion
macrumors member
 
Join Date: Jan 2010
problems with xcode debugger

hello, i've just started programming in objective c and I'm having problems with the debugger. in xcode Even when debugging a simple program the debugger jumps to the end of the code without waiting for me to step through the code. I'm sure it's only a setting somewhere (which look ok to me??), i just don't see it. can anybody help?
blue-lion is offline   0 Reply With Quote
Old Nov 24, 2010, 04:36 PM   #2
robbieduncan
Moderator
 
robbieduncan's Avatar
 
Join Date: Jul 2002
Location: London
Did you set a breakpoint? Did you read the Debugging Guide?
robbieduncan is offline   0 Reply With Quote
Old Nov 24, 2010, 05:32 PM   #3
blue-lion
Thread Starter
macrumors member
 
Join Date: Jan 2010
debugging problems

i have had a quick look through the guide.
So.. do i have to set a breakpoint somewhere in the code?. On other debuggers i just stepped into the code and then just stepped through it..

The 'step over' option is 'grayed out ' on the debugger . Is this because it's finished debugging and already gone through the code without pausing anywhere?
blue-lion is offline   0 Reply With Quote
Old Nov 24, 2010, 05:39 PM   #4
robbieduncan
Moderator
 
robbieduncan's Avatar
 
Join Date: Jul 2002
Location: London
Don't have "a quick look through". Read it. It will tell you the answers.
robbieduncan is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > Mac Programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Property doesn't show up in XCode debugger multinode Mac Programming 1 Jun 23, 2013 08:47 AM
PHP debugger 3heap Mac Applications and Mac App Store 0 Oct 25, 2012 10:28 AM
Problems switching views iOS & xcode Lonewolff iPhone/iPad Programming 2 Aug 27, 2012 09:04 AM
Problems with linking to Boost dylibs in Xcode TastyCocoa Mac Programming 2 Aug 17, 2012 04:58 AM
Xcode 4.5 problems - breakpoints I don't want and libc++abi.dylib uncaught exception moonman239 iPhone/iPad Programming 1 Jun 20, 2012 02:09 PM

Forum Jump

All times are GMT -5. The time now is 05:42 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps